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Dieser Artikel enthält eine Lösung für einen Fehler, der auftritt, wenn Sie eine E-Mail in Microsoft Dynamics 365 für Outlook nachverfolgen.
Gilt für: Microsoft Dynamics 365
Ursprüngliche KB-Nummer: 4010462
Symptome
Wenn Sie versuchen, eine E-Mail in Dynamics 365 für Outlook nachzuverfolgen, wird die folgende Fehlermeldung angezeigt:
"Der angegebene Schlüssel war im Wörterbuch nicht vorhanden."
Wenn Sie Details auswählen, werden die folgenden anderen Details angezeigt:
"Der angegebene Schlüssel war im Wörterbuch nicht vorhanden.
at System.Collections.Generic.Dictionary2.get_item(Tkey key)
at Microsoft.Crm.Application.SMWrappers.AttachmentForOutlook.Get... clientOrganizationContext, IDynamicEntityCollectionForOutlook dynamicEntityCollectionAttachments)
atMicrosoft.Crm.ApplicationSMWrappers.EmailForOutlook.Microsoft.... messageld, String subject, String from, String to, String cc, String bcc, Double receivedon, String submittedby, String importance, String body, IDynamicEntityCollectionForOutlook attachments, Int32 attachmentCount, IDynamicEntityForOutlook extraProperties, String entityXml, String regardingId, Int64 regardingObjectType, String crmId, Int32& notification)
Ursache
Dieser Fehler kann für eine der folgenden Bedingungen auftreten:
- Die E-Mail enthält eine Anlage, die größer als die in Dynamics 365 zulässige Größe ist.
- Die E-Mail enthält eine Anlage mit einer Dateierweiterung, die von Dynamics 365 blockiert wird.
Beschluss
Entschließung 1
Wenn die E-Mail eine Anlage enthält, die über dem Größenlimit liegt, entfernen Sie entweder die Anlage, oder erhöhen Sie die Größe von Anlagen, die in Dynamics 365 zulässig sind. Die standardmäßige maximale Größe beträgt 5 MB.
Wenn Sie über die Rolle "Systemadministrator" in Dynamics 365 verfügen, können Sie diese Einstellung anzeigen und ändern, indem Sie zu "Einstellungen", " Verwaltung" navigieren und dann " Systemeinstellungen" auswählen. Wählen Sie die Registerkarte " E-Mail " aus, und suchen Sie die Einstellung für die maximale Dateigröße (in Kilobyte) unter dem Grenzwert für die Dateigröße für Anlagen festlegen.
Auflösung 2
Wenn die E-Mail eine Anlage mit einer Erweiterung enthält, die von Dynamics 365 blockiert wird, entfernen Sie entweder die Anlage, oder ändern Sie, welche Dateierweiterung von Dynamics 365 blockiert wird.
Wenn Sie über die Rolle "Systemadministrator" in Dynamics 365 verfügen, können Sie diese Einstellung anzeigen und ändern, indem Sie zu "Einstellungen", " Verwaltung" navigieren und dann " Systemeinstellungen" auswählen. Suchen Sie auf der Registerkarte " Allgemein " die Einstellung " Blockierte Dateierweiterungen für Anlagen festlegen".