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Dieser Artikel enthält eine Lösung für das Problem, das ein asynchroner Workflow große Mengen von Systemaufträgen und Protokollen erstellt.
Gilt für: Microsoft Dynamics 365
Ursprüngliche KB-Nummer: 4562256
Symptome
Ein asynchroner Workflow wird schnell über einen kurzen Zeitraum aufgerufen, der eine große Anzahl von Systemaufträgen generiert. Dadurch wird der asynchrone Dienst belastet, was zu einem Anstieg im Rückstand führt, was zu Leistungseinbußen führt, die sich letztendlich auf alle Systemaufträge auswirken. Dies führt auch zu einer Erhöhung der Datenbankgröße aufgrund der großen Anzahl asynchroner Vorgänge und zugeordneter Workflowprotokolle.
Ursache
Wenn ein asynchroner Workflow aktiviert und ausgelöst wird, werden neue Aufträge von Microsoft Dynamics 365 asynchroner Dienst in die Warteschlange gestellt und basierend auf verfügbaren Ressourcen verarbeitet.
Unter bestimmten Umständen kann ein asynchroner Workflow mehrmals aufgerufen werden, sodass in kurzer Zeit eine große Anzahl von Systemaufträgen erstellt wird. Dies geschieht entweder aufgrund eines Massenvorgangs, der den Workflow aggressiv auslöst, oder aufgrund fehlerhafter Logik innerhalb eines anderen Workflows und/oder Plug-Ins, das ihn mit hoher Häufigkeit aufruft.
Die Ressourcen, die für den asynchronen Dienst verfügbar sind, sind begrenzt, und wenn der Backlog durch einen solchen entgleisten Workflow gefüllt wird, ist eine Leistungsbeeinträchtigung, die sich allgemein auf alle Systemaufträge auswirkt, häufig. Darüber hinaus wird die Datenbankgröße aufgrund der großen Anzahl von Aufträgen, die in einem solchen Szenario generiert wurden, ebenfalls erhöht.
Beschluss
In solchen Fällen ist die asynchrone Workflowinfrastruktur in der Lage, sich zu einem bestimmten Grad selbst zu heilen, nachdem der identifizierte Workflow deaktiviert wurde. Schritte zur Erreichung dieser Schritte sind unten aufgeführt:
- Navigieren Sie zu Einstellungen>Prozesse, und wählen Sie den relevanten Workflow aus. Alternativ können Sie den Workflow mit Advanced Findsuchen.
- Wählen Sie Deaktivieren aus, um den Workflow zu deaktivieren und auf den Status "Entwurf" festzulegen. Optional, wenn nicht benötigt, können Sie den Workflow an diesem Punkt auch löschen.
Nachdem die oben genannten Schritte ausgeführt wurden, werden keine neuen Aufträge mehr erstellt. Darüber hinaus werden alle Aufträge, die bereits erstellt und vor der Deaktivierung in der asynchronen Warteschlange platziert wurden, , aber noch nicht zur Verarbeitung aufgenommen wurden, sofort abgebrochen, wenn sie zur Verarbeitung aufgenommen werden. Dadurch wird der asynchrone Backlog schneller abgebaut.
Die verbleibenden Aufträge, die bereits In Bearbeitung sind, bleiben davon unberührt und werden wie erwartet abgeschlossen. Der Backlog wird sich im Laufe der Zeit stetig abbauen, um zu normalen Niveaus zurückzukehren.