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Fehlercode: @WAX:ReleasedQtyCannotBeNegative
Symptome
Wenn Sie versuchen, eine Ladezeile zu aktualisieren oder zu löschen, wird die folgende Fehlermeldung angezeigt:
Die freigegebene Menge kann nicht negativ für die Artikel-ID<>, Lot Lot <ID>, sein.
Ursache
Nachdem Sie eine Ladelinie aktualisiert oder gelöscht haben, aktualisiert das System die freigegebene Menge der zugehörigen Vertriebslinie (whsSalesLine.ReleaseQty). Wenn das System feststellt, dass die freigegebene Menge nach dem Update negativ wird, verhindert es, dass Sie die Änderung vornehmen. Diese Überprüfung erfolgt immer dann, wenn Sie versuchen, entweder die Lastleitungsmenge oder die Maßeinheit durch verschiedene Aktionen zu aktualisieren, z. B. das Löschen einer Ladelinie, das Löschen einer Sendung, das Ändern der Menge einer Ladelinie, die Reduzierung der ausgewählten Menge und die kurze Auswahl.
Der häufigste Grund für dieses Problem ist eine Änderung der Einheitenkonvertierung, die für offene Ladelinien verwendet wird. Die Einheitenumwandlung beträgt beispielsweise 50 Ea = 1 PL , wenn ein Verkaufsauftrag freigegeben wird. Wenn die Einheitenumwandlung jedoch in 100 Ea = 1 PL geändert wird, bevor die zugehörige Ladung abgeschlossen ist, kann dies zu diesem Problem führen.
Lösung
Um dieses Problem zu beheben, führen Sie die folgenden Schritte aus, um die Komponentenkonvertierungsänderungen wiederhergestellt, die Ladelinie zu aktualisieren oder zu löschen, und implementieren Sie dann die Konvertierung erneut.
Wichtig
Sie müssen verhindern, dass andere Lasten, die das Element enthalten, das dazu führte, dass das Problem verarbeitet wird, bis das Problem behoben wurde. Andernfalls können die neuen Konvertierungen für andere bereits geöffnete Lasten verwendet werden.
- Überprüfen Sie die Einheitenkonvertierung, die für die Ladelinie verwendet wurde.
- Überprüfen Sie die aktuelle Einheitenkonvertierung für das Element, und nehmen Sie Anpassungen vor, mit denen die Ladeposition aktualisiert oder gelöscht werden kann.
- Aktualisieren oder löschen Sie die Ladelinie, und stellen Sie die Einheitenkonvertierungsanpassungen zurück.
Überprüfen der Einheitenkonvertierung, die für die Ladelinie verwendet wurde
Führen Sie die folgenden Schritte aus, um Ihre Ladelinien zu überprüfen und die Für die Ladelinie verwendete Einheitenkonvertierung zu notieren:
- Wechseln Sie zu "Lagerverwaltung>lädt>alle Lasten".
- Wählen Sie die Last aus, die die Ladelinie enthält, die nicht gelöscht oder aktualisiert werden kann.
- Wählen Sie im Aktionsbereich auf der Registerkarte "Laden" in der Gruppe "Verwandte Informationen" die Option "Arbeit" aus.
- Wählen Sie im oberen Raster die relevante Arbeits-ID aus.
- Berechnen Sie auf der Registerkarte "Allgemein " unten auf der Seite die Konvertierungsrate zwischen dem Wert " Lagerarbeitsmenge " und dem Wert " Arbeitsmenge ". Notieren Sie sich den Satz.
- Wiederholen Sie dieses Verfahren für alle relevanten Arbeits-IDs, um sicherzustellen, dass dieselbe Konvertierung verwendet wurde.
Überprüfen der aktuellen Einheitenkonvertierung für das Element und Vornehmen von Anpassungen
Führen Sie die folgenden Schritte aus, um die Einheitenkonvertierung Ihres Produkts zu überprüfen und Anpassungen vorzunehmen, um sicherzustellen, dass die Einheitenkonvertierung an der Ladelinie ausgerichtet ist:
- Gehen Sie zu Produktinformationsverwaltung>Produkte>Veröffentlichte Produkte.
- Öffnen Sie das relevante Produkt, um zur Seite mit den veröffentlichten Produktdetails zu wechseln.
- Klicken Sie im Aktivitätsbereich auf der Registerkarte Produkt in der Gruppe Einrichten auf Einheitenumrechnung.
- Wählen Sie die Konvertierung zwischen den Einheiten aus, und nehmen Sie Anpassungen mithilfe der Konvertierung vor, die Sie im vorherigen Abschnitt gefunden haben.
Aktualisieren oder Löschen der Ladelinie und Zurücksetzen der Einheitenumwandlungsanpassungen
Führen Sie die folgenden Schritte aus, um die Ladelinie nach Bedarf zu verarbeiten und die Einheitenumwandlungen wie folgt zurückzuverwenden:
- Wechseln Sie zu "Lagerverwaltung>lädt>alle Lasten".
- Öffnen Sie die Last, die die Ladelinie enthält, die nicht gelöscht oder aktualisiert werden kann.
- Wählen Sie in der FastTab-Datei " Lastzeilen " die Ladelinie aus, und fahren Sie mit den erforderlichen Aktionen fort (z. B. löschen Sie die Ladelinie, oder ändern Sie die Menge).
- Gehen Sie zu Produktinformationsverwaltung>Produkte>Veröffentlichte Produkte.
- Öffnen Sie das relevante Produkt, um zur Seite mit den veröffentlichten Produktdetails zu wechseln.
- Klicken Sie im Aktivitätsbereich auf der Registerkarte Produkt in der Gruppe Einrichten auf Einheitenumrechnung.
- Wählen Sie die Konvertierung zwischen den Einheiten aus, und stellen Sie die Anpassungen zurück, die Sie im vorherigen Abschnitt vorgenommen haben.
Alternative Auflösung
Wenn das Wiederherstellen von Einheitenumwandlungen nicht machbar ist, führen Sie die folgenden Schritte aus, um WHSSalesLine.ReleasedQty (die Verkaufslinie, die Menge veröffentlicht) und WHSSalesLine.QtyLeftToLoad (die Verkaufslinienmenge, die noch nicht geladen ist) manuell zu aktualisieren:
- Wechseln Sie zu "Debitorenaufträge>>alle Bestellungen".
- Öffnen Sie den Verkaufsauftrag, der die Vertriebslinie enthält, die sich auf die Last bezieht, in der die Zeile nicht gelöscht oder aktualisiert werden kann.
- Wählen Sie oben rechts im Raster "Verkaufsauftragspositionen " die drei Punkte aus, und wählen Sie im Dropdownmenü "Spalten einfügen" aus.
- Suchen Sie nach der veröffentlichten Menge und der Menge, um Felder zu laden, wählen Sie beide aus, und wählen Sie dann "Aktualisieren" aus.
Die Felder werden im Raster " Verkaufsauftragspositionen " angezeigt und können so geändert werden, dass sie die Mengen in den Ladelinien widerspiegeln.
Weitere Informationen
Zusätzliche Vertriebszeilenfelder in WorksheetLine(WHSSalesLine)