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Fehler "Die Verarbeitung Ihrer vorherigen Buchungssitzung auf Transaktionsebene wurde nicht abgeschlossen" beim Öffnen des Fensters "Sales Transaction Entry" in der Auftragsverarbeitung

Dieser Artikel enthält eine Lösung für den Verarbeitungsfehler Ihre vorherige Buchungssitzung auf Transaktionsebene wurde nicht abgeschlossen , der auftreten kann, wenn Sie versuchen, das Fenster Sales Transaction Entry in Sales Order Processing in Microsoft Dynamics GP oder in Microsoft Business Solutions – Great Plains zu öffnen.

Gilt für: Microsoft Dynamics GP
Ursprüngliche KB-Nummer: 852623

Symptome

Möglicherweise erhalten Sie die folgende Fehlermeldung, wenn Sie versuchen, das Fenster Sales Transaction Entry in Sales Order Processing in Microsoft Dynamics GP oder in Microsoft Business Solutions – Great Plains zu öffnen:

Ihre vorherige Buchungssitzung auf Transaktionsebene wurde nicht abgeschlossen. Bitte lassen Sie zeit, bis der Vorgang abgeschlossen ist. Wenn Sie glauben, dass ein Fehler aufgetreten ist, melden Sie sich bei Great Plains ab, und melden Sie sich wieder an, um Transaktionen wiederherzustellen.

Hinweis

Um das Fenster Sales Transaction Entry zu öffnen, wählen Sie Transaktionen aus, zeigen Sie auf Sales, und wählen Sie dann Sales Transaction Entry aus.

Ursache

Dieses Problem kann auftreten, wenn Datensätze in der SY00500 Tabelle, in der SY00800-Tabelle oder in der SOP10100-Tabelle gesperrt sind. Datensätze haben eine batchnummer, die leer ist, oder die Benutzer-ID wird als Batchnummer aufgeführt.

Lösung

Gehen Sie wie folgt vor, um das Problem zu beheben:

  1. Alle Benutzer müssen Microsoft Dynamics GP beenden.

  2. Erstellen Sie eine Sicherung der Unternehmensdatenbank.

  3. Führen Sie in SQL Query Analyzer die folgende delete-Anweisung für die SY00800 Tabelle für die DYNAMICS-Datenbank aus.

    DELETE SY00800
    
  4. Suchen Sie nach den Problemdatensätzen in der SY00500 Tabelle, indem Sie die beiden folgenden Anweisungen für die Unternehmensdatenbank ausführen.

    Hinweis

    In den folgenden Anweisungen stellt xxx die Benutzer-ID dar, die den Fehler enthält.

    SELECT * from SY00500 where BACHNUMB = ''
    SELECT * from SY00500 where BACHNUMB = 'xxx'
    
  5. Wenn Datensätze mit einem leeren BACHNUMB-Feld zurückgegeben werden, verwenden Sie die folgende delete-Anweisung.

    DELETE SY00500 where BACHNUMB = ''
    
  6. Wenn Sie Über Datensätze verfügen, die mit einer Benutzer-ID im Feld BACHNUMB zurückgegeben werden, verwenden Sie die folgende delete-Anweisung.

    Hinweis

    In der folgenden Anweisung stellt xxx die Benutzer-ID dar, die den Fehler enthält.

    DELETE SY00500 where BACHNUMB ='xxx'
    
  7. Vergewissern Sie sich, dass Sie vorhandene Dokumente im Fenster Sales Transaction Entry auswählen können. Um dieses Fenster zu öffnen, wählen Sie Transaktionen aus, zeigen Sie auf Sales, und wählen Sie dann Sales Transaction Entry aus. Wenn Sie ein vorhandenes Dokument löschen möchten, wählen Sie Löschen aus. Wenn Sie ein vorhandenes Dokument für ungültig erklären möchten, wählen Sie Void aus.

  8. Wenn Sie weiterhin die Fehlermeldung erhalten oder die vorhandenen Dokumente im Fenster Sales Transaction Entry nicht auswählen können, führen Sie die folgenden Skripts in SQL Query Analyzer für die Unternehmensdatenbank aus, um Problemdatensätze in der SOP10100 Tabelle zu suchen.

    Hinweis

    In den folgenden Skripts stellt xxx die Benutzer-ID dar, die den Fehler enthält.

    SELECT BACHNUMB,* from SOP10100 where BACHNUMB = '' SELECT BACHNUMB,* from SOP10100 where BACHNUMB = '<xxx>'
    SELECT * FROM SOP10200 where SOPNUMBE in (SELECT SOPNUMBE from SOP10100 where BACHNUMB = 'xxx')
    SELECT * FROM SOP10200 where SOPNUMBE in (SELECT SOPNUMBE from SOP10100 where BACHNUMB = ' ')
    SELECT * FROM SOP10102 where SOPNUMBE in (SELECT SOPNUMBE from SOP10100 where BACHNUMB = 'xxx')
    SELECT * FROM SOP10102 where SOPNUMBE in (SELECT SOPNUMBE from SOP10100 where BACHNUMB = ' ')
    
  9. Notieren Sie sich alle zurückgegebenen Datensätze, und führen Sie dann die folgende Anweisung in SQL Query Analyzer aus, um die Problemdatensätze aus der SOP10100 Tabelle zu löschen.

    Hinweis

    • Sie müssen überprüfen, ob die Transaktionen im Modul Bestand und in den Debitorenverwaltungsmodulen gebucht werden. Wenn die Transaktionen nicht im Modul Bestand und im Modul Debitorenverwaltung bereitgestellt wurden, müssen Sie die Transaktionen im Fenster Sales Transaction Entry erneut eingeben, nachdem Sie die Löschanweisungen ausgeführt haben.
    • In den folgenden Anweisungen stellt xxx die Benutzer-ID dar, die den Fehler enthält.
    DELETE SOP10200 where SOPNUMBE in (SELECT SOPNUMBE from SOP10100 where BACHNUMB = 'xxx')
    DELETE SOP10200 where SOPNUMBE in (SELECT SOPNUMBE from SOP10100 where BACHNUMB = ' ')
    DELETE SOP10102 where SOPNUMBE in (SELECT SOPNUMBE from SOP10100 where BACHNUMB = 'xxx')
    DELETE SOP10102 where SOPNUMBE in (SELECT SOPNUMBE from SOP10100 where BACHNUMB = ' ')
    DELETE SOP10100 where BACHNUMB = '' DELETE SOP10100 where BACHNUMB = 'xxx'
    
  10. Zeigen Sie in Microsoft Dynamics GP im Menü Microsoft Dynamics GP auf Wartung , und wählen Sie dann Links überprüfen aus.

  11. Wählen Sie in der Liste Seriedie Option Sales aus, und führen Sie dann die Prozedur zum Überprüfen von Links für die Tabellengruppe Sales Work aus.

  12. Wenn die Transaktionen nicht im Modul Debitorenverwaltung und im Modul Bestand bereitgestellt wurden, geben Sie die Transaktionen im Fenster Sales Transaction Entry erneut ein.