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Dieser Artikel enthält eine Lösung für ein Problem, bei dem der Installationsprozess für eConnect unter Microsoft Dynamics GP fehlschlägt, wenn Sie eConnect auf einem Arbeitsgruppencomputer installieren, der auf einen SQL-Server auf einem anderen Computer in einer Domäne verweist.
Gilt für: Microsoft Dynamics GP
Ursprüngliche KB-Nummer: 2534520
Problembeschreibung
Der Installationsprozess für eConnect unter Microsoft Dynamics GP schlägt fehl, wenn Sie eConnect auf einem Arbeitsgruppencomputer installieren, der auf einen SQL-Server auf einem anderen Computer in einer Domäne verweist. In dieser Umgebung wird die folgende Fehlermeldung angezeigt:
Benutzer zu SQL können nicht hinzugefügt werden.
Ursache
Der Installationsprozess erfordert, dass das eConnect-Dienstkonto ein Windows-Benutzer ist. Die Installation schlägt fehl, da der Benutzer, der sich beim Arbeitsgruppencomputer angemeldet hat, keinen Zugriff auf die Erstellung von SQL-Benutzern hat oder das Konto, das für das eConnect-Dienstkonto verwendet wird, nicht aufgelöst werden kann.
Lösung
Für den Installationsprozess muss sich der gewünschte Computer für die eConnect-Installation in einer Domäne befinden.
Mit den folgenden Schritten kann letztendlich der eConnect-Integrationsdienst verwendet werden, der auf einem Arbeitsgruppencomputer ausgeführt wird und der SQL Server auf einem anderen Computer in einer Domäne ausgeführt wird. Der Vorgang erfordert, dass das Installationsprogramm den eConnect-Computer mit der Domäne verknüpft, die Installation für eConnect auf dem gewünschten Computer ausführt und dann den Computer aus der Domäne entfernt, damit er wieder in einer Arbeitsgruppe enthalten ist.
Erstellen Sie ein Domänenkonto namens "eConnectService", das während der Installation für das eConnect-Dienstkonto verwendet wird.
Verbinden Sie den eConnect-Computer mit der Domäne, und führen Sie die eConnect-Installation aus. Während der Installation müssen Sie das Domänenkonto aus Schritt 1 für das eConnect-Dienstkonto verwenden.
Entfernen Sie nach Abschluss der Installation den eConnect-Computer aus der Domäne, und erstellen Sie dann ein lokales Benutzerkonto namens "eConnectService" mit demselben Kennwort, das für das Domänenkonto in Schritt 1 verwendet wird.
Führen Sie die hier aufgeführten Anweisungen an einer Eingabeaufforderung aus, um die URL-Reservierung für das lokale Konto aus Schritt 3 festzulegen:
Notiz
Sie erhalten "Der Parameter ist falsch" für alle syntaktischen Fehler (z. B. das Verlassen des nachgestellten Schrägstrichs).
netsh http delete urlacl url=http://+:80/Microsoft/Dynamics/GP/eConnect/
netsh http add urlacl user=computer_name\econnectService url=http://+:80/Microsoft/Dynamics/GP/eConnect/
Notiz
Ersetzen Sie "computer_name" durch den Computernamen des eConnect-Computers.
Erstellen Sie auf dem SQL Server ein lokales Benutzerkonto namens "eConnectService" mit demselben Kennwort für das Domänenkonto (und das lokale Benutzerkonto auf dem Arbeitsgruppencomputer). Stellen Sie sicher, dass dieses lokale Benutzerkonto (auf dem SQL Server) über eine SQL-Anmeldung verfügt und der DYNGRP-Rolle in den DYNAMICS- und Unternehmensdatenbanken hinzugefügt wird.
eConnect für Microsoft Dynamics GP sollte jetzt für die Verwendung auf dem Arbeitsgruppencomputer bereit sein.