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"Die gespeicherte Prozedur GLpBatchCleanup hat die folgenden Ergebnisse zurückgegeben: DBMS: 0, Dynamics: 20486" Fehlermeldung, wenn Sie einen Batch im Hauptbuch in Microsoft Dynamics GP posten

Dieser Artikel enthält eine Lösung für einen Fehler, der auftritt, wenn Sie einen Batch im Hauptbuch in Microsoft Dynamics GP bereitstellen.

Gilt für: Microsoft Dynamics GP
Ursprüngliche KB-Nummer: 860710

Symptome

Wenn Sie einen Batch im Hauptbuch in Microsoft Dynamics GP oder in Microsoft Business Solutions – Great Plains posten, erhalten Sie die folgende Fehlermeldung:

Die gespeicherte Prozedur glpBatchCleanup hat die folgenden Ergebnisse zurückgegeben: DBMS: 0, Dynamics: 20486

Wenn Sie "Weitere Informationen" auswählen, wird die folgende Fehlermeldung angezeigt:

glpBatchCleanup. Fehler beim Versuch, die Batch-Header zu aktualisieren

Ursache

Dieses Problem kann eine der folgenden Ursachen haben.

Ursache 1

Dieses Problem tritt auf, wenn das aktuelle Jahr, in das gebucht wird, als historisches Jahr markiert ist. Siehe Entschließung 1.

Ursache 2

Dieses Problem tritt auf, wenn in der SY00800 Tabelle oder in der SY00801 Tabelle ungültige Datensätze vorhanden sind. Siehe Entschließung 2.

Lösung 1

Zur Problemlösung ändern Sie die Einstellung für das historische Jahr. Gehen Sie dazu wie folgt vor:

  1. Zeigen Sie in Microsoft Dynamics GP auf Tools im Menü Microsoft Dynamics GP, zeigen Sie auf Setup, zeigen Sie auf Unternehmen, und wählen Sie dann Geschäftszeiträume aus.
  2. Deaktivieren Sie das Kontrollkästchen "Historisches Jahr", und wählen Sie dann Speichern aus.
  3. Zeigen Sie im Menü "Transaktionen" auf "Finanzen", und wählen Sie dann "Batches" aus.
  4. Posten Sie den Stapel.

Lösung 2

Um dieses Problem zu beheben, löschen Sie die Datensätze in der SY00800 Tabelle oder in der SY00801 Tabelle. Gehen Sie dazu wie folgt vor:

  1. Sichern Sie die Microsoft Dynamics GP-Unternehmensdatenbank.

  2. Sichern Sie die Dynamics-Datenbank.

  3. Lassen Sie alle Benutzer sich bei Microsoft Dynamics GP abmelden.

  4. Beenden Sie den Computer, auf dem Microsoft SQL Server ausgeführt wird, und starten Sie den Computer, um die temporären Tabellen zu löschen.

  5. Starten Sie SQL Server Management Studio. Verwenden Sie dazu den entsprechenden Schritt abhängig von dem programm, das Sie verwenden:

    • Wenn Sie SQL Server 2005 verwenden, starten Sie SQL Server Management Studio. Wählen Sie dazu "Start" aus, zeigen Sie auf "Alle Programme", zeigen Sie auf Microsoft SQL Server 2005, und wählen Sie dann SQL Server Management Studio aus.
    • Wenn Sie SQL Server 2008 verwenden, starten Sie SQL Server Management Studio. Wählen Sie dazu "Start" aus, zeigen Sie auf "Alle Programme", zeigen Sie auf Microsoft SQL Server 2008, und wählen Sie dann SQL Server Management Studio aus.
    • Wenn Sie SQL Server 2012 verwenden, starten Sie SQL Server Management Studio. Wählen Sie dazu "Start" aus, zeigen Sie auf "Alle Programme", zeigen Sie auf Microsoft SQL Server 2012, und wählen Sie dann SQL Server Management Studio aus.
  6. Wählen Sie die Dynamics-Datenbank aus. Verwenden Sie dann die folgenden Anweisungen, um alle Datensätze aus der TABELLE ACTIVITY, der SY00800 Tabelle und der SY00801 Tabelle zu löschen:

    DELETE DYNAMICS..ACTIVITY 
    DELETE DYNAMICS..SY00800 
    DELETE DYNAMICS..SY00801
    
  7. Wählen Sie die TEMPDB-Datenbank aus. Verwenden Sie dann die folgenden Anweisungen, um alle Datensätze aus der DEX_LOCK Tabelle und der DEX_SESSION Tabelle zu löschen:

    DELETE TEMPDB..DEX_LOCK
    DELETE TEMPDB..DEX_SESSION
    

Weitere Informationen

Die SY00800-Tabelle ist die Tabelle "Batch-Aktivität". Diese Tabelle wird verwendet, um den Status von Batches nachzuverfolgen. Wenn sich ein Stapelaufzeichnung in dieser Tabelle befindet, wird der Batch bearbeitet, gebucht, verbucht oder gelöscht.

Die SY00801-Tabelle ist die Ressourcenaktivitätstabelle. Es wird normalerweise in Chargen verwendet. Diese Tabelle wird verwendet, um einige Elemente oder Informationen zu melden, die nicht aktualisiert werden konnten.