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In diesem Artikel wird ein Problem erläutert, bei dem Microsoft Entra Connect Health veraltete Informationen zum lokalen Microsoft Entra Connect-Server anzeigt.
Ursprüngliche Produktversion: Microsoft Entra ID
Ursprüngliche KB-Nummer: 4053427
Symptome
Das Blatt "Microsoft Entra Connect Health" zeigt keine aktuellen Informationen (z. B. Synchronisierungsfehler) zum lokalen Microsoft Entra Connect-Server an. In einigen Fällen stürzt der Microsoft Entra Connect Health Insight Service, der auf dem Microsoft Entra Connect-Server ausgeführt wird, ab und generiert das folgende Windows-Anwendungsereignis:
Protokollname: Application
Quelle: Anwendungsfehler
Datum: 10.19.2017 8:03:19 Uhr
Ereignis-ID: 1000
Vorgangskategorie: (100)
Ebene: Fehler
Schlüsselwörter: Klassisch
Benutzer: N/V
Computer: XXXXXXX
Beschreibung: Name der fehlerhaften Anwendung: Microsoft.Identity.AadConnect.Health.AadSync.Host.exe, Version: 3.0.68.0, Zeitstempel: 0x5965450e Name des fehlerhaften Moduls: ntdll.dll, Version: 6.3.9600.18696, Zeitstempel: 0x59153753 Ausnahmecode: 0xc0000374 Fehlerversatz: 0x00000000000f1c00 Fehlerprozess-ID: 0x624 Fehleranwendungsstartzeit: 0x01d348d2403fcb09 Fehleranwendungspfad: C:\Programme\Microsoft Azure AD Connect Health Sync Agent\Insights\ Microsoft.Identity.AadConnect.Health.AadSync.Host.exe Pfad des fehlerhaften Moduls: C:\Windows\SYSTEM32\ntdll.dll Berichts-ID: 7eb31450-b4c5-11e7-80cb-005056ba3ca2 Faulting package full name: Faulting package-relative application ID:
Ursache
Das Problem tritt auf, wenn zwischen dem Microsoft Entra Connect-Synchronisierungsdienst und microsoft Entra Connect Health für Synchronisierungsanwendungen ein Versionskonflikt vorliegt. Dieses Problem kann auftreten, wenn eine Komponente während des letzten Microsoft Entra Connect-Upgrades oder des automatischen Upgrades nicht erfolgreich aktualisiert wurde.
Führen Sie die folgenden Schritte aus, um zu überprüfen, ob ein vorhandener Microsoft Entra Connect-Server ein Versionskompatibilitätsproblem zwischen den beiden Anwendungen hat:
Rufen Sie die Version der Anwendungen aus dem Element "Programme" in Systemsteuerung ab.
Vergleichen Sie die Versionsinformationen mit der folgenden Kompatibilitätstabelle:
Synchronisierungsdienstversion Kompatible Integritäts-Agent-Version 1.1.614.0 (oder frühere Version) 3.0.68.0 (oder frühere Version) 3.0.127.0 1.1.647.0 (oder höher) 3.0.103.0 3.0.129.0
Lösung
Verwenden Sie eine der folgenden Methoden, um dieses Problem zu beheben.
Methode 1
Aktualisieren Sie Ihren Microsoft Entra Connect-Server manuell auf Version 1.1.649.0 oder eine höhere Version. Während des manuellen Upgrades werden beide Anwendungen auf die Versionen aktualisiert, die miteinander kompatibel sind.
Weitere Informationen zum Upgrade des Microsoft Entra Connect-Servers finden Sie im folgenden Azure-Artikel: Microsoft Entra Connect: Upgrade von einer früheren Version auf die neueste Version
Methode 2
Installieren Sie den Integritäts-Agent für die Synchronisierung manuell erneut auf eine Version, die mit der auf dem Microsoft Entra Connect-Server installierten Synchronisierungsdienstversion kompatibel ist. Sie verfügen beispielsweise über einen vorhandenen Microsoft Entra Connect-Server mit Synchronisierungsdienst, Version 1.1.647.0 und Integritäts-Agent für Synchronisierung, Version 3.0.68.0. Um das Inkompatibilitätsproblem zu beheben, können Sie den Integritäts-Agent für die Synchronisierungsversion 3.0.129.0 erneut installieren.
So installieren Sie den Integritäts-Agent für die Synchronisierung erneut:
Ermitteln Sie die Version des Integritäts-Agents, die mit der Version des Microsoft Entra Connect-Synchronisierungsdiensts kompatibel ist, die Sie installiert haben. Wenn Sie über den Microsoft Entra Connect-Synchronisierungsdienst version 1.1.647.0 oder eine höhere Version verfügen, verwenden Sie Health Agent Version 3.0.129.0.
Laden Sie eine Kopie des Installationsprogramms für den Integritäts-Agent (AadConnectHealthAadSyncSetup.exe) von der folgenden Microsoft Download Center-Website herunter:
Herunterladen und Installieren von Microsoft Entra Connect Health Agent
Melden Sie sich mit einem Konto mit lokalen Administratorrechten beim Microsoft Entra Connect-Server an.
Führen Sie die folgenden Schritte aus, um die vorhandene Version des Integritäts-Agents zu deinstallieren:
- Wechseln Sie zu Systemsteuerung> Program und Features. Wählen Sie "Microsoft Entra Connect Health Agent for Sync" und dann " Deinstallieren" aus.
Notiz
Dadurch wird das Setupfenster für den Integritäts-Agent geöffnet.
- Wählen Sie im Setupfenster für den Integritäts-Agent die Option "Deinstallieren" aus.
- Nachdem der Deinstallationsprozess abgeschlossen ist, wählen Sie "Schließen" aus.
- Wechseln Sie zu Systemsteuerung> Program und Features. Wählen Sie "Microsoft Entra Connect Health Agent for Sync" und dann " Deinstallieren" aus.
So installieren Sie die kompatible Version des Integritäts-Agents:
Doppelklicken Sie auf die heruntergeladene ausführbare Datei.
Wählen Sie auf dem Setupbildschirm die Option "Installieren" aus.
Warten Sie, bis die Installation abgeschlossen ist, und wählen Sie dann Schließen aus.
Wichtig
Wählen Sie "Konfigurieren" nicht aus.
Starten Sie eine neue PowerShell-Sitzung. Registrieren Sie den installierten Integritäts-Agent mit der Microsoft Entra-ID, indem Sie das folgende Cmdlet ausführen:
Register-AzureADConnectHealthSyncAgent -AttributeFiltering:$false -StagingMode:$false
Wenn Sie zur Eingabe von Anmeldeinformationen aufgefordert werden, geben Sie Ihre Anmeldeinformationen für den globalen Microsoft Entra-Administrator an.
Warten Sie etwa zwei Stunden, und stellen Sie dann sicher, dass im Bereich "Integrität" aktuelle Informationen zur Synchronisierung angezeigt werden.
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