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Dieser Artikel enthält Informationen zur Problembehandlung bei einem Problem, bei dem Ihr Identitätssynchronisierungsclient sich nicht bei Microsoft Entra ID authentifizieren kann, wenn ein nicht authentifizierter Proxyserver vorhanden ist.
Ursprüngliche Produktversion: Microsoft Entra ID
Ursprüngliche KB-Nummer: 3013032
Symptome
Wenn Ihre Umgebung einen nicht authentifizierten Proxyserver enthält, authentifiziert sich Ihr Identitätssynchronisierungsclient möglicherweise nicht bei Microsoft Entra ID.
Dieses Problem tritt beispielsweise auf, wenn Sie einen Identitätssynchronisierungsclient wie Microsoft Entra Connect, Azure Active Directory-Synchronisierungsdienste (Azure AD-Synchronisierung) oder das Azure Active Directory-Synchronisierungstool verwenden.
Wenn Sie Microsoft Entra Connect oder Azure AD Sync verwenden:
Der Assistent zeigt die folgende Konfigurationsfehlermeldung an:
Bereit zum Konfigurieren.
Wir haben genügend Informationen gesammelt, um Azure AD Sync zu konfigurieren und erstellt jetzt eine Standardkonfiguration.
Fehler auch nach 5 Wiederholungen. Aktion: PingProvisioningServiceEndPoint, Ausnahme: Die Kommunikation mit dem Windows Azure Active Directory-Dienst ist nicht möglich. Tracking-ID: 01601250-7951-469c-8973-34e2a8e1ca10 Weitere Details finden Sie im Ereignisprotokoll.
Wenn dieses Problem auftritt, wird ein Eintrag "Fehler 906", der etwa wie folgt aussieht, im Microsoft Entra Connect- oder Azure AD-Synchronisierungsprotokoll protokolliert. Dieser Eintrag gibt an, dass die Identitätssynchronisierungs-Appliance versucht, eine direkte Verbindung mit dem Internet herzustellen.
AzureActiveDirectoryDirectorySyncTool-Fehler: 906 : System.Management.Automation.CmdletInvocationException: Fehler auch nach 5 Wiederholungen. Aktion: PingProvisioningServiceEndPoint, Ausnahme: Die Kommunikation mit dem Windows Azure Active Directory-Dienst ist nicht möglich. Tracking-ID: 90edf657-f63e-46cc-94ec-df88817f4c73 Weitere Details finden Sie im Ereignisprotokoll. >--- Microsoft.IdentityManagement.PowerShell.ObjectModel.SynchronizationConfigurationValidationException: Fehler auch nach 5 Wiederholungen. Aktion: PingProvisioningServiceEndPoint, Ausnahme: Die Kommunikation mit dem Windows Azure Active Directory-Dienst ist nicht möglich. Tracking-ID: 90edf657-f63e-46cc-94ec-df88817f4c73 Weitere Details finden Sie im Ereignisprotokoll.
Wenn Sie das Azure Active Directory-Synchronisierungstool verwenden:
Die folgende Verzeichnissynchronisierungsereignis-ID 0 wird im Anwendungsprotokoll des Synchronisierungsclientcomputers protokolliert:
Protokollname: Anwendung
Quelle: Verzeichnissynchronisierung
Ereignis-ID: 0
Aufgabenkategorie: Keine
Ebene: Fehler
Beschreibung:
Es kann keine Verbindung mit dem Authentifizierungsdienst hergestellt werden. Wenden Sie sich an den technischen Support.0 GetAuthState() mit dem Status "-2147186688". HResult:0. Wenden Sie sich an den technischen Support. (0x80048862)
Darüber hinaus weist eine Netzwerkmonitor-Ablaufverfolgung (Netmon.exe) darauf hin, dass der Microsoft Online Services-Anmelde-Assistent den Proxy verwendet und darauf zugreift login.microsoftonline.com
.
Ursache
Dieses Problem tritt auf, da das Microsoft .NET Framework, auf dem Ihre Identitätssynchronisierungs-Appliance basiert, Ihre Proxyeinstellungen nicht erkennt.
Lösung
Gehen Sie folgendermaßen vor, um dieses Problem zu beheben:
Öffnen Sie die folgende Datei:
C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Config\machine.config
.Fügen Sie den folgenden Text am Ende der Datei hinzu:
<system.net> <defaultProxy> <proxy usesystemdefault="true" proxyaddress="http://<PROXYIP>:80" bypassonlocal="true" /> </defaultProxy> </system.net>
Notiz
In diesem Text stellt der Platzhalter <PROXYIP> die tatsächliche Proxy-IP-Adresse dar. Weitere Informationen zu den Proxyeinstellungen in diesem Kontext finden Sie unter Element (Netzwerkeinstellungen).
Weitere Informationen
Weitere Informationen finden Sie unter Fehler auf .NET-Client, der einen Webdienst über einen HTTP-Proxyserver verwendet.
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Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.