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Fehler beim Upgrade von Microsoft Entra Connect: Der Synchronisierungsdienst kann nicht installiert werden.

Ursprüngliche Produktversion: Office 365 Identity Management, Microsoft Entra ID
Ursprüngliche KB-Nummer: 4054462

Symptome

Wenn Sie versuchen, Microsoft Entra Connect zu aktualisieren, wird die folgende Fehlermeldung angezeigt:

Fehler beim Upgrade von Azure Active Directory-Synchronisierung. Der Synchronisierungsdienst kann nicht aktualisiert werden. Weitere Informationen finden Sie im Ereignisprotokoll.

Das detaillierte Ereignisprotokoll sieht wie folgt aus:

Date/Time[ 12] [INFO ] ServiceControllerProvider: StartService status: Running Date/Time[ 12] [ERROR] Error during sync engine upgrade. System.Exception: Der Synchronisierungsdienst kann nicht aktualisiert werden. Weitere Details finden Sie im Ereignisprotokoll. >--- Microsoft.Azure.ActiveDirectory.Client.Framework.ProcessExecutionFailedException: Fehler beim Installieren des MSI-Pakets "Synchronisierung Service.msi". Das vollständige Protokoll ist unter "C:\ProgramData\AADConnect\Synchronization Service_Install-DateTime.log" verfügbar.

Action startTime: DetectServiceAccount. CustomAction DetectServiceAccount hat den tatsächlichen Fehlercode 1603 zurückgegeben (Beachten Sie, dass dies möglicherweise nicht 100 % genau ist, wenn die Übersetzung innerhalb der Sandbox erfolgt ist) Action endedTime: DetectServiceAccount. Return value 3. Aktion beendetTime: INSTALL. Return value 3. MSI (s) (14:AC)Zeit: Hinweis: 1: 1708 MSI (s) (14:AC)Zeit: Produkt: Microsoft Entra Connect-Synchronisierungsdienste - Installationsvorgang fehlgeschlagen. MSI (s) (14:AC)Zeit: Windows Installer hat das Produkt installiert. Produktname: Microsoft Entra Connect-Synchronisierungsdienste. Produktversion: 1.1.614.0. Produktsprache: 1033. Hersteller: Microsoft Corporation. Installationserfolg oder Fehlerstatus: 1603. MSI (s) (14:AC)Zeit: Zurückstellen der Bereinigung von Paketen/Dateien, falls vorhanden MSI (s) (14:AC)-Zeit: MainEngineThread gibt 1603 MSI (s) (14:80)Zeit: NEUSTART-MANAGER: Sitzung geschlossen.

Ursache

Das zugrunde liegende Dienstkonto wurde mithilfe des Benutzerprinzipalnamens (USER Principal Name, UPN) anstelle von "Domain\SamAccountName" konfiguriert.

Lösung

Gehen Sie folgendermaßen vor, um das Problem zu beheben:

  1. Starten Sie die Dienstkonsole auf dem Microsoft Entra Connect-Server.
  2. Suchen Sie den Microsoft Azure AD-Synchronisierungsdienst , und klicken Sie dann mit der rechten Maustaste auf den Dienst.
  3. Wählen Sie Eigenschaften 1 und dann Anmeldungen aus.
  4. Legen Sie das Konto mithilfe von Domain\SamAccountName anstelle des UPN fest.
  5. Wählen Sie Anwenden dann OK aus.

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