Share via


Configuration Manager Clients werden alle fünf Stunden neu installiert und können zu einem versehentlichen Clientupgrade führen.

In diesem Artikel wird ein Problem in System Center 2012 Configuration Manager Client und System Center 2012 R2 Configuration Manager Client behandelt, das zu einem versehentlichen Clientupgrade in einer Configuration Manager Current Branch- oder LTSB-Umgebung (Long-Term Servicing Branch) führen kann.

Ursprüngliche Produktversion: Microsoft System Center 2012 Configuration Manager, Microsoft System Center 2012 R2 Configuration Manager
Ursprüngliche KB-Nummer: 4018655

Zusammenfassung

Bei der Configuration Manager-Clientinstallation (CCMSetup) tritt zunächst ein Fehler auf und bewirkt, dass eine Clientwiegeraufgabe im Windows-Taskplaner registriert wird. Nachdem die Clientinstallation erfolgreich war, wird die Wiederholungsaufgabe nicht wie erwartet gelöscht. Daher werden die Clients weiterhin alle fünf Stunden neu installiert.

Wenn Sie in diesem Fall die Configuration Manager-Infrastruktur auf Configuration Manager Current Branch oder LTSB aktualisieren und die Configuration Manager Clients nicht aktualisieren, erzwingt der geplante Wiederholungstask weiterhin alle fünf Stunden eine Neuinstallation des Clients.

Bei der nächsten Ausführung von CCMSetup finden die Clients einen aktualisierten Verwaltungspunkt oder Verteilungspunkt und installieren die Clientsoftware neu. Dadurch werden die Clients auf Configuration Manager aktualisiert.

Diese kontinuierlichen Upgrades erfolgen außerhalb des normalen Upgradeprozesses, der vom Administrator konfiguriert wird. Dies schließt die Clientpilotfunktion ein.

Symptome

In einer Microsoft System Center 2012- oder System Center 2012 R2-Umgebung bemerken Sie die folgenden Symptome:

  • Clients installieren sich erfolgreich alle fünf Stunden neu. Diese Aktivität wird in ccmsetup.log- und Windows-Ereignisprotokollen protokolliert.
  • Wenn Sie den Ordner "\Microsoft\Microsoft\ConfigurationManager" im Taskplaner anzeigen, finden Sie eine Aufgabe mit dem Namen Configuration Manager Clientwieinstiegstask.

Ursache

Dieses Problem tritt auf, weil CCMSetup die Clientwiezurücksetzung im falschen Ordner auf dem Client erstellt. Dadurch wird verhindert, dass CCMSetup die Aufgabe suchen und entfernen kann.

Die geplante Aufgabe wird im Ordner \Microsoft\Microsoft\Configuration Manager anstelle des Ordners \Microsoft\Configuration Manager erstellt.

Problemumgehung 1

Entfernen Sie Configuration Manager client retry Task manuell aus dem Ordner \Microsoft\Microsoft\Configuration Manager, indem Sie den Taskplaner verwenden.

Problemumgehung 2

Stellen Sie ein Skript bereit, um Configuration Manager Clientwiezurücksetzung aus dem Ordner \Microsoft\Microsoft\Configuration Manager zu entfernen.

Beispiel für Windows PowerShell Befehle, die Ihrem Skript hinzugefügt werden sollen:

get-scheduledtask -taskname "Configuration Manager Client Retry Task"  
unregister-scheduledtask -taskname "Configuration Manager Client Retry Task" -confirm:$false

Weitere Informationen

In Configuration Manager Current Branch Version 1602 und höheren Versionen und in LTSB Version 1606 entfernt Ccmsetup die geplante Aufgabe ordnungsgemäß, nachdem die Clients aktualisiert wurden.