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Configuration Manager-Konsole scheint hängen zu bleiben, wenn Sie einem Startimage einen Treiber hinzufügen

Dieser Artikel hilft Ihnen, ein Problem zu beheben, bei dem die Configuration Manager-Konsole scheinbar nicht mehr reagiert, während eine Liste der Treiber aus dem Treiberkatalog geladen wird.

Originalproduktversion: Microsoft System Center 2012 Configuration Manager, Microsoft System Center 2012 R2 Configuration Manager
Ursprüngliche KB-Nummer: 3070057

Problembeschreibung

Wenn Sie einen Treiber auf der Registerkarte "Treiber " der Eigenschaften eines Startimages hinzufügen, kann die Configuration Manager-Konsole hängen oder nicht mehr reagieren, während die Liste der Treiber aus dem Treiberkatalog geladen wird. In einer Umgebung mit 500 Treibern kann die Konsole beispielsweise bis zu 8 Minuten nicht mehr reagieren. Die genaue Anzahl der Treiber und die Länge der Verzögerung variieren jedoch je nach Systemleistung.

Während dieser Zeit zeigt eine Überprüfung der Smsprov.log Datei auf dem Standortserver, dass Configuration Manager tatsächlich die verfügbaren Treiber aufzählt:

CExtUserContext::EnterThread : User=<DOMAIN\user> Sid=0x010500000:-0000000515XXXXCEBFCF270C2XXXXC3CAFFF0 Caching IWbemContextPtr=000008DEF086000 in Process 0x1534 (5428)
Kontext: SMSAppName=Configuration Manager-Administratorkonsole
Kontext: MachineName=<siteserver.fqdn>
Kontext: Benutzername==<DOMÄNE\Benutzer>
Kontext: ObjectLockContext=796d1f9e-3512-4fd4-ae23-11cbe5883fda
Kontext: ApplicationName=Microsoft.ConfigurationManagement.exe
Kontext: ApplicationVersion=5.0.8239.1000
Kontext: LocaleID=MS\0x409
Kontext: __ProviderArchitecture=32
Kontext: __RequiredArchitecture=0 (Bool)
Kontext: __ClientPreferredLanguages=en-US,en
Kontext: __CorrelationId={3ACC714D-97FE-0005-897C-CC3AFE97D001}
Kontext: __GroupOperationId=181360
CExtUserContext: Set ThreadLocaleID OK to: 1033
CSspClassManager::P reCallAction, dbname=CM_392
ExecQueryAsync: START select FromCIID from SMS_CIRelation where ToCIID =16777966 AND RelationType=5
Hinzufügen von Handle -346430696 zur asynchronen Aufrufzuordnung
CExtProviderClassObject::D oCreateInstanceEnumAsync (SMS_CIRelation)
CSspQueryForObject :: Execute...
Ausführen von WQL =FromCIID aus SMS_CIRelation wobei ToCIID =16777966 AND RelationType=5
Sql =wählen Sie alle SMS_CIRelation.FromCIID aus vSMS_CIRelation AS SMS_CIRelation aus, wobei (SMS_CIRelation.ToCIID = 16777966 AND SMS_CIRelation.RelationType = 5)
Zurückgegebene Ergebnisse: 0 von 1
Entfernen von Handle -346430696 aus asynchroner Aufrufzuordnung
ExecQueryAsync: COMPLETE select FromCIID from SMS_CIRelation where ToCIID =16777966 AND RelationType=5
CExtUserContext::LeaveThread : Veröffentlichen von IWbemContextPtr=-284663808

Ursache

Dieses Problem tritt aufgrund der Zeit auf, die zum Aufzählen der verfügbaren Treiber erforderlich ist.

Lösung

Abhängig von der Anzahl der Treiber und der leistung einzelner Systeme kann der Vorgang möglicherweise erfolgreich abgeschlossen werden. Um das Problem zu vermeiden, sollten Sie jedoch erwägen, zusätzliche Ordner zum Speichern Ihrer Treiber zu erstellen. Dadurch können Sie die Anzahl der Treiber verringern, die in einer einzelnen Ordneransicht aufgelistet werden.

Die folgenden Problemumgehungen sind ebenfalls verfügbar:

  • Wählen Sie im Knoten "Betriebssysteme\Treiber" den hinzuzufügenden Treiber aus, klicken Sie mit der rechten Maustaste auf den Treiber, wählen Sie "Bearbeiten", wählen Sie "Startimages" aus, und geben Sie dann das Startimage an, dem der ausgewählte Treiber hinzugefügt werden soll.
  • Fügen Sie beim Import oder erneuten Importieren des Treibers in den Treiberkatalog den Treiber zu diesem Zeitpunkt zum erforderlichen Startimage hinzu.
  • Fügen Sie den Treiber zum Startimage hinzu, indem Sie das Windows PowerShell-Cmdlet "Set-CMDriverBootImage " verwenden.
  • Verwenden Sie DISM , um den Treiber manuell zum Startimage hinzuzufügen.