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Dieser Artikel enthält eine Lösung für das Problem, bei dem die Configuration Manager-Konsole veraltete Endpoint Protection Definition-Version und die uhrzeit der letzten Aktualisierung anzeigt, während die Clients die neueste Version der Definition installiert haben.
Ursprüngliche Produktversion: Configuration Manager
Ursprüngliche KB-Nummer: 4528414
Problembeschreibung
Wenn Sie Endpoint Protection zusammen mit Configuration Manager verwenden, treten die folgenden Probleme auf:
- In der Configuration Manager-Konsole öffnen Sie den Arbeitsbereich "Assets and Compliance " unter dem Knoten "Geräte ". In diesem Arbeitsbereich stellen Sie fest, dass in den Spalten "Letzte Version der letzten Version " von Endpoint Protection und "Endpoint Protection Last Update Time " veraltete Werte für einige Geräte angezeigt werden. Die Clients zeigen jedoch, dass sie die neuesten Versionen angewendet haben.
- Der Thementyp 1901 (State_Topictype_Ep_Am_Health) ist nicht in StateMessage.log auf den Clients angemeldet.
- Die folgenden Fehlermeldungen werden in ExternalEventAgent.log auf den Clients protokolliert:
PARSE XML zum Abrufen der Abfragezeichenfolge SELECT * FROM MSFT_MPComputerStatus
...
Führen Sie alle Initialisierungsaktionen für Richtlinienänderungen von CCM_ExternalEventConfig aus.
Der Registrierungsschlüssel SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\ComputerStatusStateMessage\SyncStatus mit Fehler 0x80070002 konnte nicht geöffnet werden.
Der Registrierungsschlüssel SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\ComputerStatusStateMessage mit Fehler 0x80070002 konnte nicht geöffnet werden.
Fehler beim Laden vorheriger Werte der Differenzierungskriterien ComputerStatusStateMessage mit Fehler 0x80070002.
Der Registrierungsschlüssel SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\InfectionStatusStateMessage\SyncStatus mit Fehler 0x80070002 konnte nicht geöffnet werden.
Der Registrierungsschlüssel SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\InfectionStatusStateMessage mit Fehler 0x80070002 konnte nicht geöffnet werden.
Fehler beim Laden vorheriger Werte der Differenzierungskriterien InfectionStatusStateMessage mit Fehler 0x80070002.
Darüber hinaus sind die folgenden Registrierungsschlüssel nicht auf dem Client vorhanden:
HKLM\SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\ComputerStatusStateMessage
HKLM\SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\InfectionStatusStateMessage
Ursache
Dieses Problem tritt auf, da die Instanz der MSFT_MpComputerStatus
Klasse im root\Microsoft\ProtectionManagement
Namespace nicht vorhanden ist. Der Client fragt diese Instanz ab, um die zugehörigen Registrierungsschlüssel aufzufüllen.
Lösung
Führen Sie zum Beheben des Problems den folgenden Befehl auf den betroffenen Clientcomputern aus, um den ProtectionManagement
Anbieter erneut zu registrieren:
Register-CimProvider -ProviderName ProtectionManagement -Namespace root\Microsoft\protectionmanagement -Path <path of ProtectionManagement.dll> -Impersonation True -HostingModel LocalServiceHost -SupportWQL -ForceUpdate
Notiz
In diesem Befehl <ist der Pfad von ProtectionManagement.dll> der Platzhalter für den Pfad von ProtectionManagement.dll. Zum Beispiel:
C:\ProgramData\Microsoft\Windows Defender\Platform\4.18.1907.4-0\ProtectionManagement.dll
Nachdem Sie diesen Befehl ausgeführt haben, sind die folgenden Bedingungen erfüllt:
- Die Instanz von
MSFT_MpComputerStatus
wird imroot\Microsoft\ProtectionManagement
Namespace aufgefüllt. - Der Thementyp 1901 wird in StateMessage.log protokolliert.
- Die betroffenen Werte in der Configuration Manager-Konsole werden aktualisiert.
Weitere Informationen
Windows Defender-Protokolle können Ihnen helfen, die Ursache dieses Problems zu identifizieren. Der folgende Protokollausschnitt gibt beispielsweise das Vorhandensein einer anderen Antivirenlösung an:
2019-09-04T08:00:11.166Z [Minifilter] Verweigerter Zugriff auf Datei: \ProgramData\Microsoft\Windows Defender\Platform\4.18.1907.4-0\Powershell\MSFT_MpComputerStatus.cdxml, from process '\Device\HarddiskVolume2\Program Files (x86)\Symantec\Symantec Endpoint Protection\14.0.3929.1200.105\Bin\ccSvcHst.exe' (PID: 3408)
Führen Sie zum Sammeln von Diagnoseprotokollen für Windows Defender die Schritte unter Sammeln von Updatecompliance-Diagnosedaten für die Windows Defender AV-Bewertung aus.
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