Fehler 0x800f0831 beim Installieren eines Updates

Dieser Artikel behebt ein Problem, bei dem Sie den Fehler 0x800f0831 erhalten, wenn Sie ein kumulatives Update installieren.

Originalversion des Produkts: Configuration Manager (Current Branch), Windows Server Update Services
Ursprüngliche KB-Nummer: 4477073

Problembeschreibung

Wenn Sie versuchen, ein Windows-Update zu installieren, insbesondere ein kumulatives Update, erhalten Sie die folgende Fehlermeldung in WindowsUpdate.log:

SCHWERWIEGEND: CBS-Fehler mit 0x800f0831

Dieses Problem tritt wahrscheinlicher auf, wenn kein Zugriff auf Microsoft Update besteht.

Darüber hinaus erhalten Sie Fehlermeldungen, die in CBS.log wie folgt aussehen:

Speicherfehler, Manifest fehlt für Paket: <Fehlendes_Paket>
Fehler beim Auflösen des Pakets >Fehlendes_Paket> [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
Kennzeichen für Speicherbeschädigung aufgrund von Paket >Fehlendes_Paket> [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
Fehler beim Auflösen des Pakets [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
Fehler beim Abrufen des nächsten neu zu bewertenden Pakets [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
Fehler bei der Verarbeitung der Ausführungskette. [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
Fehler bei der Verarbeitung der einphasigen Ausführung. [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
WER: Erzeuge Fehlerbericht für Paket: <Gescheitertes_Paket> Status: 0x800f0831, Fehlerquelle: Ausführen, Startstatus: Bereitgestellt, Zielzustand: Installiert, Client-ID: DISM-Paketmanagementanbieter

Hinweis

              <Gescheitertes_Paket> steht für das Paket, das nicht installiert werden kann.               <Fehlendes_Paket> steht für das Paket, für das das Manifest fehlt.

Ursache

Dieses Problem tritt auf, weil das Update, das nicht installiert werden kann, das Manifest eines früheren Updatepakets erfordert.

Lösung

Verwenden Sie eine der folgenden Methoden, um das Problem zu beheben.

Methode 1: Reparieren des Komponentenspeichers mit DISM-Befehlen

Führen Sie die folgenden Schritte aus, um den Komponentenspeicher mit dem DISM RestoreHealth Befehl zu reparieren:

  1. Öffnen Sie eine Eingabeaufforderung mit erhöhten Rechten, und führen Sie die folgenden Befehle aus:

    DISM /ONLINE /CLEANUP-IMAGE /SCANHEALTH
    
    DISM /ONLINE /CLEANUP-IMAGE /CHECKHEALTH
    
    DISM /ONLINE /CLEANUP-IMAGE /RESTOREHEALTH
    
    Sfc /Scannow
    
  2. Starten Sie das Gerät neu.

Methode 2: Manuelle Reparatur mit der Nutzlast der teilweise installierten Komponente

  1. Rufen Sie den Microsoft Update-Katalog auf.
  2. Geben Sie im Feld Suchen die Paket-ID von <Fehlendes_Paket> ein.
  3. Suchen Sie in den Suchergebnissen das richtige Update für Ihr Betriebssystem, und klicken Sie dann auf Herunterladen.
  4. Wählen Sie im Fenster Microsoft Update-Katalog den Link der Datei aus, um das Update herunterzuladen.
  5. Klicken Sie nach Abschluss des Downloads auf Schließen. Dann finden Sie an dem Speicherort, den Sie angegeben haben, einen Ordner, in dem sich das Updatepaket befindet.
  6. Öffnen Sie den Ordner, und doppelklicken Sie auf das Updatepaket, um das Update zu installieren.