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Fehler beim Verwalten von Startimages in Configuration Manager

In diesem Artikel wird ein Problem behoben, bei dem Sie keine Startimages im Configuration Manager vorgesetzt haben können, wenn der WIMMount-Dienst beschädigt, falsch konfiguriert oder fehlt.

Originalproduktversion: Configuration Manager (current branch), Microsoft System Center 2012 R2 Configuration Manager, Microsoft System Center 2012 Configuration Manager
Ursprüngliche KB-Nummer: 4096324

Problembeschreibung

In einer Umgebung, in der das Windows Assessment and Deployment Kit (ADK) auf dem Server installiert und auf dem Server installiert ist, auf dem der SMS-Anbieter gehostet wird, können Sie startimages nicht mithilfe von Configuration Manager verwalten. Der Vorgang umfasst folgende Aktionen:

  • Aktualisieren Sie Startimages auf Verteilungspunkten.
  • Importieren sie neue Startimages.
  • Erstellen Sie neue Startimages mithilfe des Microsoft Deployment Toolkit (MDT)-Assistenten.
  • Ändern Sie Startimages, z. B. zum Hinzufügen von Treibern.

In diesem Szenario wird der folgende Fehler in der datei SMSProv.log auf dem SMS Provider-Server protokolliert:

SMS-Anbieter ExecMethodAsync : SMS_BootImagePackage.PackageID="<Boot_Image_Package_ID>"::RefreshPkgSource~
SMS Provider Requested Class =SMS_BootImagePackage~
SMS-Anbieter Angeforderte Nummernschlüssel =1~
SMS-Anbieter IExtClassManager::ValidateAuthenticationLevel...
SMS Provider CExtProviderClassObject::D oExecuteMethod RefreshPkgSource~
SMS-Anbieter geladen wimgapi.dll Version 10.0.16299.15 vom Speicherort "C:\Programme (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\amd64\DISM\wimgapi.dll"
DER WIM-Index des SMS-Anbieters ist 1.
SMS Provider Image Language ID 1033 und en-US~
SMS-Anbieter hat das Image aus \\<Boot_Image_Path>\boot.wim geladen.
Der temporäre PFAD des SMS-Anbieters für WIM-Datei lautet "C:\Windows\TEMP\BootImages\{<Random_GUID>}\temp".
SMS-Anbieter hat den Bildindex 1 geladen.
FEHLER> des SMS-Anbieters beim Einbinden der WIM-Datei, err=-1052638943~
SMS-Anbieter ~*~*~.. \sspbootimagepackage.cpp(5198) : Fehler beim Einfügen von OSD-Binärdateien in die bereitgestellte WIM-Datei (häufig tritt auf, wenn nicht signierte Treiber in das x64-Startimage eingefügt werden)~*~*~
SMS-Anbieter ~*~*~Fehler beim Einfügen von OSD-Binärdateien in die bereitgestellte WIM-Datei (tritt häufig auf, wenn nicht signierte Treiber in das x64-Startimage eingefügt werden) ~*~*~

Wenn Sie DISM.exe manuell auf dem SMS Provider-Server ausführen, wird der folgende Fehler in der DISM.log Datei protokolliert:

DISM DISM.EXE: Erfolgreich registrierte Befehle für den Anbieter: Kompatibilitäts-Manager.
[10780] [0x8007007b] OpenFilterPort:(408): Der Dateiname, der Verzeichnisname oder die Volumebezeichnungssyntax ist falsch.
[10780] [0x8007007b] FltCommVerifyFilterPresent:(502): Der Dateiname, der Verzeichnisname oder die Volumebezeichnungssyntax ist falsch.
[10780] [0x8007007b] WIMMountImageHandle:(1089): Der Dateiname, der Verzeichnisname oder die Volumebezeichnungssyntax ist falsch.
[10780] [0x80070002] StateStoreRemoveMountedImage:(1030): Das System kann die angegebene Datei nicht finden.
[10780] [0x80070002] WIMMountImageHandle:(1331): Das System kann die angegebene Datei nicht finden.

DISM DISM WIM-Anbieter: PID=10780 TID=1096 "Fehler beim Bereitstellen des Images."- CWimImageInfo::Mount(hr:0x8007007b)
DISM DISM WIM-Anbieter: PID=10780 TID=1096 onecore\base\ntsetup\opktools\dism\providers\wimprovider\dll\wimmanager.cpp:2684 - CWimManager::InternalOpMount(hr:0x8007007b)
DISM DISM WIM-Anbieter: PID=10780 TID=1096 onecore\base\ntsetup\opktools\dism\providers\wimprovider\dll\wimmanager.cpp:4028 - CWimManager::InternalCmdMount(hr:0x8007007b)
DISM DISM-WIM-Anbieter: PID=10780 TID=1096 "Fehler beim Ausführen des Befehls" - CWimManager::InternalExecuteCmd(hr:0x8007007b)
DISM DISM WIM-Anbieter: PID=10780 TID=1096 onecore\base\ntsetup\opktools\dism\providers\wimprovider\dll\wimmanager.cpp:2201 - CWimManager::ExecuteCmdLine(hr:0x8007007b)

Notiz

Verwenden der Prozessüberwachung, wenn Sie DISM manuell ausführen, kann nicht identifiziert werden, welche Datei oder welches Verzeichnis nicht gefunden werden kann.

Ursache

Dieses Problem tritt auf, wenn der WIMMount-Dienst beschädigt, falsch konfiguriert oder auf dem SMS-Anbieterserver fehlt.

Überprüfen Sie zum Überprüfen den folgenden Registrierungseintrag auf dem Server, auf dem der SMS-Anbieter gehostet wird:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WIMMount\ImagePath

Der Wert dieses Eintrags sollte der Speicherort der Wimmount.sys-Datei sein, die sich unter dem Installationsverzeichnis von Windows ADK befindet.

Notiz

Der Server, auf dem der SMS-Anbieter gehostet wird, ist möglicherweise nicht der Zentraladministrationsstandort oder der primäre Standortserver. Wenn mehrere Server vorhanden sind, die den SMS-Anbieter hosten, stellen Sie sicher, dass Sie diesen Registrierungseintrag auf allen SMS-Anbieterservern überprüfen.

Führen Sie die folgenden Schritte aus, um die Server zu finden, die den SMS-Anbieter an einem Standort hosten:

  1. Wechseln Sie in der Configuration Manager-Konsole zu "Verwaltungsübersicht>>Standortkonfigurationswebsites>".
  2. Klicken Sie mit der rechten Maustaste auf die Website, und wählen Sie dann "Eigenschaften" aus.
  3. Suchen Sie auf der Registerkarte "Allgemein " die Server, die unter dem Speicherort des SMS-Anbieters aufgeführt sind.

Lösung

Führen Sie zum Beheben des Problems die folgenden Schritte aus, um den WIMMount-Dienst neu zu installieren:

  1. Wechseln Sie auf dem Server, auf dem der SMS-Anbieter gehostet wird, zu dem Speicherort, an dem Windows ADK installiert ist. Der Standardpfad von Windows ADK 10 lautet C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\amd64z. B. .

  2. Wechseln Sie zum DISM-Ordner, und führen Sie dann den folgenden Befehl aus:

    WimMountAdkSetupAmd64.exe /Install