Hinweis
Für den Zugriff auf diese Seite ist eine Autorisierung erforderlich. Sie können versuchen, sich anzumelden oder das Verzeichnis zu wechseln.
Für den Zugriff auf diese Seite ist eine Autorisierung erforderlich. Sie können versuchen, das Verzeichnis zu wechseln.
Dieser Artikel enthält eine Lösung für die folgende Fehlermeldung, wenn Sie eine macOS-Branchen-App in Microsoft Intune bereitstellen:
Mindestens eine App enthält ungültige BundleIDs. (0x87D13BA2)
Problembeschreibung
Sie veröffentlichen eine macOS-BRANCHEN-App mit Intune. Wenn Sie die App im Microsoft Intune Admin Center auswählen, werden im Geräteinstallationsstatus die folgenden Informationen zur App angezeigt:
- Status: Fehlgeschlagen
- Statusdetails: Mindestens eine App enthält ungültige BundleIDs. (0x87D13BA2)
Hier ist ein Beispiel für Microsoft Teams:
Dieses Problem kann auch dann auftreten, wenn die App erfolgreich auf dem Gerät installiert wurde.
Ursache
Dieses Problem tritt unter den folgenden Bedingungen auf:
- Mehrere Anwendungen sind in einem macOS-App-Paket enthalten.
- Der Installationsstatus aller einzelnen Anwendungen, die im Paket enthalten sind, werden nicht an Intune gemeldet.
Jede App mit mehreren Komponenten, z. B. Microsoft Teams, kann diese Fehlermeldung generieren.
Lösung
Führen Sie die folgenden Schritte aus, um dieses Problem zu beheben und die macOS-Branchen-App zu aktivieren, um den Status korrekt zu melden.
Öffnen Sie auf einem macOS-Gerät, auf dem die App über Intune installiert ist, terminal, und führen Sie den folgenden Befehl aus, um eine Liste der installierten Apps im aktuellen Verzeichnis auszugeben:
sudo /usr/libexec/mdmclient QueryInstalledApps > InstalledApps.txt
Öffnen Sie die InstalledApps.txt-Datei in einem Text-Editor:
Wechseln Sie zu der betroffenen App in Intune, indem Sie "Eigenschaften-App-Informationen>>bearbeiten" auswählen:
Vergleichen Sie die Liste der in Intune enthaltenen Apps mit den apps, die in der datei InstalledApps.txt aufgeführt sind, und entfernen Sie alle Apps, die in der Textdatei nicht angezeigt werden:
Überprüfen und speichern Sie die Anwendung, und synchronisieren Sie dann das Gerät, um den neuesten App-Installationsstatus abzurufen: