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Dieser Artikel enthält die Methoden zum Beheben des Konfliktfehlers, der auftritt, wenn der Konfigurationswert ein kaufmännisches Und-Zeichen (&) in Microsoft Intune aufweist.
Problembeschreibung
Stellen Sie sich folgendes Szenario vor:
Sie erstellen eine App-Konfigurationsrichtlinie für verwaltete iOS-Geräte in Intune.
Wählen Sie unter dem Format "Konfigurationseinstellungen>" die Option "Konfigurations-Designer verwenden" aus.
Sie fügen eine Einstellung hinzu, in der der Konfigurationswert eine URL ist, die ein kaufmännisches Und-Zeichen (&) enthält. Es folgt ein Beispiel:
Konfigurationsschlüssel:
ssoAuthEndpoint
Werttyp: Zeichenfolge
Konfigurationswert:https://sso.contoso.com/idpov/accesslogin/FedSSODispatch.faces?PartnerIdpId=https://sts.windows.net/{GUID}/&TargetResource=https://sso.contoso.com/idprov/pages/home/dispatch.jsp?SpName=MBF
Wenn Sie auf "OK" klicken, um die Konfigurationseinstellung zu speichern, wird die folgende Fehlermeldung angezeigt:
Nichtübereinstimmung zwischen dem Werttyp und dem Konfigurationswert im Konfigurationseinstellungen-Designer
Der Konfigurationseinstellungen-Designer hat einen Werttyp als Zeichenfolge, aber einen Konfigurationswert als "https://sso.contoso.com/idpov/accesslogin/FedSSODispatch.faces?PartnerIdpId=https://sts.windows.net/{GUID}/& TargetResource=https://sso.contoso.com/idprov/pages/home/dispatch.jsp?SpName=MBF", das ungültiges XML-Zeichenformat enthält, wird nicht unterstützt. Bitte korrigieren Sie sie entsprechend.
Ursache
Dieses Problem tritt auf, da iOS-Konfigurationsprofile das kaufmännische Und-Zeichen in XML-Konfigurationsdateien nicht unterstützen.
Lösung
Verwenden Sie eine der folgenden Methoden, um das Problem zu beheben:
Erstellen Sie eine kurze URL, die an die ursprüngliche URL umleitet, die das kaufmännische Und-Zeichen enthält, und verwenden Sie dann die kurze URL als Konfigurationswert.
Ersetzen & durch
&
in der URL. Zum Beispiel:https://sso.contoso.com/idpov/accesslogin/FedSSODispatch.faces?PartnerIdpId=https://sts.windows.net/{GUID}/&TargetResource=https://sso.contoso.com/idprov/pages/home/dispatch.jsp?SpName=MBF
Wenn Sie keine dieser Methoden verwenden können, wenden Sie sich an den Apple-Support.
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