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Es kann keine Verbindung mit Access Datenbank-Engine OLE DB hergestellt werden.

Dieser Artikel enthält eine Lösung für ein Problem, bei dem Sie keine Verbindung mit Access Datenbank-Engine OLE DB in Microsoft Power Automate für Desktop herstellen können.

Gilt für: Power Automate
Ursprüngliche KB-Nummer: 5004577

Symptome

Betrachten Sie das folgende Szenario in Microsoft Power Automate für Desktop:

  1. Access Datenbank-Engine OLE DB-Anbieter wird nicht in der Fensterliste "Datenlinkeigenschaften" angezeigt, wenn Sie eine Verbindung mit Datenbankaktionen herstellen.

  2. Wenn Sie eine Verbindungszeichenfolge direkt verwenden, wird möglicherweise die folgende Fehlermeldung angezeigt:

    Es kann keine Verbindung mit der Datenquelle hergestellt werden: "Microsoft.ACE.OLEDB.1x.0". Der Anbieter ist nicht auf dem lokalen Computer registriert.

Ursache

Diese Fehlermeldung tritt auf, da der entsprechende 64-Bit-Treiber nicht auf Ihrem Computer installiert ist. Beachten Sie, dass Power Automate für Desktop auf der 64-Bit-Architektur basiert und somit nur mit 64-Bit-Datenbanktreibern kompatibel ist.

Problemumgehung

Stellen Sie sicher, dass der 64-Bit-Access-Datenbanktreiber auf Ihrem Computer installiert ist, indem Sie auf Windows zur ODBC-Anwendung für Datenquellenadministrator (64-Bit) und dann zur Registerkarte "Treiber" wechseln. Wenn in der Liste "Microsoft Access-Treiber" nicht angezeigt wird, müssen Sie die 64-Bit-Version von Microsoft Access Datenbank-Engine 2016 Redistributable herunterladen und installieren.

Tipp

Wenn Sie 32-Bit-Office auf Ihren Fenstern installiert haben und kein Upgrade auf die 64-Bit-Version von Office durchführen können, lesen Sie den rest des Artikels weiter.

Führen Sie die folgenden Schritte aus, um sowohl die 32-Bit- als auch die 64-Bit-Zugriffstreiber auf Ihrem Computer gemeinsam zu verwenden:

  1. Deinstallieren Sie alle Access-Treiberversionen von Ihrem Computer.

  2. Wechseln Sie zum Registrierungs-Editor auf Ihrem Desktop (Sie können in der Suchleiste danach suchen), und navigieren Sie zu den beiden unten stehenden Pfaden, sofern vorhanden:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0\Common\FilesPaths

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\16.0\Common\FilesPaths

  3. Überprüfen Sie, ob der Registrierungsschlüssel "mso.dll" in beiden obigen Pfaden vorhanden ist. Wenn der Schlüssel vorhanden ist, bedeutet dies, dass Sie nicht alle Treiber deinstalliert haben. Überprüfen Sie die Treiber auf Ihrem System, und deinstallieren Sie alle Access-Treiber, und überprüfen Sie erneut die Pfade der Registrierungs-Editoren, die in Schritt 2 erwähnt wurden.

  4. Laden Sie eine neue Version von Microsoft Access Datenbank-Engine von der offiziellen Microsoft-Website herunter, und installieren Sie dann den 64-Bit-Treiber mithilfe der Eingabeaufforderung (CMD) mit dem Befehl AccessDatabaseEngine_x64.exe /quiet für 2016 Redistributable.

  5. Wechseln Sie zurück zum Registrierungs-Editor, und löschen Sie den Registrierungsschlüssel "mso.dll" und dessen Wert im folgenden Pfad:

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\16.0\Common\FilesPaths

Installieren Sie schließlich den 32-Bit-Treiber mithilfe der Eingabeaufforderung (CMD) mit dem Befehl AccessDatabaseEngine.exe /quiet für 2016 Redistributable. Dadurch können sowohl die 32-Bit- als auch die 64-Bit-Treiber auf Ihrem Computer gemeinsam vorhanden sein.