Freigeben über


Datensätze können aufgrund fehlender Objektzugriffe in Salesforce CRM nicht aktualisiert werden.

Dieser Artikel hilft Ihnen bei der Problembehandlung und Behebung von Problemen, wenn Benutzer CRM-Datensätze in Microsoft Copilot for Sales aufgrund fehlender Objektzugriffe in Salesforce CRM nicht aktualisieren können.

Wer ist betroffen?

Anforderungstyp Beschreibung
Client-App Copilot for Sales Outlook-Add-In
Plattform Web- und Desktopclients
Betriebssystem Windows und Mac
Bereitstellung Vom Benutzer und Administrator verwaltet
CRM Salesforce
Benutzer Benutzer, die versuchen, einen CRM-Datensatz von Copilot for Sales zu aktualisieren

Problembeschreibung

Wenn ein Benutzer versucht, einen CRM-Eintrag aus dem Copilot for Sales-Add-In für Outlook zu aktualisieren, wird die folgende Fehlermeldung angezeigt:

Um Salesforce zu aktualisieren, bitten Sie um Bearbeitungszugriff für dieses Objekt.

Fehler dazu, dass Datensätze aufgrund fehlenden Objektzugriffs in Salesforce CRM nicht aktualisiert werden können.

Ursache

Der Benutzer hat keinen Bearbeitungszugriff auf ein Objekt in Salesforce.

Wenn ein Benutzer versucht, ein Objekt zu bearbeiten, überprüft Copilot für Vertrieb, ob der Benutzer Schreibzugriff auf das Objekt in Salesforce hat. Haben die Benutzenden keinen Schreibzugriff auf das Objekt, wird die Fehlermeldung angezeigt.

Sie können bestätigen, ob der Benutzer, der keinen Schreibzugriff auf die Entität hat, die Ursache des Problems ist, wenn der folgende Fehler in den Protokollen angezeigt wird:

Exception thrown in VivaSalesContacts/UpdateContact -  
Microsoft.SalesProductivity.Common.Base.SPServiceException: Salesforce failed to complete task: Message: entity is deleted clientRequestId:<CLIENT REQUEST ID>-self --->  
System.Exception: {  
    "status": 400,  
    "message": "Object type contact is not supported. If you are attempting to use a custom object, be sure to append the '__c' after the entity name.  
                Please reference your WSDL or the describe call for the appropriate names\r\nclientRequestId: <CLIENT REQUEST ID>-self",  
    "error": null,  
    "source": "Salesforce.Common",  
    "errors": []  
} 

Gibt in der obigen Fehlermeldung an, Object type contact is not supported dass der Benutzer keinen Schreibzugriff auf das Contact Objekt hat.

Lösung

Um das Problem zu beheben, stellen Sie sicher, dass Benutzende über Folgendes verfügen:

  • Lese- oder Schreibberechtigungen für das Objekt, das der Benutzer in Salesforce bearbeiten möchte.
  • Lese- oder Schreibberechtigungen für alle felder, die für die Bearbeitung konfiguriert sind.

Informationen zur Sicherheit auf Objektebene, Sicherheit auf Feldebene und Sicherheit auf Datensatzebene in Salesforce finden Sie unter Kontrollieren, wer was sieht. Sie können sich auch an Ihren Salesforce-Administrierenden wenden, um Hilfe beim Festlegen von Objektberechtigungen in Profilen zu erhalten.

Weitere Informationen

Wenn Ihr Problem noch nicht behoben ist, wechseln Sie zum Copilot for Sales - Microsoft Community Hub , um sich mit unseren Experten zu beschäftigen.

Informationen zum Haftungsausschluss von Drittanbietern

Die in diesem Artikel genannten Drittanbieterprodukte stammen von Herstellern, die von Microsoft unabhängig sind. Microsoft gewährt keine implizite oder sonstige Garantie in Bezug auf die Leistung oder Zuverlässigkeit dieser Produkte.

Haftungsausschluss für Kontaktinformationen von Drittanbietern

Die Kontaktinformationen zu den in diesem Artikel erwähnten Drittanbietern sollen Ihnen helfen, zusätzliche Informationen zu diesem Thema zu finden. Diese Kontaktinformationen können ohne vorherige Ankündigung geändert werden. Sie werden von Microsoft ohne jede Gewähr weitergegeben.