Datensätze können aufgrund fehlender Objektzugriffe in Salesforce CRM nicht aktualisiert werden
Dieser Artikel hilft Ihnen bei der Behandlung und Behebung von Problemen, wenn Benutzer CRM-Datensätze in Microsoft Copilot for Sales aufgrund fehlenden Objektzugriffs in Salesforce CRM nicht aktualisieren können.
Hinweis
Microsoft Sales Copilot wird im Januar 2024 in Microsoft Copilot for Sales umbenannt. Der Screenshot in diesem Artikel wird in Kürze mit dem neuen Namen aktualisiert.
Wer ist betroffen?
Anforderungstyp | Beschreibung |
---|---|
Client-App | Copilot for Sales Outlook-Add-In |
Plattform | Web- und Desktopclients |
Betriebssystem | Windows und Mac |
Bereitstellung | Vom Benutzer verwaltet und vom Administrator verwaltet |
CRM | Salesforce |
Benutzer | Benutzer, die versuchen, einen CRM-Datensatz von Copilot for Sales zu aktualisieren |
Symptome
Wenn ein Benutzer versucht, einen CRM-Datensatz aus dem Copilot for Sales-Add-In für Outlook zu aktualisieren, wird die folgende Fehlermeldung angezeigt:
Um Salesforce zu aktualisieren, fragen Sie nach Bearbeitungszugriff für dieses Objekt.
Ursache
Der Benutzer hat keinen Bearbeitungszugriff auf ein Objekt in Salesforce.
Wenn ein Benutzer versucht, ein Objekt zu bearbeiten, überprüft Copilot for Sales, ob der Benutzer Schreibzugriff auf das Objekt in Salesforce hat. Wenn der Benutzer keinen Schreibzugriff auf das Objekt hat, wird die Fehlermeldung angezeigt.
Sie können überprüfen, ob der Benutzer ohne Schreibzugriff auf die Entität die Grundursache des Problems ist, wenn in den Protokollen der folgende Fehler angezeigt wird:
Exception thrown in VivaSalesContacts/UpdateContact -
Microsoft.SalesProductivity.Common.Base.SPServiceException: Salesforce failed to complete task: Message: entity is deleted clientRequestId:<CLIENT REQUEST ID>-self --->
System.Exception: {
"status": 400,
"message": "Object type contact is not supported. If you are attempting to use a custom object, be sure to append the '__c' after the entity name.
Please reference your WSDL or the describe call for the appropriate names\r\nclientRequestId: <CLIENT REQUEST ID>-self",
"error": null,
"source": "Salesforce.Common",
"errors": []
}
In der obigen Fehlermeldung gibt an, Object type contact is not supported
dass der Benutzer keinen Schreibzugriff auf das Contact
Objekt hat.
Lösung
Um das Problem zu beheben, stellen Sie sicher, dass der Benutzer über Folgendes verfügt:
- Lese- oder Schreibberechtigungen für das Objekt, das der Benutzer in Salesforce zu bearbeiten versucht.
- Lese- oder Schreibberechtigungen für alle Felder, die für die Bearbeitung konfiguriert sind.
Informationen zur Sicherheit auf Objektebene, zur Sicherheit auf Feldebene und zur Sicherheit auf Datensatzebene in Salesforce finden Sie unter Steuern, wer was sieht. Sie können sich auch an Ihren Salesforce-Administrator wenden, um Hilfe beim Festlegen von Objektberechtigungen in Profilen zu erhalten.
Weitere Informationen
Wenn Ihr Problem immer noch nicht gelöst ist, wechseln Sie zum Copilot for Sales - Microsoft Community Hub , um mit unseren Experten zu interagieren.
Informationen zum Haftungsausschluss von Drittanbietern
Die in diesem Artikel genannten Drittanbieterprodukte stammen von Herstellern, die von Microsoft unabhängig sind. Microsoft gewährt keine implizite oder sonstige Garantie in Bezug auf die Leistung oder Zuverlässigkeit dieser Produkte.
Haftungsausschluss für Kontaktinformationen von Drittanbietern
Die Kontaktinformationen zu den in diesem Artikel erwähnten Drittanbietern sollen Ihnen helfen, zusätzliche Informationen zu diesem Thema zu finden. Diese Kontaktinformationen können ohne vorherige Ankündigung geändert werden. Sie werden von Microsoft ohne jede Gewähr weitergegeben.