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Dieser Artikel hilft Ihnen, das Problem zu beheben, bei dem Sie möglicherweise keine Verbindung mit einer benannten Instanz von Analysis Services herstellen können, die in einem Failovercluster installiert ist.
Ursprüngliche Produktversion: SQL Server
Ursprüngliche KB-Nummer: 2429685
Problembeschreibung
Möglicherweise können Sie keine Verbindung mit einer benannten Instanz von Analysis Services herstellen, die auf einem Failovercluster installiert ist. Möglicherweise erhalten Sie eine Fehlermeldung, die den folgenden ähnelt:
Es kann keine Verbindung mit <dem Servernamen hergestellt werden.>
ZUSÄTZLICHE INFORMATIONEN:
Es kann keine Verbindung hergestellt werden. Stellen Sie sicher, dass der Server ausgeführt wird. (Microsoft.AnalysisServices.AdomdClient)
Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die <IP-Adresse> aktiv abgelehnt hat:2383 (System)
Ursache
Das Problem tritt auf, wenn Sie die benannte Instanz von SQL Server Analysis Services (SSAS) mit entweder SQL Server-Konfigurations-Manager oder dem Services-Applet in der Systemsteuerung starten. Wenn Sie eine SSAS-Instanz auf einem Failovercluster mithilfe eines anderen Tools als Failoverclusterverwaltung (Clusteradministrator auf älteren Betriebssystemen) starten, wird die SSAS-Instanz als eigenständige Instanz ausgeführt und überwacht einen nicht standardmäßigen Port, was zu Verbindungsfehlern aus verschiedenen Anwendungen führt.
Lösung
Beenden Und starten Sie die SQL Server Analysis Services mithilfe des Failovercluster-Verwaltungstools neu.
Weitere Informationen
Eine SSAS-Instanz, die auf einem Cluster gestartet wurde (Standard- oder benannte Instanz), beginnt mit der Überwachung aller IP-Adressen der Clustergruppe mithilfe des Standardports von 2383. Die Servereinstellungseigenschaft <Port>
ändert nicht die Portnummer des SSAS-Diensts in einem Cluster.