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Kommunikationsprobleme bei einem Data Protection Manager-Agent

Dieser Artikel hilft Ihnen, Fehlermeldungen zu Kommunikationsproblemen zu beheben, die auf einem DPM-Agent (Data Protection Manager) auftreten.

Ursprüngliche Produktversion: System Center Data Protection Manager
Ursprüngliche KB-Nummer: 970090

Problembeschreibung

Auf einem DPM-Agent erhalten Sie die folgenden Fehlermeldungen zu Kommunikationsproblemen:

Ein DPM-Agent konnte aufgrund eines Kommunikationsfehlers nicht mit dem DPM-Dienst auf <dem Server> kommunizieren. Stellen Sie sicher, dass <der Server> über den Computer, auf dem der DPM-Agent ausgeführt wird, remote zugreifen kann. Wenn eine Firewall auf <dem Server> aktiviert ist, stellen Sie sicher, dass sie keine Anforderungen vom Computer blockiert, auf dem der DPM-Agent ausgeführt wird (Fehlercode: 0x800706ba, vollständiger Name: <Server>).

DPM konnte nicht mit dem Schutz-Agent auf <dem Server> kommunizieren, da der Zugriff verweigert wurde. (ID 42 Details: Zugriff verweigert (0x80070005))

Fehler 270: Fehler beim Agent-Vorgang auf dem <Server> , da DPM nicht mit dem DPM-Schutz-Agent kommunizieren konnte. Der Computer kann von einem anderen DPM-Server geschützt werden, oder der Schutz-Agent wurde auf dem geschützten Computer deinstalliert.

Ursache

Dieses Problem tritt auf, wenn ein DPM-Computerkonto aus einer der folgenden Sicherheitsgruppen auf dem geschützten Server fehlt:

  • DPMRADmTrustedMachines
  • DPMRADCOMTrustedMachines
  • Distributed COM-Benutzer

Lösung

Wenn das DPM-Computerkonto in einer der Sicherheitsgruppen fehlt, die im Abschnitt "Ursache" aufgeführt sind, fügen Sie das DPM-Computerkonto manuell hinzu.

Wenn beispielsweise der Name des DPM-Servers DPM01 lautet und dieser Name zur Contoso-Domäne gehört, sollte Conotoso\DPM01 als Mitglied jeder Gruppe auf dem geschützten Server angezeigt werden.

In einer Situation, in der der geschützte Server ein Domänencontroller ist, könnte eine fehlgeschlagene Installation des Schutz-Agents dazu führen, dass die DPMRADmTrustedMachines - und DPMRADCOMTrustedMachines-Gruppen entfernt werden. Sie können dieses Problem beheben, indem Sie den folgenden Befehl ausführen:

<drive letter>:\Program Files\Microsoft Data Protection Manager\bin\SetDpmServer.exe -dpmServerName <DPM server name>

Der letzte Teil dieses Befehls könnte z. B. wie folgt aussehen:

SetDpmServer.exe -dpmServerName DPM01

Notiz

  • DPM01 ist der tatsächliche DPM-Servername.
  • Mit diesem Befehl werden die beiden Gruppen in Active Directory neu erstellt, und es wird das DPM-Computerkonto zu diesen Gruppen und der Gruppe "Verteilte COM-Benutzer " hinzugefügt.