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Fehler 0x80004005: Nicht angegebener Fehler beim Starten des OpalisActionService-Diensts

Dieser Artikel hilft bei der Behebung eines Problems, bei dem Sie den Fehler 0x80004005 erhalten: Fehlermeldung nicht angegeben, wenn Sie versuchen, den OpalisActionService-Dienst zu starten.

Gilt für: Alle Versionen von Orchestrator
Ursprüngliche KB-Nummer: 2023357

Symptome

Beim Versuch, den OpalisActionService-Dienst mit dem Windows Services-Applet zu starten, wird der folgende Fehler empfangen:

Fehler 0x80004005: Nicht angegebener Fehler

Die folgenden Fehler können in den Aktionsserverprotokollen (bei Verwendung von SQL Server) erfasst werden:

Db-Verbindung kann nicht geöffnet werden
[DBNETLIB][ConnectionOpen (Connect()).]SQL Server ist nicht vorhanden oder der Zugriff verweigert.
-2147467259

Ursache

Der OpalisActionService-Prozess kann keine Verbindung mit der Datenbank herstellen. Dies kann aus einem der folgenden Gründe sein:

  1. Die Datenbankinstanz wird nicht ausgeführt.
  2. Hostname, der für den Datenbankserver bereitgestellt wird, wird nicht ordnungsgemäß über das Domain Name System (DNS) aufgelöst.
  3. Auf eine falsche Datenbankinstanz wurde verwiesen.
  4. Möglicherweise wurde ein nicht standardmäßiger TCP-/IP-Port (Transmission Control Protocol) für TCP/IP-Konnektivität konfiguriert.
  5. TCP/IP ist möglicherweise nicht als akzeptable Bindung konfiguriert oder eine alternative Protokollbindung kann mit höherer Priorität konfiguriert werden, sodass Verbindungen von einigen Standorten funktionieren, aber nicht als andere (z. B. lokal oder remote).
  6. Das bereitgestellte Benutzerkonto verfügt nicht über die Berechtigung für den Zugriff auf die Datenbank.

Lösung

Beheben Sie das Problem, das verhindert, dass der OpalisActionService-Prozess auf die Datenbank zugreift.

  1. Überprüfen, ob die Datenbankinstanz ausgeführt wird

    Wenn die Datenbankinstanz nicht ausgeführt wird, kann sie die Verbindungen vom OpalisActionService-Dienst nicht akzeptieren. Wenn der OpalisActionService-Dienst den ersten Kontakt mit der Datenbank nicht herstellen kann, ist er so konzipiert, dass er beendet wird. Dies tritt nur auf, wenn die Konnektivität beim Dienststart nicht abgerufen werden kann. Wenn der Action Server auf demselben Server wie die Datenbank installiert ist, kann ein Fehler beim Starten des OpalisActionService-Diensts beim Computerstart das Ergebnis der Datenbankinstanz sein, die noch nicht gestartet wurde. Dies kann gelöst werden, indem eine Abhängigkeit im OpalisActionService-Dienst für den Datenbankinstanzdienst eingerichtet wird.

  2. Überprüfen des Hostnamens des Datenbankservers

    Überprüfen Sie, ob der Hostname des Datenbankservers keinen Tippfehler hat, und überprüfen Sie, ob der entsprechende Hostname auf Netzwerkdatenverkehr antwortet (z. B. Ping für Antwort und Überprüfung, dass die richtige IP antwortet).

  3. Falsche Datenbankinstanz

    Überprüfen Sie, ob auf die entsprechende Instanz verwiesen wird.

  4. Datenbankinstanzport

    Überprüfen Sie, ob der erwartete Port für die Verwendung konfiguriert wurde.

  5. Protokollkonfiguration

    Wenn mehrere Protokolle verwendet werden, können andere Protokolle als TCP/IP dazu führen, dass verbindungen von einigen Standorten funktionieren, aber von anderen nicht ausgeführt werden (z. B. lokal oder remote). Wenn mehrere Protokolle auf dem Datenbankserver konfiguriert sind, kann es erforderlich sein, das zu verwendende Protokoll explizit zu definieren.

  6. Benutzerkontoberechtigung

    Das Benutzerkonto wird mithilfe des Konfigurationshilfsprogramms für die Datenbankkonfiguration des Opalis-Integrationsservers definiert. Wenn Microsoft SQL Server als Datenbankserver mit Windows-Authentifizierung als ausgewählter Sicherheitsanbieter verwendet wird, wird das Benutzerkonto, das den OpalisActionService-Dienst startet, genutzt. Das konfigurierte Konto muss über Lese- und Schreibberechtigungen für die Opalis-Datenbank verfügen.