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Sie können in System Center 2012 R2 Operations Manager nicht auf die Unix/Linux-Computeransicht zugreifen.

Dieser Artikel hilft Ihnen, ein Problem zu beheben, bei dem Sie nicht auf die UNIX/Linux-Computeransicht in Microsoft System Center 2012 R2 Operations Manager zugreifen können.

Ursprüngliche Produktversion: System Center 2012 R2 Operations Manager
Ursprüngliche KB-Nummer: 4075004

Problembeschreibung

Sie können nicht auf die UNIX/Linux-Computeransicht im Verwaltungsbereich in System Center 2012 R2 Operations Manager zugreifen. Wenn dieses Problem auftritt, erhalten Sie die folgende Fehlermeldung:

Datum: <DateTime>
Anwendung: Operations Manager
Anwendungsversion: <VersionNumber>
Schweregrad: Fehler
Meldung:
System.NullReferenceException: Objektverweis wird nicht auf eine Instanz eines Objekts festgelegt.
at Microsoft.SystemCenter.CrossPlatform.UI.OM.Integration.UnixComputerOperatingSystemHelper.JoinCollections(IEnumerable'1 managementServers, IEnumerable'1 resourcePools, IEnumerable'1 unixcomputer, IEnumerable'1 operatingSystems)
at Microsoft.SystemCenter.CrossPlatform.UI.OM.Integration.UnixComputerOperatingSystemHelper.GetUnixComputerOperatingSystemInstances(String criteria)
at Microsoft.SystemCenter.CrossPlatform.UI.OM.Integration.Administration.UnixAgentQuery.DoQuery(String criteria)
at Microsoft.EnterpriseManagement.Mom.Internal.UI.Cache.Query'1.DoQuery(String criteria, Nullable'1 lastModified)
at Microsoft.EnterpriseManagement.Mom.Internal.UI.Cache.Query'1.FullUpdateQuery(CacheSession session, IndexTable& indexTable, Boolean forceUpdate, DateTime queryTime)
at Microsoft.EnterpriseManagement.Mom.Internal.UI.Cache.Query'1.InternalSyncQuery(CacheSession session, IndexTable indexTable, UpdateReason reason, UpdateType updateType)
at Microsoft.EnterpriseManagement.Mom.Internal.UI.Cache.Query'1.InternalQuery(CacheSession session, UpdateReason reason)
at Microsoft.EnterpriseManagement.Mom.Internal.UI.Cache.Query'1.TryDoQuery(UpdateReason reason, CacheSession session)
at Microsoft.EnterpriseManagement.Mom.Internal.UI.Console.Console.ConsoleJobExceptionHandler.ExecuteJob(IComponent component, EventHandler'1 job, Object sender, ConsoleJobEventArgs args)

Ursache

Das Problem tritt auf, wenn der UNIX/Linux-Überwachungsressourcenpool gelöscht wird.

Lösung

Gehen Sie folgendermaßen vor, um das Problem zu beheben:

  1. Erstellen Sie einen Ressourcenpool für UNIX/Linux-Überwachung. Weisen Sie dem neuen Pool einen anderen Namen als den Namen des gelöschten Ressourcenpools zu.

  2. Fügen Sie die Verwaltungsserver hinzu, die UNIX/Linux-Überwachung durchführen, zum neuen Ressourcenpool.

  3. Konfigurieren Sie die UNIX/Linux Run As-Konten, die vom neuen Ressourcenpool verteilt werden sollen. Gehen Sie dazu wie folgt vor:

    1. Wechseln Sie in der Operations-Konsole zu "Administration>Run As Configuration>UNIX/Linux Accounts".

    2. Führen Sie für jedes Konto die folgenden Schritte aus:

      1. Klicken Sie mit der rechten Maustaste auf das Konto, und wählen Sie dann "Eigenschaften" aus.
      2. Wählen Sie auf der Seite "Distribution Security " des UNIX/Linux Run As Accounts Wizard die Option "Sicherer" aus.
      3. Wählen Sie in ausgewählten Computern und Ressourcenpools "Hinzufügen" aus.
      4. Wählen Sie "Nach Ressourcenpoolnamen suchen" und dann "Suchen" aus.
      5. Wählen Sie den neuen Ressourcenpool aus, der in Schritt 1 erstellt wird, wählen Sie "Hinzufügen" und dann "OK" aus.
  4. Führen Sie das folgende PowerShell-Cmdlet aus, um die verwalteten UNIX- und Linux-Computer abzurufen:

    Get-SCXAgent
    
  5. Stellen Sie sicher, dass die Agents, die dem gelöschten Ressourcenpool zugeordnet sind, weiterhin vorhanden sind und dass die Beziehung erhalten bleibt.

  6. Führen Sie den folgenden Befehl aus, um den verwalteten Ressourcenpool in den in Schritt 1 erstellten zu ändern:

    $SCXPool = Get-SCOMResourcePool -DisplayName "<New Resource Pool Name>"
    Get-SCXAgent | Set-SCXResourcePool -ResourcePool $SCXPool
    

References