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In diesem Artikel wird ein Problem behoben, bei dem Sie keine Verbindung mit einem virtuellen Hyper-V-Computer (VM) herstellen können, und der Fehler "Virtual Machine Manager" hat die Verbindung mit dem virtuellen Computer verloren.
Ursprüngliche Produktversion: System Center Virtual Machine Manager
Ursprüngliche KB-Nummer: 2288932
Problembeschreibung
Bei der Authentifizierung beim System Center Virtual Machine Manager Self-Service Portal (SSP) führt die Auswahl eines virtuellen Computers (VM), der unter Windows Hyper-V gehostet wird, und das Klicken auf "Mit vm verbinden" dazu führt, dass die folgende Fehlermeldung auf einem weißen Bildschirm angezeigt wird:
Der Virtual Machine Manager hat die Verbindung mit dem virtuellen Computer verloren, da eine andere Verbindung mit diesem Computer hergestellt wurde.
Nehmen Sie das folgende Szenario als Beispiel:
- Es sind zwei Benutzerkonten vorhanden: User1 und User2.
- User1 ist in SCVMM nicht überall konfiguriert.
- User2 ist Mitglied einer Self-Service-Benutzerrolle in SCVMM und ist der Besitzer einer VM.
- Benutzer1 meldet sich bei einem Windows-Client an und stellt eine Verbindung mit dem SSP bereit, bei dem er sich als Benutzer2 authentifiziert.
- Der virtuelle Computer im Besitz von User2 wird aus der Liste ausgewählt, und auf die Schaltfläche "Mit vm verbinden" wird geklickt.
In diesem Szenario wird die obige Fehlermeldung angezeigt.
Ursache
Dieses Problem kann auftreten, da die Anmeldeinformationen für das bei Windows angemeldete Benutzerkonto (User1) anstelle der Anmeldeinformationen für den SSP (User2) übergeben werden.
Standardmäßig ist das Optionsfeld "Meine Anmeldeinformationen nicht speichern" ausgewählt, wodurch dieses Verhalten verursacht wird.
Benutzer1 kann auf dem Hyper-V-Host authentifiziert werden, der Autorisierungs-Manager (AzMan) kann jedoch keine Aufzeichnung seiner Berechtigungen finden, um eine Verbindung mit der Konsole des virtuellen Computers herzustellen. (Wenn die Authentifizierung erfolgreich ist, wird sie nicht als fehlgeschlagener Anmeldeversuch betrachtet.)
Lösung
Um dieses Problem zu beheben, wählen Sie das Optionsfeld "Meine Anmeldeinformationen speichern" auf der Anmeldeseite des SSP aus. Dadurch werden die hier eingegebenen Anmeldeinformationen übergeben, wenn auf "Mit vm verbinden" geklickt wird.
Weitere Informationen
Wenn User2 bei Windows angemeldet war, tritt das Problem nicht auf, da beide Anmeldeinformationen übereinstimmen. Wenn Sie als lokales Benutzerkonto anstelle eines Domänenkontos bei Windows angemeldet sind, fordert der Anmeldeinformations-Manager beim Klicken auf die Anmeldeinformationen auf, da lokale Konten nicht auf Remotecomputern verwendet werden können (und die Anmeldeinformationen für User2 hier eingegeben werden können).