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In diesem Artikel wird ein Problem beschrieben, bei dem die Systemdateiprüfung Windows Defender PowerShell-Moduldateien fälschlicherweise als beschädigt gekennzeichnet.
Gilt für: Windows-Client
Ursprüngliche KB-Nummer: 4513240
Problembeschreibung
Das SFC-Tool (System File Checker) kennzeichnet Dateien, die sich im Ordner "%windir%\System32\WindowsPowerShell\v1.0\Modules\Defender " befinden, als beschädigt oder beschädigt. Wenn dieses Problem auftritt, werden Fehlereinträge angezeigt, die wie folgt aussehen:
Hashes für Das Dateielement stimmen nicht überein.
Ursache
Dies ist ein bekanntes Problem in Windows 10, Version 1607 und höher, und Windows Defender, Version 4.18.1906.3 und höher, bis Version 4.8.1908.
Die Dateien für das Windows Defender PowerShell-Modul, das sich im Windows-Image " %windir%\System32\WindowsPowerShell\v1.0\Modules\Defender " befindet. Diese Dateien sind katalogsignieren. Die Verwaltbarkeitskomponente von Windows Defender verfügt jedoch über einen neuen Out-of-Band(OOB)-Updatekanal. Dieser Kanal ersetzt die ursprünglichen Dateien durch aktualisierte Versionen, die mit einem Microsoft-Zertifikat signiert sind, dem das Windows-Betriebssystem vertraut. Aufgrund dieser Änderung kennzeichnet SFC die aktualisierten Dateien als "Hashes für Dateimitglied stimmen nicht überein".
Zukünftige Versionen von Windows verwenden die aktualisierten Dateien im Windows-Image. Nachdem diese Änderung implementiert wurde, kennzeichnet SFC die Dateien nicht mehr.
Lösung
Dieses Problem wurde im Update 4.8.1908 von Windows Defender behoben. Nachdem dieses Update angewendet wurde, werden PowerShell-Dateien, die Teil des Windows-Images sind, nicht geändert, und das SFC-Tool kennzeichnet diese Dateien nicht mehr. Mit dem Internet verbundene Computer, die den Windows Update-Kanal abonnieren, laden dieses Update automatisch herunter und installieren es.
Verwenden Sie das DISM-Tool, um die Windows-Imagedateien auf Computern zu reparieren, die von diesem Problem betroffen sind. Öffnen Sie dazu ein Eingabeaufforderungsfenster auf dem betroffenen Computer, und führen Sie die folgenden Befehle aus:
dism /online /cleanup-image /restorehealth
sfc /scannow
Wenn diese Befehle fehlschlagen und eine Fehlermeldung generieren, die "Datei nicht gefunden" ähnelt, stellen Sie sicher, dass auf die Datei "Install.wim" zugegriffen werden kann, und führen Sie dann die folgenden Befehle aus:
DISM /Online /Cleanup-Image /RestoreHealth /Source:WIM:c:\install.wim:1 /LimitAccess
sfc /scannow
Weitere Informationen zu Reparaturbefehlen finden Sie unter Reparieren eines Windows-Images.
Datensammlung
Wenn Sie Unterstützung vom Microsoft-Support benötigen, empfehlen wir Ihnen, die Informationen zu sammeln, indem Sie die Schritte unter Sammeln von Informationen mithilfe von TSS für Bereitstellungsprobleme ausführen.