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Systemfehler 126 beim Starten des Windows Modules Installer-Diensts (TrustedInstaller): Das spezifische Modul konnte nicht gefunden werden.

Dieser Artikel hilft beim Beheben des Systemfehlers 126, der auftritt, wenn Sie den Windows Modules Installer-Dienst starten.

Gilt für: Windows 7 Service Pack 1, Windows Server 2008 R2 Service Pack 1
Ursprüngliche KB-Nummer: 959077

Problembeschreibung

Wenn Sie den Windows Modules Installer-Dienst starten, erhalten Sie die folgende Fehlermeldung:

Screenshot des Windows Modules Installer-Diensts Fehler 126.

Außerdem wird an der Eingabeaufforderung eine Fehlermeldung angezeigt:

Screenshot der Fehlermeldung an der Eingabeaufforderung: Systemfehler 126 ist aufgetreten.

Ursache

Dieses Problem tritt auf, wenn der folgende Registrierungsunterschlüssel geändert wird:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\Version

Lösung

Um dieses Problem zu beheben, müssen Sie den erweiterbaren Zeichenfolgenwert des Registrierungsunterschlüssels, der im Abschnitt "Ursache " erwähnt wird, erneut erstellen.

Zunächst müssen Sie überprüfen, ob der Registrierungsunterschlüssel vorhanden ist. Starten Sie dazu den Registrierungs-Editor, und navigieren Sie dann zum Unterschlüssel, der im Abschnitt "Ursache " erwähnt wird. Wenn der Unterschlüssel nicht vorhanden ist, müssen Sie ihn erstellen. Gehen Sie dazu wie folgt vor:

  1. Suchen Sie das C:\Windows\Servicing\Version Verzeichnis, und notieren Sie sich den Namen des Unterordners in diesem Verzeichnis. Es wird ungefähr wie 6.1.7600.16385 benannt. Dies ist Ihre TrustedInstaller-ID.

  2. Kopieren Sie den Namen des Unterordners in die Zwischenablage, und fügen Sie ihn dann zur Sicherstellung in Editor ein.

    Screenshot des Unterordnernamens in diesem Verzeichnis.

    Notiz

    In diesem Beispiel ist die TrustedInstaller-ID 6.1.7601.17592.

  3. Suchen Sie im C:\Windows\WinSxS Verzeichnis nach einem Unterordner, dessen Name mit einer der folgenden Zeichenfolgen beginnt. (Im folgenden Unterordnernamen wird der Platzhalter TrustedInstaller-ID stellt Ihre TrustedInstaller-ID dar.)

    Für 32-Bit-Windows: x86_microsoft-windows-servicingstack_31bf3856ad364e35_ TrustedInstaller ID _none

    Für 64-Bit-Windows: amd64_microsoft-windows-servicingstack_31bf3856ad364e35_ TrustedInstaller ID _none

  4. Kopieren Sie den Namen des Unterordners in die Zwischenablage, und fügen Sie ihn dann zur Sicherstellung in Editor ein.

    Screenshot des Suchergebniss des Unterordnernamens im Verzeichnis

  5. Erstellen Sie den Registrierungsunterschlüssel HKLM\Software\Microsoft\Windows\CurrentVersion\Component Based Servicing\Version.

    Notiz

    Um diesen Schlüssel zu erstellen, müssen Sie besitzer des komponentenbasierten Wartungsschlüssels sein. Anschließend müssen Sie sich selbst vollzugriffsberechtigungen erteilen.

  6. Erstellen Sie auf dem in Schritt 5 erstellten Versionsschlüssel einen erweiterbaren Zeichenfolgenwert (oder bearbeiten Sie ihn, wenn er bereits vorhanden ist). Verwenden Sie dazu die TrustedInstaller-ID als Namen, und verwenden Sie den vollständigen Pfad des Ordners, den Sie in Schritt 3 als Wert identifiziert haben.

    Notiz

    Im vollständigen Pfad müssen %SystemRoot%\WinSxS\folder_name Sie anstelle von C:\Windows\WinSxS\folder_name.

    Screenshot einer Beispieleinstellung für einen Zeichenfolgenwert des Versionsschlüssels.

  7. Klicken Sie auf "OK", und beenden Sie dann den Registrierungs-Editor.

Sie können nun den Windows Modules Installer (TrustedInstaller)-Dienst wie gewohnt starten.

Datensammlung

Wenn Sie Unterstützung vom Microsoft-Support benötigen, empfehlen wir Ihnen, die Informationen zu sammeln, indem Sie die Schritte unter Sammeln von Informationen mithilfe von TSS für Bereitstellungsprobleme ausführen.