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Code 31-Fehler in Geräte-Manager für WAN Miniport -Gerät (Netzwerkmonitor) in Windows

Dieser Artikel enthält eine Problemumgehung für ein Problem, bei dem Geräte-Manager neben dem WAN Miniport -Gerät (Netzwerkmonitor) ein gelbes Ausrufezeichen anzeigt.

Ursprüngliche KB-Nummer: 2871372

Problembeschreibung

Stellen Sie sich folgendes Szenario vor:

  • Sie installieren Windows.
  • Sie öffnen Geräte-Manager nach Abschluss der Installation.

In diesem Szenario zeigt Geräte-Manager ein gelbes Ausrufezeichen neben dem WAN Miniport -Gerät (Netzwerkmonitor) an. Darüber hinaus zeigt die Registerkarte "Details " des Geräteeigenschaftenfensters die folgende Meldung an:

Das Gerät funktioniert nicht ordnungsgemäß, da Windows die für dieses Gerät erforderlichen Treiber nicht laden kann. (Code 31)

Ursache

Dieses Problem tritt auf, da Windows die Treiber, die für das WAN-Gerät (Netzwerkmonitor) erforderlich sind, nicht laden kann. Da dem Gerät kein Treiber zugeordnet ist, kann er nicht aus Geräte-Manager entfernt werden.

Lösung

Um dieses Problem bei zukünftigen Installationen zu verhindern, müssen Sie Update-2822241 in die Installationsmedien integrieren, die Sie während des Setups verwenden.

Informationen zur Verwendung von Deployment Image Servicing and Management (DISM) zum Integrieren eines Hotfixpakets in Installationsmedien finden Sie unter Hinzufügen oder Entfernen von Paketen offline.

Problemumgehung

Wenn Sie das Betriebssystem bereits installiert haben und derzeit einen Fehler "Code 31" auf dem WAN Miniport -Gerät (Netzwerkmonitor) erhalten, führen Sie die folgenden Schritte aus:

  1. Öffnen Sie den Geräte-Manager.
  2. Klicken Sie mit der rechten Maustaste auf das WAN-Miniportgerät (Netzwerkmonitor), und klicken Sie dann auf "Treibersoftware aktualisieren".
  3. Klicken Sie auf " Meinen Computer durchsuchen", um treibersoftware zu suchen.
  4. Klicken Sie auf " Auswahl zulassen" aus einer Liste der Gerätetreiber auf meinem Computer.
  5. Deaktivieren Sie das Kontrollkästchen "Kompatible Hardware anzeigen".
  6. Wählen Sie in der Spalte auf der linken Seite Microsoft aus, und wählen Sie in der Spalte auf der rechten Seite den Microsoft KM-TEST-Loopbackadapter aus.
  7. Klicken Sie im Dialogfeld "Treiberwarnung aktualisieren" auf "Ja ", um die Installation dieses Treibers fortzusetzen.
  8. Nachdem der Treiber installiert wurde, klicken Sie mit der rechten Maustaste auf das Gerät, und klicken Sie dann auf " Deinstallieren".
  9. Nachdem das Gerät deinstalliert wurde, klicken Sie mit der rechten Maustaste auf den Computernamen in Geräte-Manager, und klicken Sie dann auf "Nach Hardwareänderungen suchen".
  10. Klicken Sie im Menü "Ansicht" auf " Ausgeblendete Geräte anzeigen". Das WAN Miniport -Gerät (Netzwerkmonitor) sollte jetzt gestartet werden und hat kein gelbes Ausrufezeichen mehr daneben.