Freigeben über


Internetfirewalls können das Browsen und die Dateifreigabe verhindern

Wenn Sie eine Firewall aktivieren, können Sie möglicherweise daran hindern, Dateien mit anderen Computern in einem Heimnetzwerk zu durchsuchen oder freizugeben.

Ursprüngliche KB-Nummer: 298804

Symptome

Nachdem Sie eine Internetfirewall aktiviert haben, können Sie möglicherweise nicht nach anderen Computern in Ihrem Heim- oder Büronetzwerk suchen oder suchen. Möglicherweise können Sie Dateien nicht für andere Computer in Ihrem Heim- oder Büronetzwerk freigeben. Wenn Sie beispielsweise das Feature "Internet Connection Firewall(ICF)" in Windows XP aktivieren, stellen Sie fest, dass Sie Ihr Netzwerk nicht mithilfe von "Meine Netzwerkorte" durchsuchen können. Wenn Sie den net view \\computername Befehl verwenden, um Freigaben auf einem Computer in Ihrem Heim- oder Büronetzwerk anzuzeigen, wird möglicherweise die folgende Fehlermeldung angezeigt:

Systemfehler 6118 ist aufgetreten. Die Liste der Server für diese Arbeitsgruppe ist derzeit nicht verfügbar.

Ursache

Dieses Verhalten kann auftreten, wenn Sie eine Firewall in der Netzwerkverbindung aktivieren, die Sie für Ihr Heim- oder Büronetzwerk verwenden. Standardmäßig schließt eine Firewall die Ports, die für die Datei- und Druckfreigabe verwendet werden. Der Zweck besteht darin, zu verhindern, dass Internetcomputer eine Verbindung mit Datei- und Druckfreigaben auf Ihrem Computer herstellen.

Lösung

Um dieses Verhalten zu beheben, verwenden Sie eine Firewall nur für Netzwerkverbindungen, die Sie verwenden, um eine direkte Verbindung mit dem Internet herzustellen. Verwenden Sie beispielsweise eine Firewall auf einem einzelnen Computer, der direkt über ein Kabelmodem, ein DSL-Modem oder ein DFÜ-Modem mit dem Internet verbunden ist. Wenn Sie dieselbe Netzwerkverbindung verwenden, um eine Verbindung mit dem Internet und einem Heim- oder Büronetzwerk herzustellen, verwenden Sie einen Router oder eine Firewall, der verhindert, dass Internetcomputer eine Verbindung mit den gemeinsam genutzten Ressourcen auf den Heim- oder Bürocomputern herstellen.

Verwenden Sie keine Firewall für Netzwerkverbindungen, die Sie zum Herstellen einer Verbindung mit Ihrem Heim- oder Büronetzwerk verwenden, es sei denn, die Firewall kann so konfiguriert werden, dass ports nur für Ihr Heim- oder Büronetzwerk geöffnet werden. Wenn Sie über Ihr Heim- oder Büronetzwerk eine Verbindung mit dem Internet herstellen, kann eine Firewall nur auf dem Computer oder dem anderen Gerät verwendet werden, z. B. einem Router, der die Internetverbindung bereitstellt. Wenn Sie beispielsweise über ein von Ihnen verwaltetes Netzwerk eine Verbindung mit dem Internet herstellen und dieses Netzwerk verbindungsfreigaben verwendet, um Internetzugriff auf mehrere Computer bereitzustellen, können Sie eine Firewall nur in der freigegebenen Internetverbindung installieren oder aktivieren. Wenn Sie über ein Netzwerk, das Sie nicht verwalten, eine Verbindung mit dem Internet herstellen, überprüfen Sie, ob Ihr Netzwerkadministrator eine Firewall verwendet.

Status

Es handelt sich hierbei um ein beabsichtigtes Verhalten.

Weitere Informationen

Eine Firewall ist Software oder Hardware, die eine Schutzbarriere zwischen Ihrem Computer und potenziell schädlichen Inhalten im Internet erzeugt. Es hilft, Ihren Computer vor böswilligen Benutzern und vor vielen Computerviren und Würmern zu schützen.

Wichtig

Wenn Sie eine Firewall einrichten, um Computerports zu schützen, die mit dem Internet verbunden sind, wird nicht empfohlen, diese Ports zu öffnen, da sie für andere Computer im Internet verfügbar gemacht werden können. Darüber hinaus können bestimmten Computern kein Zugriff auf die geöffneten Ports gewährt werden.

Die folgenden Ports sind mit der Kommunikation zwischen Dateifreigabe und Servernachrichtenblock (SMB) verknüpft:

  • Microsoft File Sharing SMB: UDP-Ports (User Datagram Protocol) von 135 bis 139 und TCP-Ports (Transmission Control Protocol) von 135 bis 139.
  • Direkt gehosteter SMB-Datenverkehr ohne netzwerkbasiertes Eingabe-/Ausgabesystem (NetBIOS): Port 445 (TCP und UDP).

Technischer Support für Windows x64-Editionen

Ihr Hardwarehersteller bietet technischen Support und Unterstützung für Microsoft Windows x64-Editionen. Ihr Hardwarehersteller bietet Unterstützung, da eine Windows x64-Edition in Ihrer Hardware enthalten war. Möglicherweise hat Ihr Hardwarehersteller die Installation der Windows x64-Edition mit eindeutigen Komponenten angepasst. Dazu gehören beispielsweise bestimmte Gerätetreiber oder optionale Einstellungen zur Leistungsoptimierung der Hardware. Microsoft stellt angemessene Unterstützung bereit, wenn Sie technische Hilfe bei Ihrer Windows x64-Edition benötigen. Sie müssen sich jedoch möglicherweise direkt an den Hersteller wenden. Der Hersteller kann Ihnen den besten Support für die von ihm auf der Hardware installierte Software bieten.

Weitere Informationen finden Sie unter "Schützen meines PCs vor Viren".