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Dieser Artikel enthält eine Lösung für ein Problem, bei dem microsoft: Protected EAP (PEAP)-Option in einigen Fällen fehlt.
Gilt für: Windows 7 Service Pack 1
Ursprüngliche KB-Nummer: 2699785
Problembeschreibung
Es gibt mehrere Symptome für das Problem:
- Microsoft: Die Option für geschützteS EAP (PEAP) fehlt möglicherweise beim Erstellen des Drahtlosprofils auf einem Client.
- Microsoft: Die Option "Geschütztes EAP(PEAP)" fehlt möglicherweise, sobald die Dateiübertragung über den Fenster-Easy Transfer-Assistenten gestartet wurde.
- Der Remotezugriff Verbindungs-Manager wird nicht gestartet.
Ursache
Der Standardspeicherort der Datei SymRasMan.dll lautet %SystemRoot%\System32\rastls.dll. Beim Installieren von Symantec Antivirus oder Symantec Endpoint Protection wird der Standardspeicherort dann in der Registrierung in "C:\Programme\ Symantec\Symantec Endpoint Protection \SymRasMan.dll" geändert und bearbeitet. Nach der Deinstallation wird dieser Speicherort nicht rückgängig gemacht. Das Problem tritt aufgrund eines Problems mit Registrierungsschlüsseln auf, die nicht auf die Standardwerte oder .dll dateien zurückgesetzt werden, die in Registrierungswerten angegeben sind, sind nach dem Entfernen von Symantec Endpoint Protection 11.0 nicht vorhanden.
Diese zwei Registrierungsstrukturen sind betroffen:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\25
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\13
Die Werte der folgenden Schlüssel unter EAP werden von C:\System32\rastls.dll in C:\Programme\Symantec\Symantec Endpoint Protection\SymRasMan.dll geändert.
- ConfigUiPath
- IdentityPath
- InteractiveUIPath
- Pfad
4 neue Registrierungsschlüssel mit dem Wert "C:\Windows\ System32\rastls.dll" werden erstellt.
- ConfigUiPathBack
- IdentityPathBack
- InteractiveUIPathBack
- PathBack
Lösung
Wichtig
Dieser Abschnitt, diese Methode bzw. diese Aufgabe enthält eine Beschreibung der Schritte zum Bearbeiten der Registrierung. Durch die falsche Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Daher müssen Sie sicherstellen, dass Sie diese Schritte sorgfältig ausführen. Für weiteren Schutz sichern Sie die Registrierung, bevor Sie sie ändern. Anschließend können Sie die Registrierung wiederherstellen, wenn ein Problem auftritt.
Um dieses Problem zu beheben, ändern Sie die Registrierung so, dass die Werte von ConfigUiPath, IdentityPath, InteractiveUIPath und Path korrigiert werden. Gehen Sie dazu wie folgt vor:
Klicken Sie auf Start und dann auf Ausführen. Geben Sie regedit& ein, und klicken Sie auf OK.
Klicken Sie auf den folgenden Registrierungsunterschlüssel:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\13
Wählen Sie den Ordner 13 aus.
Ändern des Werts für Schlüssel: ConfigUiPath, IdentityPath, InteractiveUIPath und Pfad zu: C:\Windows\ System32\rastls.dll
Navigieren Sie zu
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\25
.Wählen Sie den Ordner 25 aus.
Ändern Sie den Wert für Schlüssel: ConfigUiPath, IdentityPath, InteractiveUIPath und Pfad zu: C:\Windows\ System32\rastls.dll.
Löschen Sie die folgenden Schlüssel unter Ordner 13 und 25.
Pfad:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\13
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\25
Registrierungsschlüssel:
- ConfigUiPathBack
- IdentityPathBack
- InteractiveUIPathBack
- PathBack
Geben Sie den Registrierungs-Editor an, und starten Sie den Computer dann neu.