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Einige Windows-Prozeduren funktionieren nicht, wenn der Remoteprozeduraufrufdienst deaktiviert ist.

Dieser Artikel enthält eine Lösung für ein Problem, bei dem einige Windows-Prozeduren nicht funktionieren, wenn der Remoteprozeduraufruf (REMOTE Procedure Call, RPC)-Dienst deaktiviert ist.

Ursprüngliche KB-Nummer: 830071

Wichtig

Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Bevor Sie Änderungen an der Registrierung vornehmen, erstellen Sie eine Sicherungskopie, und stellen Sie sicher, dass Sie genau wissen, wie die Registrierung im Falle eines Problems wiederhergestellt wird. Weitere Informationen zum Sichern, Wiederherstellen und Ändern der Registrierung finden Sie unter Informationen über die Windows-Registrierung für erfahrene Benutzer.

Symptome

Wenn Sie Ihren Computer neu starten, auf dem Microsoft Windows NT 4.0, Microsoft Windows 2000, Microsoft Windows Server 2003 oder Microsoft Windows XP ausgeführt wird, können die folgenden Bedingungen auftreten:

  • Symbole können nicht auf dem Desktop verschoben werden.
  • Ereignisprotokolleinträge können nicht angezeigt werden.
  • Sie können die Microsoft Management Console (MMC) der Dienste öffnen, es werden jedoch keine Dienste aufgelistet.

Ursache

Dieses Problem kann auftreten, wenn Sie den RPC-Dienst deaktivieren. Viele Windows-Betriebssystemprozeduren hängen vom RPC-Dienst ab.

Microsoft empfiehlt, den RPC-Dienst nicht zu deaktivieren.

Lösung

Warnung

Die unkorrekte Verwendung des Registrierungseditors kann schwerwiegende Probleme verursachen, die das gesamte System betreffen und eine Neuinstallierung des Betriebssystems erforderlich machen. Microsoft kann nicht garantieren, dass Probleme, die von einer falschen Verwendung des Registrierungseditors herrühren, behoben werden können. Sie verwenden den Registrierungs-Editor auf eigene Verantwortung.

Gehen Sie folgendermaßen vor, um dieses Problem zu beheben:

  1. Klicken Sie auf "Start", klicken Sie auf "Ausführen", geben Sie "regedt32" ein, und klicken Sie dann auf "OK".
  2. Erweitern Sie den Registrierungsschlüssel HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RpcSs\.
  3. Doppelklicken Sie auf "Start", geben Sie "2" im Dialogfeld "DWORD-Wert bearbeiten" ein, und klicken Sie dann auf "OK".
  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Computer dann neu.

Wenn Ihr Computer nicht ordnungsgemäß gestartet wird, können Sie die Wiederherstellungskonsole verwenden, um den RPC-Dienst erneut zu aktivieren. Führen Sie die folgenden Schritte aus, um die Wiederherstellungskonsole zu verwenden:

  1. Starten Sie Ihren Computer mit der Wiederherstellungskonsole.
  2. Geben Sie an der Eingabeaufforderung der Wiederherstellungskonsole den Enable RPCSS Service_Auto_Start Befehl ein, und drücken Sie dann die EINGABETASTE.
  3. Geben Sie EXITan der Eingabeaufforderung der Wiederherstellungskonsole die EINGABETASTE ein, und drücken Sie dann die EINGABETASTE.
  4. Starten Sie den Computer neu.

Weitere Informationen

Die folgenden Dienste sind vom RPC-Dienst abhängig:

  • Intelligenter Hintergrundübertragungsdienst
  • COM+-Ereignissystem
  • Tacking-Client für verteilte Verknüpfungen
  • Distributed Transaction Coordinator
  • Faxdienst
  • Indexdienst
  • IPSec-Richtlinien-Agent
  • Messenger
  • Netzwerkverbindungen
  • Druckspooler
  • Geschützter Speicher
  • Wechselmedien
  • Routinginformationsprotokoll(RIP)-Listener
  • Routing und RAS
  • Aufgabenplanung
  • Telefonie
  • Telnet
  • Windows Installer
  • Windows-Verwaltungsinstrumentation

References

Weitere Informationen zur Verwendung der Wiederherstellungskonsole in Windows XP, in Windows 2000 oder in Windows Server 2003 finden Sie unter Was sind die Systemwiederherstellungsoptionen in Windows? und wie verwenden Sie die Wiederherstellungskonsole auf einem Windows Server 2003-basierten Computer, der nicht gestartet wird.