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Dieser Artikel enthält eine Lösung für ein Problem, bei dem Geräte nicht funktionieren, bevor Sie sich auf einem Computer anmelden, auf dem Windows 10 ausgeführt wird.
Gilt für: Windows 10, Version 1709
Ursprüngliche KB-Nummer: 4057300
Problembeschreibung
Stellen Sie sich folgendes Szenario vor:
Sie verfügen über einen Computer, auf dem Windows 10 ausgeführt wird, und der Computer ist mit einer Active Directory-Domäne verbunden.
Auf dem Computer ist bitLocker oder die Geräteverschlüsselung aktiviert.
Sie aktivieren die "Neue DMA-Geräte deaktivieren", wenn dieser Computer auf dem Computer gesperrt ist. Die Neuen DMA-Geräte deaktivieren, wenn dieser Computer gesperrt ist, wird im folgenden Pfad gefunden:
Computerkonfiguration\Administrative Vorlagen\Windows-Komponenten\BitLocker-LaufwerkverschlüsselungNotiz
Um zu überprüfen, ob die Richtlinie festgelegt ist, können Sie auch den folgenden Registrierungsschlüsselwert überprüfen:
Pfad:HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\FVE
Wert: DisableExternalDMAUnderLock
Typ: DWORD
Das Problem tritt auf, wenn der Wert auf 1 festgelegt ist.Sie starten den Computer neu.
In diesem Szenario werden Peripheriekomponentenverbindungsgeräte (Peripheral Component Interconnect, PCI), auf die BusMaster Enabled (BME) festgelegt ist, nicht vom Betriebssystem (Os) aufgezählt, bis sich ein Benutzer erfolgreich anmeldet. Es handelt sich hierbei um ein beabsichtigtes Verhalten.
Darüber hinaus funktionieren nach der Anmeldung eines Benutzers bestimmte interne und externe Geräteklassen möglicherweise nicht. Dazu gehören unter anderem Folgende:
- Verkabelte Netzwerkadapter
- Drahtlosnetzwerkadapter
- Audiogeräte
- Zeigegeräte einschließlich Touchpads
Ursache
Dieses Problem kann unter einer der folgenden Bedingungen auftreten:
Für die Deaktivierung neuer DMA-Geräte, wenn dieser Computer gesperrt ist, muss die Systemfirmware das BME-Bit für alle internen Geräte während des Starts ordnungsgemäß festlegen und das BME-Bit für alle extern verfügbar gemachten PCI-Ports deaktivieren.
Wenn die Systemfirmware das BME-Bit während des Starts fälschlicherweise für interne Geräte löscht, werden diese Geräte blockiert, bis eine erfolgreiche Benutzeranmeldung erfolgt.
Gerätetreiber können das vom Betriebssystem gesperrte BME-Bit erst verarbeiten, wenn sich ein Benutzer anmeldet.
Die Neuen DMA-Geräte deaktivieren, wenn dieser Computer gesperrt ist, wird vorübergehend auf Windows 10 Version 1703-Computern in bestimmten Szenarien angewendet. Windows 10, Version 1709-Computer wenden diese Richtlinie konsistent an, und dies verursacht Firmware- oder Treiberprobleme.
Weitere Informationen
Möglicherweise treten die folgenden Probleme auf der Grundlage dieser Bedingungen auf:
Wenn der Treiber korrekt ist und die Firmware korrekt ist
Interne Geräte funktionieren vor und nach dem Start. Externe PCI-Geräte werden ordnungsgemäß blockiert, bis sich ein Benutzer anmeldet.
Wenn der Treiber korrekt ist und die Firmware falsch ist
Geräte werden vor einer Anmeldung blockiert, funktionieren aber nach einer Anmeldung. Sowohl interne als auch externe Geräte, auf denen BME auf 0 festgelegt ist, werden vor der Anmeldung blockiert. Nach einer Anmeldung werden treiber richtig aufgezählt.
Wenn der Treiber falsch ist und die Firmware korrekt ist
Externe Geräte funktionieren nach einer Anmeldung möglicherweise nicht.
Wenn der Treiber falsch ist und die Firmware falsch ist
Interne Geräte, die anfänglich von der Firmware blockiert wurden, werden nach der erfolgreichen Anmeldung des Benutzers entweder nicht ordnungsgemäß aufgezählt oder fehlfunktioniert.
Lösung
Um dieses Problem zu beheben, installieren Sie den 23. April 2018-KB4093105 (Betriebssystembuild 16299.402).
Problemumgehung
Um dieses Problem zu umgehen, konfigurieren Sie die Neuen DMA-Geräte deaktivieren, wenn dieser Computer auf "Nicht konfiguriert" gesperrt ist, um es auf betroffenen Systemmodellen zu deaktivieren, bevor Sie Treiber und Firmware aktualisieren.
Datensammlung
Wenn Sie Unterstützung vom Microsoft-Support benötigen, empfehlen wir Ihnen, die Informationen zu sammeln, indem Sie die Schritte unter Sammeln von Informationen mithilfe von TSS für Bereitstellungsprobleme ausführen.