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MiracastView-Paket verursacht sysprep-Fehler nach dem Upgrade eines Computers auf Windows 10, Version 1709

Dieser Artikel enthält Problemumgehungen für ein Problem, bei dem sysprep nach dem Upgrade eines Computers auf Windows 10, Version 1709, fehlschlägt.

Gilt für: Windows 10, Version 1709
Ursprüngliche KB-Nummer: 4057974

Problembeschreibung

Stellen Sie sich folgendes Szenario vor:

  • Auf einem Windows 10 Version 1703-basierten Computer ist MiracastView eine integrierte App und standardmäßig installiert.

  • Sie aktualisieren den Computer auf Windows 10, Version 1709.

  • Sie öffnen ein Eingabeaufforderungsfenster mit Administratorberechtigung und führen den folgenden Befehl aus:

    cd %windir%\System32\Sysprep
    sysprep.exe /generalize /oobe /reboot
    

In diesem Szenario schlägt der Sysprep-Befehl fehl. Sie erhalten eine Fehlermeldung, die etwa wie folgt aussieht:

Sysprep konnte Ihre Windows-Installation nicht überprüfen. Weitere Informationen finden Sie in der Protokolldatei unter %WINDIR%\System32\Sysprep\Panther\setupact.log. Verwenden Sie nach dem Beheben des Problems Sysprep, um die Installation erneut zu überprüfen.

Die Details von Sysprep konnten ihren Windows-Installationsfehler nicht überprüfen.

Darüber hinaus enthält das Setupact-Protokoll Fehlermeldungen, die wie folgt aussehen:

Date/Time, Error SYSPRP Package Windows.MiracastView_6.3.0.0_neutral_cw5n1h2txyewy wurde für einen Benutzer installiert, aber nicht für alle Benutzer bereitgestellt. Dieses Paket funktioniert im Sysprep-Image nicht ordnungsgemäß.
Datum/Uhrzeit, Fehler SYSPRP Fehler beim Entfernen von Apps für den aktuellen Benutzer: 0x80073cf2.
Date/Time, Error SYSPRP Exit code of RemoveAllApps thread was 0x3cf2.
Datum/Uhrzeit, Fehler SYSPRP ActionPlatform::LaunchModule: Fehler beim Ausführen von 'SysprepGeneralizeValidate' von C:\Windows\System32\AppxSysprep.dll; dwRet = 0x3cf2
Datum/Uhrzeit, Fehler SYSPRP SysprepSession::Validate: Fehler bei der Überprüfung von Aktionen aus C:\Windows\System32\Sysprep\ActionFiles\Generalize.xml; dwRet = 0x3cf2R

Wenn Sie den PowerShell-Befehl Remove-AppxPackage verwenden, um MiracastView zu entfernen, funktioniert der Befehl nicht, und Sie erhalten die folgende Fehlermeldung:

Vorgang zum Entfernen der Bereitstellung mit Zielvolume C: bei Package Windows.MiracastView_6.3.0.0.0_neutral_neutral_cw5n1h2txyewy von: Fehler mit Fehler 0x80070490.
Hilfe zur Diagnose von App-Bereitstellungsproblemen finden Sie http://go.microsoft.com/fwlink/?LinkId=235160 unter.

Die Fehlermeldung, die auftritt, wenn Sie Remove-AppxPackage zum Entfernen von MiracastView verwenden.

Ursache

Dieses Problem tritt aufgrund eines Fehlers auf, bei dem setup das paket Windows.MiracastView_6.3.0.0_neutral_neutral_cw5n1h2txyewy während des Upgrades migriert hat. Dieses Paket funktioniert im generalisierten Bild nicht ordnungsgemäß.

Problemumgehung

Verwenden Sie eine der folgenden Methoden, um dieses Problem zu umgehen.

Methode 1

Kopieren Sie auf dem Windows 10 Version 1709-Computer Windows.MiracastView_6.3.0.0_neutral_neutral_cw5n1h2txyewy.xml von C:\Windows.old\ProgramData\Microsoft\Windows\AppRepository\ in C:\ProgramData\Microsoft\Windows\AppRepository.

Methode 2

Kopieren Sie den Ordner "C:\Windows\MiracastView" von einem Windows 10 Version 1703-Computer auf den Windows 10 Version 1709-Computer. Starten Sie dann den Computer neu, damit Windows die Deinstallation von MiracastView beenden kann.

Datensammlung

Wenn Sie Unterstützung vom Microsoft-Support benötigen, empfehlen wir Ihnen, die Informationen zu sammeln, indem Sie die Schritte unter Sammeln von Informationen mithilfe von TSS für Bereitstellungsprobleme ausführen.