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Netzwerkanbietereinstellungen werden während eines direkten Upgrades auf Windows 10 entfernt.

Dieser Artikel enthält Problemumgehungen für ein Problem, bei dem Netzwerkanbietereinstellungen während eines direkten Upgrades auf Windows 10 entfernt werden.

Gilt für: Windows 10, Version 1809, Windows 10, Version 1709, Windows 10, Version 1703, Windows 10, Version 1607
Ursprüngliche KB-Nummer: 4013822

Problembeschreibung

Wenn Sie ein direktes Upgrade auf Windows 10, Version 1809, Version 1709, Version 1703 oder Version 1607 durchführen, werden die Einstellungen des Drittanbieternetzwerkanbieters vom Computer entfernt.

Ursache

Dies ist ein bekanntes Problem im Windows 10-Upgradeprozess. Nach dem Upgrade wird die Anbieterliste (HKLM\SYSTEM\CurrentControlSet\Control\NetworkProvider) zurückgesetzt, und die Registrierungseinstellungen des Drittanbieters (unter HKLM\System\CurrentControlSet\Services\) werden entfernt.

Problemumgehung

Wichtig

Dieser Abschnitt, diese Methode bzw. diese Aufgabe enthält eine Beschreibung der Schritte zum Bearbeiten der Registrierung. Durch die falsche Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Daher müssen Sie sicherstellen, dass Sie diese Schritte sorgfältig ausführen. Für weiteren Schutz sichern Sie die Registrierung, bevor Sie sie ändern. Anschließend können Sie die Registrierung wiederherstellen, wenn ein Problem auftritt. Weitere Informationen zum Sichern und Wiederherstellen der Registrierung finden Sie im folgenden Microsoft Knowledge Base-Artikel:
322756 Sichern und Wiederherstellen der Registrierung in Windows

Verwenden Sie eine der folgenden Methoden, um dieses Problem zu umgehen.

Methode 1

  1. Bevor Sie ein Upgrade durchführen, sichern Sie den Inhalt der Anbieterliste HKLM\SYSTEM\CurrentControlSet\Control\NetworkProvider unter den jeweiligen Einstellungen des Drittanbieters (unter HKLM\System\CurrentControlSet\Services\).
  2. Führen Sie das Upgrade aus.
  3. Stellen Sie nach Abschluss des Upgrades die Registrierungseinstellungen wieder her, die in Schritt 1 gesichert wurden.

Methode 2

Wenn Nach dem Upgrade Probleme auftreten, die sich auf die Netzwerkanbietereinstellungen von Drittanbietern auswirken, stellen Sie die Registrierungsschlüssel, die vom Installationsprogramm gelöscht wurden, manuell wieder her.

Weitere Informationen

Führen Sie die folgenden Schritte aus, um die Liste der Netzwerkanbieter zu überprüfen:

  1. Öffnen Sie das Feld "Ausführen" . Drücken Sie dazu die Windows-Logo-Taste ( )+R.

  2. Geben Sie ncpa.cpl ein, und drücken Sie dann die EINGABETASTE.

  3. Drücken Sie alt, um die Menüleiste zu öffnen.

  4. Wählen Sie "Erweitert" aus, und klicken Sie dann auf "Erweiterte Einstellungen".

    Screenshot des Dialogfelds

Diese Liste der Drittanbieternetzwerkanbieter wird am folgenden Registrierungsspeicherort gespeichert:
HKLM\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order\ProviderOrder
Standardwert: RDPNP,LanmanWorkstation,Webclient
HKLM\System\CurrentControlSet\Control\NetworkProvider\HwOrder\ProviderOrder
Standardwert: RDPNP,LanmanWorkstation,Webclient

Notiz

Jeder Zeichenfolgenwert verfügt über eigene Einstellungen unter HKLM\System\CurrentControlSet\Services.
Beispielsweise sind die folgenden Standardnetzwerkanbieter aufgeführt:

  • HKLM\System\CurrentControlSet\Services\RDPNP\NetworkProvider
  • HKLM\System\CurrentControlSet\Services\LanmanWorkstation\NetworkProvider
  • HKLM\System\CurrentControlSet\Services\WebClient\NetworkProvider

Der Anbietername wird aus der Liste entfernt, und alle hinzugefügten Registrierungsschlüssel werden entfernt.

Datensammlung

Wenn Sie Unterstützung vom Microsoft-Support benötigen, empfehlen wir Ihnen, die Informationen zu sammeln, indem Sie die Schritte unter Sammeln von Informationen mithilfe von TSS für Bereitstellungsprobleme ausführen.