Netzwerkanbietereinstellungen werden während eines direkten Upgrades auf Windows 10
Dieser Artikel enthält Problemumgehungen für ein Problem, bei dem Netzwerkanbietereinstellungen während eines direkten Upgrades auf Windows 10 entfernt werden.
Gilt für: Windows 10, Version 1809, Windows 10, Version 1709, Windows 10, Version 1703, Windows 10, Version 1607
Ursprüngliche KB-Nummer: 4013822
Symptome
Wenn Sie ein direktes Upgrade auf Windows 10, Version 1809, Version 1709, Version 1703 oder Version 1607 durchführen, werden die Einstellungen des Netzwerkanbieters des Drittanbieters vom Computer entfernt.
Ursache
Dies ist ein bekanntes Problem im Windows 10 Upgradeprozess. Nach dem Upgrade wird die Anbieterliste (HKLM\SYSTEM\CurrentControlSet\Control\NetworkProvider
) zurückgesetzt, und die Registrierungseinstellungen des Drittanbieters (unter HKLM\System\CurrentControlSet\Services\
) werden entfernt.
Problemumgehung
Wichtig
Dieser Abschnitt, diese Methode bzw. diese Aufgabe enthält eine Beschreibung der Schritte zum Bearbeiten der Registrierung. Durch die falsche Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Daher ist es wichtig, bei der Ausführung der folgenden Schritte sorgfältig vorzugehen. Für zusätzlichen Schutz sichern Sie die Registrierung, bevor Sie sie ändern. Sie können die Registrierung wiederherstellen, wenn ein Problem auftritt. Weitere Informationen zum Sichern und Wiederherstellen der Registrierung finden Sie im folgenden Microsoft Knowledge Base-Artikel:
322756 Sichern und Wiederherstellen der Registrierung in Windows
Verwenden Sie eine der folgenden Methoden, um dieses Problem zu umgehen.
Methode 1
- Sichern Sie vor dem Upgrade manuell den Inhalt der Anbieterliste unter
HKLM\SYSTEM\CurrentControlSet\Control\NetworkProvider
und die entsprechenden Drittanbietereinstellungen (unterHKLM\System\CurrentControlSet\Services\
). - Führen Sie das Upgrade aus.
- Stellen Sie nach Abschluss des Upgrades die Registrierungseinstellungen wieder her, die in Schritt 1 gesichert wurden.
Methode 2
Wenn nach dem Upgrade Probleme auftreten, die sich auf die Einstellungen des Drittanbieternetzwerkanbieters auswirken, stellen Sie die Registrierungsschlüssel, die vom Installationsprogramm gelöscht wurden, manuell wieder her.
Weitere Informationen
Führen Sie die folgenden Schritte aus, um die Liste der Netzwerkanbieter zu überprüfen:
Öffnen Sie das Feld Ausführen . Drücken Sie dazu die Windows-Logo-Taste ( )+R.
Geben Sie ncpa.cplein, und drücken Sie dann die EINGABETASTE.
Drücken Sie die ALT-TASTE, um die Menüleiste zu öffnen.
Wählen Sie Erweitert aus, und klicken Sie dann auf Erweiterte Einstellungen.
Diese Liste der Netzwerkanbieter von Drittanbietern wird am folgenden Registrierungsspeicherort gespeichert:
HKLM\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order\ProviderOrder
Standardwert: RDPNP,LanmanWorkstation,webclient
HKLM\System\CurrentControlSet\Control\NetworkProvider\HwOrder\ProviderOrder
Standardwert: RDPNP,LanmanWorkstation,webclient
Hinweis
Jeder Zeichenfolgenwert hat seine eigenen Einstellungen unter HKLM\System\CurrentControlSet\Services
.
Im Folgenden sind beispielsweise die Standardnetzwerkanbieter aufgeführt:
HKLM\System\CurrentControlSet\Services\RDPNP\NetworkProvider
HKLM\System\CurrentControlSet\Services\LanmanWorkstation\NetworkProvider
HKLM\System\CurrentControlSet\Services\WebClient\NetworkProvider
Der Anbietername wird aus der Liste entfernt, und alle hinzugefügten Registrierungsschlüssel werden entfernt.
Datensammlung
Wenn Sie Unterstützung vom Microsoft-Support benötigen, empfehlen wir Ihnen, die Informationen zu sammeln, indem Sie die Schritte unter Sammeln von Informationen mithilfe von TSS für Bereitstellungsprobleme ausführen.