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Bekannte Probleme bei der Windows-Desktopsuche und Cortana in Windows 10

In diesem Artikel werden die bekannten Probleme beschrieben, die auftreten können, wenn Sie die Windows-Desktopsuche oder Cortana in Windows 10 verwenden.

Notiz

Heimanwender*innen: Dieser Artikel richtet sich an Support-Mitarbeiter*innen und professionelles IT-Personal. Wenn Sie nach weiteren Informationen zu Websitefehlermeldungen suchen, lesen Sie die folgende Windows-Website: Suchen Sie überall nach beliebigen Elementen.

Gilt für: Windows 10 – alle Editionen
Ursprüngliche KB-Nummer: 3206883

Bekannte Probleme

Problem 1:

Die Desktopsuche oder Cortana kann keine Verknüpfungsdateien (.lnk) finden.

Problembeschreibung

Auf einem Computer, auf dem Windows 10, Desktopsuche oder Cortana ausgeführt wird, können Sie keine Verknüpfungsdateien (Dateien mit einer LNK-Erweiterung) finden.

Das Problem tritt unabhängig davon auf, ob sich die Verknüpfungsdateien an indizierten Speicherorten befinden.

Status

Microsoft ist dieses Problem bekannt und untersucht es.

Problem 2:

Die Desktopsuche oder Cortana finden keine Dateien, die über eine URL-Erweiterung verfügen.

Problembeschreibung

Auf einem Computer, auf dem Windows 10 ausgeführt wird, können Sie keine Dateien finden, die über eine URL-Erweiterung verfügen, indem Sie die Desktopsuche oder Cortana verwenden.

Status

Es handelt sich hierbei um ein beabsichtigtes Verhalten. Die Suche filtert die Ergebnisse, um Rauschen zu vermeiden, die durch Nicht-App-Verknüpfungen verursacht werden.

Problem 3

Die Windows-Desktopsuche zeigt keine Ergebnisse an, wenn Ihre Internetoptioneneinstellungen so konfiguriert sind, dass Websitedaten deaktiviert werden.

Problembeschreibung

Wenn Sie versuchen, über das Startmenü oder von Cortana auf einem Windows 10-basierten Computer zu suchen, erhalten Sie keine Ergebnisse. Dieses Verhalten tritt auf, wenn Ihre Internetoptioneneinstellungen so konfiguriert sind, dass lokale Caches und Datenbanken deaktiviert werden.

Sie können lokale Caches und Datenbanken mithilfe einer der folgenden Methoden deaktivieren:

  • Verwenden von Internet Explorer: Internetoptionen ->Allgemeine Registerkarte ->Browserverlauf ->Einstellungen ->Websitedateneinstellungen ->Caches und Datenbankregisterkarte zulassen ->Websitecaches und Datenbanken zulassen (Kontrollkästchen deaktivieren)

  • Verwenden des Registrierungs-Editors:
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\BrowserStorage\AppCache "AllowWebsiteCaches"=dword:000000000

  • Verwenden von Gruppenrichtlinien:
    Gruppenrichtlinie unter der Konfiguration von Benutzer und Computer:

    Administrative Vorlagen>Windows-Komponenten> Internet Explorer>Internet Systemsteuerung> General Page>Browsing History>Zulassen, dass Websites Anwendungscaches auf Clientcomputern speichern

Ursache

Dieses Problem tritt auf, wenn der Benutzer die Verwendung von Caches und Datenbanken über Internetoptionen oder Gruppenrichtlinien deaktiviert. Dadurch wird verhindert, dass die Anwendung, die AppCache verwendet, Daten lokal speichert, und die Anwendung muss Zugriff auf den Webinhalt haben, der ursprünglich zum Auffüllen des Caches verwendet wurde. Wenn ein Computer keinen Internetzugriff hat und die Option konfiguriert ist, die Webplattform-APIs von der Verwendung von AppCache zu verbieten (Die Option "Websitecaches zulassen" und "Datenbanken zulassen" ist deaktiviert), funktioniert die Desktopsuche nicht.

Lösung

Um dieses Problem zu umgehen, ändern Sie die Konfiguration der Desktopsuche über Gruppenrichtlinien. Gehen Sie dazu wie folgt vor:

  1. Drücken Sie die WINDOWS-TASTE+R, um das Feld "Ausführen " zu öffnen.

  2. Geben Sie "gpedit.msc" ein, und drücken Sie dann die EINGABETASTE.

  3. Navigieren Sie im Gruppenrichtlinien-Editor zu folgendem Speicherort:

    Computerkonfiguration -Administrative Vorlagen ->>Windows-Komponenten -Suche>

  4. Doppelklicken Sie im Bereich auf der rechten Seite. Durchsuchen Sie das Web nicht, oder zeigen Sie webergebnisse in der Suche an.

  5. Wählen Sie Aktiviert.

  6. Klicken Sie auf "Übernehmen", und klicken Sie dann auf "OK". Die Desktopsuche vermeidet jetzt die Verwendung einer der Webplattform-APIs zum Abrufen von Inhalten aus dem Web. Dies verringert auch die Auswirkungen der Deaktivierung von Websitezwischenspeicherung und -datenbanken.

Weitere Informationen

Windows-Desktopsuche, Internet Explorer und Microsoft Store-Apps verwenden ein Feature namens Anwendungscache (AppCache), das das Erstellen von Offlineweb-Apps und Webseitenzwischenspeichern ermöglicht. AppCache ermöglicht es den Apps, die sie verwenden, die Leistung von Webinhalten zu steigern, indem die Anzahl der Anforderungen an den Hostingserver reduziert wird.