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Dieser Artikel enthält eine Lösung für das Problem, das der SMS-Agent-Hostdienst nach dem Neustart eines Systems Management Server 2003-Clientcomputers nicht startet.
Gilt für: Windows 10 – alle Editionen
Ursprüngliche KB-Nummer: 922362
Wichtig
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Sie sollten eine Sicherungskopie der Registrierung erstellen, bevor Sie die Registrierung bearbeiten. Sie müssen wissen, wie die Registrierung wiederhergestellt werden kann, wenn ein Problem auftritt. Weitere Informationen zum Sichern, Wiederherstellen und Ändern der Registrierung finden Sie in der Microsoft Knowledge Base auf die folgende Artikelnummer:
256986 Beschreibung der Microsoft Windows-Registrierung
Problembeschreibung
Nachdem Sie einen Microsoft Systems Management Server (SMS) 2003-Clientcomputer neu gestartet haben, wird der SMS-Agent-Hostdienst (Ccmexec.exe) nicht gestartet. Wenn dieses Problem auftritt, werden Fehlereinträge, die den folgenden ähneln, in der datei CCMExec.log auf dem SMS-Clientcomputer angezeigt:
CCMExec.log Dateieintrag 1
CcMEXEC-Dienst wird gestartet... $$<CcmExec><Fri 13 13:13:13.819 2004 Central Standard Time><thread=1216 (0x4C0)>
Wird auf Computer ComputerName als BenutzerSYSTEM ausgeführt.
$$<CcmExec><Fri 13 8:13:13.859 2004 Central Standard Time><thread=1216 (0x4C0)>
FEHLER!! WBEM wurde im Systempfad nicht gefunden. $$<CcmExec><Fri 13 8:13:13.859 2004 Central Standard Time><thread=1216 (0x4C0)>
WBEM wurde der Prozessumgebungsvariable PATH erfolgreich hinzugefügt. $$<CcmExec><Fri 13 8:13:13.859 2004 Central Standard Time><thread=1216 (0x4C0)>
Initialisieren von COM. $$<CcmExec><Fri 13 8:13:13.859 2004 Central Standard Time><thread=1216 (0x4C0)>
Registrieren für die Protokollierung von Änderungsbenachrichtigungen. $$<CcmExec><Fri 13 8:13:13.869 2004 Central Standard Time><thread=1216 (0x4C0)>
Festlegen der Standardprotokollierungskomponente für den Prozess. $$<CcmExec><Fri 13 8:13:13.869 2004 Central Standard Time><thread=1216 (0x4C0)>
Festlegen des Dienststatus auf "AUSFÜHREN". $$<CcmExec><Fri 13 8:13:13.869 2004 Central Standard Time><thread=1216 (0x4C0)>
Überprüfen, ob eine Reparatur erforderlich ist. $$<CcmExec><Fri 13 8:13:13.889 2004 Central Standard Time><thread=1216 (0x4C0)>
Fehler beim Öffnen des WMI-Namespace '\\.\root\ccm' (80004002) $$<CcmExec><Fri 13 8:13:17.224 2004 Central Standard Time><thread=1216 (0x4C0)>
CCMExec.log Dateieintrag 2
1/25/2006 9:16:35 PMFailed to open to WMI namespace '\\.\root\ccm' (8004100a)
1/25/2006 9:16:35 PMCCMDoCertificateMaintenance fehlgeschlagen (0x8004100a).
1/25/2006 9:16:35 PMFailed to open to WMI namespace '\\.\root\CCM\Events' (8004100a)
1/25/2006 9:16:35 PMCCMDoCertificateMaintenance() ausgelöst CCM_ServiceHost_CertificateOperationsFailure Statusereignis.
1/25/2006 9:16:35 PMLoading service settings.
1/25/2006 9:16:35 PMFailed to open to WMI namespace '\\.\root\ccm\Policy\Machine' (8004100a)
1/25/2006 9:16:35 PMError loading service settings. Code-0x8004100a
1/25/2006 9:16:35 PMPhase 0 Initialisierung fehlgeschlagen (0x8004100a).
1/25/2006 9:16:35 PMService Initialisierung fehlgeschlagen (0x8004100a).
1/25/2006 9:16:35 PMShutting down AdditonallyCCMEXEC...
Darüber hinaus kann die Wbemcore.log Datei einen Fehlereintrag enthalten, der etwa wie folgt aussieht:
(Fr. Februar 13 08:13:13 2004.69289) : Registrierungseintrag gibt an, dass ein Setup ausgeführt wird.
(Fr. Februar 13 08:14:13 2004.129856) : CFactory-Konstrukt
(Fr. Februar 13 08:14:13 2004.129886) : CFactory destruct
(Fr. Februar 13 08:14:13 2004.129896) : Erstellt WINMGMT_ACTIVE mutex
(Fr. Februar 13 08:14:13 2004.129946) : Lesen von Konfigurationsinformationen aus der Registrierung
(Fr. Februar 13 08:14:16 2004.132800) : Vorbereiten einer Namespace-Init-Anforderung für den aktiven Namespace //./ROOT/ccm/policy
(Fr. Februar 13 08:14:16 2004.132901) : Vorbereiten einer Namespace-Init-Anforderung für den aktiven Namespace //./root/CIMV2
(Fr. Februar 13 08:14:16 2004.132961) : Vorbereiten einer Namespace-Init-Anforderung für den aktiven Namespace //./root/subscription
(Fr. Februar 13 08:14:16 2004.133021) : Initialisieren des Namespace //./ROOT/ccm/policy
(Fr. Februar 13 08:14:16 2004.133041) : Initialisieren des Namespace //./root
Ursache
Dieses Problem tritt auf, wenn eine oder beide der folgenden Bedingungen erfüllt sind:
- Die Pfadvariable %SystemRoot%\System32\Wbem wird nicht im Systempfad auf dem Clientcomputer aufgeführt.
- Der Typ des Pfadregistrierungseintrags ist auf dem SMS-Clientcomputer falsch.
Das Problem kann auch auftreten, wenn der Windows-Verwaltungsinstrumentationsdienst (Windows Management Instrumentation, WMI) nicht rechtzeitig gestartet wird.
Lösung
Verwenden Sie eine der folgenden Methoden, um das Problem zu beheben.
Methode 1: Stellen Sie sicher, dass die Variable %SystemRoot%\System32\Wbem im Systempfad auf dem Clientcomputer aufgeführt ist.
Klicken Sie auf "Start", klicken Sie auf "Ausführen", geben Sie sysdm.cpl ein, und klicken Sie dann auf "OK".
Klicken Sie auf die Registerkarte Erweitertund dann auf Umgebungsvariablen.
Klicken Sie unter Systemvariablen auf "Pfad" und dann auf "Bearbeiten".
Stellen Sie sicher, dass %SystemRoot%\System32\Wbem im Feld "Variabler Wert " aufgeführt ist. Wenn dieser Wert nicht aufgeführt ist, müssen Sie ihn hinzufügen. Gehen Sie dazu wie folgt vor:
Klicken Sie im Dialogfeld "Systemvariable bearbeiten" im Feld "Variablenwert" auf das Ende des Texts, und geben Sie dann Folgendes ein:
;%SystemRoot%\System32\Wbem
Klicken Sie dreimal auf OK , um die Änderungen zu speichern.
Methode 2: Festlegen des Typs des Pfadregistrierungseintrags auf REG_EXPAND_SZ
Warnung
Schwerwiegende Probleme können auftreten, wenn die Registrierung mit dem Registrierungs-Editor oder einer anderen Methode unsachgemäß bearbeitet wird. Diese Probleme können eine Neuinstallation des Betriebssystems erforderlich machen. Microsoft gibt keinerlei Garantien dafür ab, dass diese Probleme behoben werden können. Das Ändern der Registrierung erfolgt auf eigenes Risiko.
Klicken Sie auf Start und dann auf Ausführen, geben Sie „regedit“ ein und klicken Sie auf OK.
Suchen Sie im Registrierungs-Editor den folgenden Registrierungsunterschlüssel, und klicken Sie dann auf den folgenden Registrierungsunterschlüssel:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment
Stellen Sie sicher, dass der Typ des Pfadeintrags REG_EXPAND_SZ und nicht REG_SZ ist. Wenn der Typ dieses Eintrags REG_SZ ist, müssen Sie die Pfadinformationen kopieren, den vorhandenen Pfadeintrag löschen und dann einen neuen Eintrag vom Typ REG_EXPAND_SZ erstellen. Gehen Sie dazu wie folgt vor:
- Doppelklicken Sie im Registrierungs-Editor auf den Pfadwert .
- Klicken Sie mit der rechten Maustaste auf den Text im Datenfeld "Wert", klicken Sie auf "Kopieren", und klicken Sie dann auf "Abbrechen".
- Fügen Sie den Text in ein Editordokument ein.
- Klicken Sie im Registrierungs-Editor mit der rechten Maustaste auf "Pfad", und klicken Sie dann auf "Löschen".
- Klicken Sie auf der Menüleiste auf "Bearbeiten", zeigen Sie auf "Neu", und klicken Sie dann auf "Erweiterbarer Zeichenfolgenwert".
- Geben Sie "Pfad" ein, und drücken Sie dann die EINGABETASTE.
- Doppelklicken Sie auf "Pfad".
- Klicken Sie mit der rechten Maustaste auf das Feld "Wert" , klicken Sie auf "Einfügen", und klicken Sie dann auf "OK".
- Beenden Sie den Registrierungs-Editor.
Weitere Informationen
Weitere Informationen zur Problembehandlung für erweiterte Client-Pushinstallationen finden Sie im folgenden Artikel in der Microsoft Knowledge Base:
928282 Behandeln von Problemen mit erweiterter Client-Pushinstallation in Systems Management Server 2003 und System Center Configuration Manager 2007