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"w32tm /resync" schlägt mit "Der Computer hat keine Synchronisierung ausgeführt, da keine Zeitdaten verfügbar waren."

Dieser Artikel enthält mehrere mögliche Lösungen für einen Fehler, den Sie möglicherweise erhalten, wenn Sie den Befehl ausführen, um die w32tm /resync Zeit mit einer Zeitquelle zu synchronisieren.

Gilt für: Windows Server (alle unterstützten Versionen)
Ursprüngliche KB-Nummer: 929276

Symptome

Auf dem Computer treten Zeitsynchronisierungsprobleme auf. Wenn Sie eine manuelle Erneute Synchronisierung ausführen w32tm /resync, wird der folgende Fehler zurückgegeben: Der Computer wurde nicht erneut synchronisiert, da keine Zeitdaten verfügbar waren.

C:\Windows\system32>w32tm /resync /rediscover
Sending resync command to local computer
The computer did not resync because no time data was available

Möglicherweise werden auch die folgenden Ereignisse angezeigt:

Protokollname: System
Quelle: Microsoft-Windows-Time-Service
Datum: 24-04-2019 22:35:55
Ereignis-ID: 129
Aufgabenkategorie: Keine
Ebene: Warnung
Schlüsselwörter:
Benutzer: LOKALER DIENST
Computer: MEM1.fabrikam.com
Beschreibung: NtpClient konnte aufgrund eines Ermittlungsfehlers keinen Domänenspeer für die Verwendung als Zeitquelle festlegen. In 15 Minuten wird ein weiterer Versuch ausgeführt und das Intervall für weitere Versuche anschließend verdoppelt. Fehler: Der Eintrag wurde nicht gefunden. (0x800706E1)

Protokollname: System
Quelle: Microsoft-Windows-Time-Service
Datum: 24-04-2019 23:45:32
Ereignis-ID: 134
Aufgabenkategorie: Keine
Ebene: Warnung
Schlüsselwörter:
Benutzer: LOKALER DIENST
Computer: MEM1.fabrikam.com
Beschreibung: NtpClient konnte aufgrund eines DNS-Auflösungsfehlers für "time.windows.com.0x9" keinen manuellen Peer für die Verwendung als Zeitquelle festlegen. In 15 Minuten wird ein weiterer Versuch ausgeführt und das Intervall für weitere Versuche anschließend verdoppelt. Der Fehler war: Kein solcher Host ist bekannt. (0x80072AF9)

Ursache

Dieser Fehler tritt in der Regel auf, wenn der Client eine NTP-Anforderung sendet, aber keine ordnungsgemäße NTP-Antwort zurückgibt. Es gibt mehrere Szenarien, die dies verursachen können.

Szenario 1

Der NTP-Client kann den NTP-Server nicht finden. Dies kann darauf zurückzuführen sein, dass die Namensauflösung (DNS) fehlschlägt oder die im NTPServer-Registrierungsschlüssel definierte Namens-/IP-Adresse falsch geschrieben wurde.

Szenario 2

UDP-Port 123 ist blockiert. Dies kann sich in der lokalen Windows-Firewall oder in einer Nicht-Microsoft-Firewall befinden.

Szenario 3

Der NTP-Zielserver, mit dem der Client die Zeit synchronisieren möchte, wird nicht als NTP-Server angezeigt.

Lösung

Lösung für Szenario 1

  1. Überprüfen Sie die Rechtschreibung und Genauigkeit des im NTPServer-Registrierungsschlüssel definierten Werts. Lassen Sie den Kunden überprüfen, ob es sich um einen gültigen Server mit dem richtigen Namen oder der richtigen IP-Adresse ist.
  2. Überprüfen Sie DNS. Stellen Sie sicher, dass die richtigen DNS-Server definiert sind, die den NTP-Zielserver auflösen können.
  3. Verwenden Sie Netzwerkablaufverfolgungen, um eine bessere Vorstellung davon zu erhalten, was mit der Namensauflösung geschieht.

Letztendlich könnte dieses Szenario enden Szenario 2 oder Szenario 3.

Lösung für Szenario 2

Sammeln sie Netzwerkablaufverfolgungen, um UDP-Port 123-Datenverkehr zu überprüfen. Starten Sie dazu eine Aufzeichnung, und führen Sie dann eine w32tm /resync /rediscover.

  1. Wenn keine UDP 123-Pakete (NTP-Anforderung) gesendet werden, wird wahrscheinlich der UDP-Port 123 in der lokalen Windows-Firewall blockiert.
  2. Wenn UDP-Port 123 -Pakete (NTP-Anforderung) gesendet, aber keine Antwort zurückgegeben werden, ist es wahrscheinlich, dass UDP-Port 123 in einer Nicht-Microsoft-Firewall blockiert wird.

Wenn dies überprüft wird und UDP-Port 123 nicht blockiert ist, sollten Sie Szenario 3 in Betracht ziehen.

Lösung für Szenario 3

  1. Wenn Ihr Kunde versucht, eine Synchronisierung mit einem Domänencontroller (ob über NT5DS, NTP oder AllSync) auszuführen, überprüfen Sie die Windows-Zeithierarchie. Überprüfen Sie beginnend mit dem PDC die Domänencontroller, um sicherzustellen, dass sie alle Zeit von ihrer jeweiligen Quelle erhalten. Sie können w32tm /monitor für eine schnelle Statusüberprüfung auf allen Domänencontrollern verwenden.

  2. Wenn die Domänencontroller die Zeit von der Quelle ordnungsgemäß synchronisieren, überprüfen Sie, und stellen Sie sicher, dass die Domänencontroller als Domänencontroller werben, indem Sie eine dcdiag /test:Advertising.

  3. Überprüfen Sie abschließend auf den Domänencontrollern, ob die folgenden w32time-Registrierungsschlüssel wie folgt konfiguriert sind (at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time):

    • Auf allen DCs: \TimeProviders\NtpServer – Enabled=1
    • Auf der PDC: \Config – AnnounceFlags = 5
    • Auf Mitglieds-DCs: \Config – AnnounceFlags = 10