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Problembehandlung bei Domänencontrollerreplikationsfehler 1727– Fehler beim Remoteprozeduraufruf und nicht ausgeführt

In diesem Artikel wird die Fehlermeldung "Fehler beim Remoteprozeduraufruf und nicht ausgeführt" behoben. Dieser Fehler tritt während der Domänencontrollerreplikation auf Windows Server auf.

Gilt für: Windows Server (alle unterstützten Versionen)
Ursprüngliche KB-Nummer: 4019721

Symptome

Dieser Active Directory (AD)-Replikationsfehler wird in mindestens einer der folgenden Formen angezeigt:

  • Dezimalzahl: 1727
  • Hex: 0x6bf
  • Symbolisch: RPC_S_CALL_FAILED_DNE
  • Fehlermeldung: Fehler beim Remoteprozeduraufruf und nicht ausgeführt.

Ursache

Dieses Problem tritt aus einem der folgenden Gründe auf:

  • Ein Netzwerkkonnektivitätsproblem zwischen den beiden DCs.A network connectivity issue between the two domain controllers (DCs). Weitere Informationen hierzu finden Sie in den nachfolgenden Abschnitten.
  • Ein lastinduziertes Leistungsproblem für den Replikationspartner. Dieses Problem ist weniger häufig und ist oft vorübergehend in der Natur. Weitere Informationen hierzu finden Sie in den nachfolgenden Abschnitten.

Informationen zum Netzwerkkonnektivitätsproblem

Dieses Problem tritt auf, wenn der Replikationspartner des DC die RPC-Verbindung zum RPC-Dienst der AD-Replikation nicht abschließen kann (DRSR UUID E3514235-4B06-11D1-AB04-00C04FC2DCD2). Genauer gesagt kann der Replikationspartner eine Bindung an die RPC-Endpunktzuordnung herstellen, aber die DRSR RPC-Bindung nicht abschließen.

Mögliche Ursachen sind:

  • Firewalls
  • Router
  • WAN-Optimierungen
  • andere Zwischennetzwerkgeräte
  • Netzwerkfiltertreiber

Informationen zum Leistungsproblem

Dieses Problem tritt auf, wenn eine der folgenden Bedingungen zutrifft:

  • Der Server ist geloggt und antwortet nicht auf den TCP-ACK oder die Antwortnachricht. Der Absender gibt also die TCP-Sitzung auf.
  • Das Netzwerk ist zu langsam oder unzuverlässig. Er kann den TCP-ACK oder die Antwortnachricht nicht übermitteln.

Lösung

Um dieses Problem zu beheben, bestimmen Sie alle kürzlich vorgenommenen Änderungen, die sich auf das Netzwerk zwischen den beiden DCs auswirken und diese Änderungen ggf. rückgängig machen würden. Wenn keine letzten Änderungen vorhanden sind, müssen Sie die RPC-Netzwerkkonnektivität zwischen den beiden DCs vollständig untersuchen. Führen Sie dazu entweder die allgemeinen Schritte zur Problembehandlung oder die detaillierten Schritte zur Problembehandlung aus.

Allgemeine Schritte zur Problembehandlung

  1. Nehmen Sie eine doppelseitige Netzwerkaufnahme, während Sie das Problem reproduzieren. Führen Sie dazu die folgenden Schritte aus:

    1. Starten Sie eine Netzwerkaufnahme auf beiden DCs.
    2. Starten Sie die Replikation zwischen den beiden DCs manuell.
    3. Beenden Sie beide Seiten der Ablaufverfolgung, wenn Sie den Fehler erhalten.
  2. Untersuchen Sie die RPC-Unterhaltung zwischen den beiden DCs. Ermitteln Sie, ob es jemals einen Fall gibt, in dem die Nachricht, die vom Anforderer DC gesendet wird, keine Antwort vom Replikationspartner verursacht.

Notiz

Gelegentlich gibt es eine partielle Antwort, die den Piggy-Back-TCP-ACK für die Anforderungsnachricht enthält. Der Datenverkehr wurde jedoch geändert, oder die Antwort kommt nicht tatsächlich an den Anforderer DC. Daher empfängt der TCP-Stapel keine ACK.

Ausführliche Problembehandlungsschritte

Starten Sie eine Netzwerkaufnahme auf beiden DCs, bevor Sie die folgenden Schritte ausführen, um die DC-Konnektivität zu testen.

Testen der Quell-DC-Verbindung vom Ziel-DC

Führen Sie die folgenden Schritte auf dem Ziel-DC aus:

  1. Überprüfen Sie, ob der Quell-DC auf TCP-Port 135 überwacht wird. Führen Sie dazu den PortQry.exe -n -e 135 Befehl aus.

    Wenn der Portstatus GEFILTERT ist, schlägt der AD-Replikationsfehler wahrscheinlich fehl und gibt stattdessen fehler 1722 zurück. Versuchen Sie, fehler 1722 zu beheben, und überprüfen Sie dann, ob die AD-Replikation erfolgreich ist. Wenn das Problem weiterhin besteht, starten Sie die detaillierten Schritte zur Problembehandlung neu.

    Wenn der Status nicht GEFILTERT ist, geben die Befehle die RPC-Endpunktzuordnungsdatenbank zurück. Suchen Sie nach MS NT Directory DRS Interface , um den portierten oberen Bereich in der Endpunktzuordnungsdatenbank zu finden, auf den die Quell-DC auf die AD-Replikation lauscht. Möglicherweise erhalten Sie einen oder mehrere Einträge. Notieren Sie sich die Ports für ncacn_ip_tcp.

    Sie erhalten beispielsweise etwas, das dem folgenden Beispiel ähnelt, das zwei Ports für den oberen Bereich 49159 und 49160 darstellt:

    UUID: e3514235-4b06-11d1-ab04-00c04fc2dcd2 MS NT Directory DRS Interface ncacn_ip_tcp:2012dc[49159]UUID: e3514235-4b06-11d1-ab04-00c04fc2dcd2 MS NT Directory DRS Interface ncacn_ip_tcp:2012dc[49160]

    Notiz

    Die Ports im oberen Bereich sind DC-spezifisch und werden dynamisch zugewiesen. Ein Administrator kann jedoch den Port hart codieren, der für die AD-Replikation verwendet wird, indem er den folgenden Registrierungswert verwendet.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Parameters
    Registrierungswert: TCP/IP-Port
    Werttyp: REG_DWORD
    Wertdaten: (verfügbarer Port)

  2. Testen Sie die TCP-Portkonnektivität mit den oben angegebenen Ports. Führen Sie hierzu den folgenden Befehl aus:

    PortQry.exe -n <SourceDC> -e <Upper_Range_Port_Number>
    

    Sie führen beispielsweise die folgenden Befehle aus:

    PortQry.exe -n 2012dc -e 49159
    PortQry.exe -n 2012dc -e 49160
    

    Wenn der Portstatus GEFILTERT ist, überprüfen Sie die Netzwerkablaufverfolgung, die Sie erfasst haben, um zu bestimmen, wo das Paket blockiert ist.

  3. Testen Sie DNS. Stellen Sie sicher, dass der Ziel-DC die CNAME- und HOST-Einträge der Quell-DC auflösen kann. Und stellen Sie sicher, dass die aufgelöste IP-Adresse die tatsächliche IP-Adresse des Quell-DC ist. Wenn DNS auf eine alte oder ungültige IP-Adresse verweist, wird versucht, eine falsche Quelle DC herzustellen.

Testen der Ziel-DC-Konnektivität vom Quell-DC

Wiederholen Sie Schritt 1 bis 3 auf dem Quell-DC.

Datensammlung

Wenn Sie Unterstützung vom Microsoft-Support benötigen, empfehlen wir, die Informationen zu sammeln, indem Sie die unter " Sammeln von Informationen" genannten Schritte ausführen, indem Sie TSS für Active Directory-Replikationsprobleme verwenden.