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WinStoreUI.admx-Konflikt beim Aktualisieren des zentralen Speichers mit Windows 10 ADMX-Dateien der Version 1511

Dieser Artikel bietet Hilfe bei der Lösung eines WinStoreUI.admx-Konflikts, der auftritt, wenn der zentrale Store mithilfe von Windows 10 ADMX-Dateien der Version 1511 aktualisiert wird.

Gilt für: Windows Server (alle unterstützten Versionen)
Ursprüngliche KB-Nummer: 3190327

Problembeschreibung

Die Datei WinStoreUI.admx ist in Windows Server 2012 R2 verfügbar, aber nicht in der ersten Version von Windows 10 enthalten. Nachdem Sie jedoch den zentralen Speicher mithilfe der ADMX-Dateien aus Windows 10 Version 1511 aktualisiert haben, wird der folgende Fehler angezeigt, sobald Sie mit der Bearbeitung eines Gruppenrichtlinie-Objekts (GPO) beginnen:

Der Namespace "Microsoft.Policies.WindowsStore" ist bereits als Zielnamespace für eine andere Datei im Speicher definiert.

Screenshot des Fensters

Der Vergleich der ADMX-Dateien von Windows Server 2012 R2 und Windows 10 Version 1511 zeigt, dass WindowsStore.admx die gleichen Informationen wie WinStoreUI.admx sowie einige zusätzliche Richtlinieneinstellungen enthält. Nachdem Sie WinStoreUI.admx gelöscht haben, tritt dieser Fehler nicht mehr auf. Der resultierende Richtliniensatz auf einem 2012 R2-basierten Computer enthält jedoch den folgenden Fehler:

Screenshot der Fehlermeldung: Fehler beim Sammeln von Daten für administrative Vorlagen.

Fehler beim Sammeln von Daten für administrative Vorlagen. Die folgenden Fehler sind aufgetreten:

Für \\<domain>\sysvol\domain\<domain.dns>policies\PolicyDefinitions\WinStoreUI.admx(error = 2) wurde keine entsprechende Ressourcendatei gefunden: Die angegebene Datei kann vom System nicht gefunden werden.

Ursache

In Windows 10 Version 1507 wurde die ADMX-Store-Datei entfernt. Eine Korrektur hat die ADMX-Datei wiederhergestellt. Diese Datei hat jedoch jetzt einen neuen Namen. Nach der Installation von Version 1511 verfügen Kunden beim Aktualisieren ihres zentralen Speichers über zwei ADMX-Dateien mit identischen Einstellungen. Da dies nicht zulässig ist, tritt der im Abschnitt "Symptome" beschriebene Fehler auf.

Die ADMX-Dateien sind die folgenden:

  • Ursprünglicher Name der Store-Gruppenrichtlinie-Datei: winstoreui.admx
  • Neuer Store Gruppenrichtlinie Dateiname: windowsstore.admx

Lösung

Dieses Problem wurde in Windows 10 Version 1511 und durch das neueste kumulative Update behoben. Betroffene Kunden sollten nach Möglichkeit ein Upgrade auf dieses Release durchführen. Führen Sie die folgenden Schritte aus, um zu verhindern, dass der Fehler auftritt, wenn Sie Gpedit.msc öffnen und Gpresult.exe ausführen:

  1. Vergewissern Sie sich, dass sowohl winstoreui.admx als auch windowsstore.admx im zentralen Store enthalten sind.
  2. Löschen Sie die Dateien winstoreui.admx und winstoreui.adml aus dem zentralen Speicher.
  3. Vergewissern Sie sich, dass sowohl das Öffnen von "Gpedit.msc" als auch das Ausführen Gpresults.exe ohne Fehler funktionieren.