Hinweis
Für den Zugriff auf diese Seite ist eine Autorisierung erforderlich. Sie können versuchen, sich anzumelden oder das Verzeichnis zu wechseln.
Für den Zugriff auf diese Seite ist eine Autorisierung erforderlich. Sie können versuchen, das Verzeichnis zu wechseln.
Dieser Artikel enthält eine Lösung für ein Problem, bei dem falsche Fehlermeldungen zurückgegeben werden, wenn ADML-Dateien fehlen.
Gilt für: Windows Server (alle unterstützten Versionen)
Ursprüngliche KB-Nummer: 2688272
Symptome
SR-Symptome:
EN-US-Domänencontroller versucht, einen Einstellungsbericht für ein Gruppenrichtlinienobjekt zu erstellen. Der Bericht wird mit der Nachricht erstellt:
Eine entsprechende Ressourcendatei konnte für die Datei
\\domainname.com\sysvol\domainname.com\Policies\PolicyDefinitions\anyfile.admx
nicht gefunden werden (Fehler = 2): Das System kann die angegebene Datei nicht finden.
Die als fehlende ADMX-Dateien gemeldeten Dateien sind im angegebenen Ordner vorhanden.
Repro-Symptome:
Wenn Sie den Ordner umbenennen, der die entsprechenden ADML-Dateien enthält, wird der Fehler zurückgegeben:
Eine entsprechende Ressourcendatei konnte für die Datei
\\domainname.com\sysvol\domainname.com\Policies\PolicyDefinitions\anyfile.admx
nicht gefunden werden (Fehler = 3): Der angegebene Pfad kann vom System nicht gefunden werden.
Dieser Fehler tritt auch auf, wenn der Ordner "EN-US" nicht vorhanden ist und fehlt.
Das Bearbeiten der betroffenen GPOs wird unmöglich, Berichte sind ungenau. Das Problem tritt nicht auf die gleiche Weise auf, wenn andere Sprachdateien und Ordner fehlen, da EN-US die Fallbacksprache ist und stattdessen geladen wird, wenn eine andere Sprache fehlt.
Ursache
Um Berichte zu generieren oder das Gruppenrichtlinienobjekt zu bearbeiten, muss die ADMX-Datei sowie die entsprechende ADML-Sprachdatei geladen werden. Abhängig von der nativen Sprache, die den Bearbeitungs-/Berichterstellungsvorgang anfordert, wird die ADML-Datei im entsprechenden Sprachordner gesucht (en for en, de for de, a so on). Wenn beispielsweise der Abfragebenutzer englisch möchte und der zentrale GPO-Speicher nur die deutschen ADML-Dateien installiert hat, tritt ein solcher Fehler auf.
Die Fehlerberichterstattung ist falsch, da sie auf die ADMX-Datei verweist, da sie fehlt, während diese Datei am angegebenen Speicherort vorhanden ist.
Lösung
Wenn die ADML-Dateien für die im richtigen Ordner abgefragte Sprache verfügbar sind, wird das Problem gelöst. Informationen zum Erstellen des zentralen Informationsspeichers für administrative Gruppenrichtlinienvorlagendateien in Windows Vista.
Datensammlung
Wenn Sie Unterstützung vom Microsoft-Support benötigen, empfehlen wir Ihnen, die Informationen zu sammeln, indem Sie die unter " Sammeln von Informationen" genannten Schritte unter Verwendung von TSS für Gruppenrichtlinienprobleme ausführen.