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Übersicht über Probleme, die auftreten können, wenn administrative Freigaben fehlen

Dieser Artikel enthält eine Lösung für die Probleme, die auftreten können, wenn administrative Freigaben fehlen.

Ursprüngliche KB-Nummer: 842715

Übersicht

In diesem Artikel werden die Symptome beschrieben, die auftreten können, wenn mindestens eine der versteckten administrativen Freigaben auf Ihrem Computer fehlt. Der Artikel enthält auch Informationen zum Beheben dieses Problems.

Wenn Sie bereits festgestellt haben, dass auf Ihrem Computer mindestens eine der ausgeblendeten administrativen Freigaben fehlt, lesen Sie die Abschnitte "Ursache" und "Lösung". Beachten Sie, dass fehlende administrative Freigaben in der Regel darauf hindeuten, dass der betreffende Computer von bösartiger Software kompromittiert wurde. Es wird empfohlen, dass Benutzer Windows auf kompromittierten Servern formatieren und erneut installieren.

Symptome

Es kann eine Vielzahl von Problemen auftreten, wenn administrative Freigaben entfernt werden oder anderweitig von Ihrem Computer fehlen.

Wenn Sie den Net Share-Befehl oder MPSReports verwenden, zeigt die Ausgabe möglicherweise an, dass auf Ihrem Computer die IPC$-, ADMIN$- oder C$-Freigabe fehlt. Wenn Sie eine fehlende Freigabe erneut erstellen, fehlt sie möglicherweise erneut nach dem nächsten Start oder der nächsten Anmeldung. Dieses Problem kann auch dann auftreten, wenn Sie die Registrierungs-DWORD-Werte für AutoShareServer und AutoShareWks auf 1 festlegen.

Möglicherweise finden Sie unbekannte Prozesse, die aus dem Startordner oder aus dem Run-Schlüssel in der Registrierung beginnen. Antivirensoftware kann Viren, Würmer, Trojaner oder Hintertüren erkennen. Oder der FTP-Stamm auf einem Webserver kann mit unbekannten Dateien gefüllt werden.

Die folgende Liste ist eine umfassende Liste des problematischen Verhaltens, das mit diesem Problem verbunden sein kann.

  • Wenn der betroffene Computer ein Domänencontroller ist, erhalten Sie möglicherweise Fehlermeldungen auf Clientcomputern während der Netzwerkanmeldung oder während der Zeit, in der er versucht, der Domäne beizutreten. Manchmal können Sie sich mit Clientcomputern anmelden, aber möglicherweise wird eine Fehlermeldung angezeigt, die einem der folgenden ähnelt:

    • Das angegebene Domänenkennwort ist nicht korrekt, oder der Zugriff auf Ihren Anmeldeserver wurde verweigert.

    • Der Anmeldeserver hat Ihr Domänenkennwort nicht erkannt, oder der Zugriff auf den Server wurde verweigert.

    • Für die Anmeldeanforderung steht kein Anmeldeserver zur Verfügung.

      Wenn Sie versuchen, der Domäne beizutreten, wird möglicherweise eine Fehlermeldung angezeigt, die etwa wie folgt lautet:

      Beim Versuch, der Domäne "Domain_Name" beizutreten, ist der folgende Fehler aufgetreten: Der Netzwerkname wurde nicht gefunden.

  • Wenn Sie versuchen, remote auf den betroffenen Computer zuzugreifen oder ihn anzuzeigen, indem Sie einen UNC-Pfad, ein zugeordnetes Laufwerk, den Netznutzungsbefehl, den Netzansichtsbefehl oder das Netzwerk in der Netzwerkviertel oder "Meine Netzwerkorte" durchsuchen, erhalten Sie möglicherweise eine Fehlermeldung, die einer der folgenden Elemente ähnelt:

    • Der Server ist nicht für Transaktionen konfiguriert.

    • „Systemfehler 53 ist aufgetreten. Der Netzwerkpfad wurde nicht gefunden.“

    • Domain_Name ist nicht zugänglich.

  • Möglicherweise erhalten Sie Fehler, wenn Sie versuchen, administrative Aufgaben auf einem Domänencontroller auszuführen. Beispielsweise werden MMC-Snap-Ins wie Active Directory-Benutzer und -Computer oder Active Directory-Standorte und -Dienste möglicherweise nicht gestartet, und Sie erhalten möglicherweise eine Fehlermeldung, die dem folgenden ähnelt:

    Benennungsinformationen können nicht gefunden werden, da der Anmeldeversuch fehlgeschlagen ist.

  • Wenn Sie versuchen, einen Benutzer zu einer Sicherheitsgruppe hinzuzufügen, wird möglicherweise eine Fehlermeldung angezeigt, die etwa wie folgt lautet:

    Die Objektauswahl kann nicht geöffnet werden, da keine Speicherorte zum Auswählen von Objekten gefunden werden können.

  • Wenn Sie versuchen, Netdom.exe auszuführen, um die FSMO-Rollen zu finden, erhalten Sie möglicherweise eine Fehlermeldung, die dem folgenden ähnelt:

    Das Kennwort kann nicht aktualisiert werden. Der als aktuelles Kennwort angegebene Wert ist falsch.

  • Wenn Sie versuchen, Dcdiag.exe auszuführen, wird möglicherweise eine Fehlermeldung angezeigt, die dem folgenden ähnelt:

    Fehler bei 67: Der Netzwerkname konnte nicht gefunden werden.

    Die Ergebnisse aus Dcdiag.exe können auch LDAP-Bindungsfehler auflisten, die dem folgenden ähneln:

    Fehler bei der LDAP-Bindung mit Fehler 1323.

  • Wenn Sie versuchen, Netdiag.exe auszuführen, wird möglicherweise eine Fehlermeldung angezeigt, die etwa wie folgt lautet:

    DC-Listentest. . . . . . . . . . . Fehlgeschlagen:
    Fehler beim Aufzählen von DCs mithilfe des Browsers. [NERR_BadTransactConfig]

  • Wenn Sie eine Netzwerkablaufverfolgung ausführen, wenn Sie versuchen, eine Verbindung mit dem betroffenen Computer herzustellen, werden möglicherweise Ergebnisse angezeigt, die dem folgenden ähneln:

    C session setup & X, Username = username, and C tree connect & X, Share = \\<Server_Name>\IPC$  
    R session setup & X - DOS Error, (67) BAD_NET_NAME
    
  • Auf dem Server wird der WINS-Dienst möglicherweise nicht gestartet, oder die WINS-Konsole zeigt ein rotes X oder beides an.

  • NetBT 4311-Ereignisse, die den folgenden ähneln, können in Ereignisanzeige protokolliert werden:

    Ereignis-ID: 4311
    Ereignisquelle: NetBT
    Ereignistyp: Fehler
    Beschreibung: Fehler bei der Initialisierung, da das Treibergerät nicht erstellt werden konnte.

  • Die Terminaldienste-Lizenzierungskonsole wird möglicherweise nicht gestartet, und Möglicherweise wird eine Fehlermeldung angezeigt, die etwa wie folgt lautet:

    • In der aktuellen Domäne oder Arbeitsgruppe ist kein Lizenzserver für Terminaldienste verfügbar. Um eine Verbindung mit einem anderen Lizenzserver herzustellen, klicken Sie auf "Lizenz", klicken Sie auf "Verbinden", und klicken Sie auf den Servernamen.

    • Die Netzwerkadresse ist ungültig.

Ursache

Diese Probleme können auftreten, nachdem ein schädliches Programm die administrativen Freigaben auf einem Computer entfernt hat, auf dem Windows Server ausgeführt wird.

Häufig stellen böswillige Benutzer eine Verbindung zu diesen administrativen Freigaben her, indem sie schwache Kennwörter nutzen, fehlende Sicherheitsupdates, direkte Gefährdung des Computers im Internet oder eine Kombination dieser Faktoren nutzen. Die böswilligen Benutzer installieren dann schädliche Programme, um ihren Einfluss auf den Computer und über den Rest des Computernetzwerks zu erweitern. In vielen Fällen entfernen diese bösartigen Programme die administrativen Freigaben als defensive Bewegung, um andere konkurrierende böswillige Benutzer daran zu hindern, die Kontrolle über die infizierten Systeme zu übernehmen.

Die Infektion durch eines dieser schädlichen Programme kann direkt aus dem Internet oder von einem anderen Computer im lokalen Netzwerk kommen, der infiziert ist. Es weist im Allgemeinen darauf hin, dass die Sicherheit im Netzwerk schwach ist. Daher empfehlen wir, alle anderen Computer im Netzwerk anhand von Antivirensoftware und Spyware-Erkennungstools zu untersuchen, wenn Sie diese Symptome sehen. Außerdem wird empfohlen, eine Sicherheitsanalyse durchzuführen, um Sicherheitsrisiken im Netzwerk zu identifizieren. Informationen zum Erkennen bösartiger Programme und zur Analyse der Netzwerksicherheit finden Sie im Abschnitt "Lösung".

Ein Beispiel für ein schädliches Programm, das auf administrative Freigaben abzielt, ist das Win32.Agobot Programm.

Die Kontaktinformationen zu den in diesem Artikel erwähnten Drittanbietern sollen Ihnen helfen, den benötigten technischen Support zu finden. Diese Kontaktinformationen können ohne vorherige Ankündigung geändert werden. Sie werden von Microsoft ohne jede Gewähr weitergegeben.

Notiz

Das Win32.Agobot Programm ist nur ein Beispiel. Bösartige Programme werden veraltet, da Antivirenanbieter sie entdecken und zu ihren Virusdefinitionen hinzufügen. Böswillige Benutzer entwickeln jedoch häufig neue Programme und Varianten, um die Erkennung durch Antivirensoftware zu vermeiden.

Lösung

Wichtig

Dieser Abschnitt, diese Methode bzw. diese Aufgabe enthält eine Beschreibung der Schritte zum Bearbeiten der Registrierung. Durch die falsche Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Daher müssen Sie sicherstellen, dass Sie diese Schritte sorgfältig ausführen. Für weiteren Schutz sichern Sie die Registrierung, bevor Sie sie ändern. Sie können die Registrierung wiederherstellen, wenn ein Problem auftritt. Weitere Informationen zum Erstellen und Wiederherstellen einer Sicherungskopie der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
322756 Sichern und Wiederherstellen der Registrierung in Windows

Führen Sie die folgenden Schritte aus, um zu überprüfen, ob ein Computer von diesem Problem betroffen ist:

  1. Überprüfen Sie die Registrierungswerte AutoShareServer und AutoShareWks, um sicherzustellen, dass sie nicht auf 0 festgelegt sind:

    1. Klicken Sie auf "Start", klicken Sie auf "Ausführen", geben Sie "regedit" ein, und drücken Sie dann die EINGABETASTE.
    2. Finden und klicken Sie auf den folgenden Registrierungsunterschlüssel: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters
    3. Wenn die DWORD-Werte "AutoShareServer" und "AutoShareWks" im Unterschlüssel "LanmanServer\Parameters " mit einem Wert von 0 konfiguriert sind, ändern Sie diesen Wert in 1.

      Notiz

      Wenn diese Werte nicht vorhanden sind, müssen Sie sie nicht erstellen, da das Standardverhalten darin besteht, die administrativen Freigaben automatisch zu erstellen.

    4. Beenden Sie den Registrierungs-Editor.
  2. Starten Sie den Computer neu. Normalerweise erstellen Computer, auf denen Windows Server ausgeführt wird, während des Starts automatisch die administrativen Freigaben.

  3. Überprüfen Sie nach dem Neustart des Computers, ob die administrativen Freigaben aktiv sind. Um die Freigaben zu untersuchen, verwenden Sie den Net Share-Befehl. Gehen Sie dazu wie folgt vor:

    1. Klicken Sie auf "Start", klicken Sie auf "Ausführen", geben Sie cmd ein, und drücken Sie dann die EINGABETASTE.

    2. Geben Sie an der Eingabeaufforderung net share ein, und drücken Sie dann die EINGABETASTE.

    3. Suchen Sie nach den Administrativen Freigaben "Admin$", "C$" und "IPC$" in der Liste der Freigaben.

Wenn die administrativen Freigaben nicht aufgeführt sind, wird auf dem Computer möglicherweise ein schädliches Programm ausgeführt, das die Freigaben während des Starts entfernt. Führen Sie die folgenden Schritte aus, um nach bösartigen Programmen zu suchen:

  1. Verwenden Sie die neuesten Virendefinitionen, um einen vollständigen Virenscan auf dem Computer auszuführen. Sie können Ihre Antivirensoftware verwenden oder einen von mehreren kostenlosen Virenscandiensten verwenden, die im Internet verfügbar sind. Im Abschnitt "Weitere Informationen" finden Sie Links zu Virendefinitionsupdates und kostenlosen Online-Scans von Antivirensoftwareanbietern.

    Wichtig

    Wenn Sie vermuten, dass ein Computer mit bösartigem Code infiziert ist, empfehlen wir, ihn so schnell wie möglich aus dem Netzwerk zu entfernen. Wir empfehlen dies, da ein böswilliger Benutzer möglicherweise den infizierten Computer verwendet, um Verteilte Denial of Service (DDoS)-Angriffe zu starten, unerwünschte kommerzielle E-Mails zu senden oder illegale Kopien von Software, Musik und Filmen zu teilen.

  2. Wenn der Antivirusscan ein schädliches Programm auf dem System identifiziert, verwenden Sie die Entfernungsanweisungen des Antivirenanbieters. Überprüfen Sie außerdem die Bedrohungsbewertung und die technischen Details zum Programm auf der Website Ihres Antivirenanbieters. Überprüfen Sie insbesondere, ob das Programm Backdoor-Funktionen enthält. Die Backdoor-Funktion bedeutet, dass das Programm dem böswilligen Benutzer die Möglichkeit bietet, die Kontrolle über das System zu erlangen, wenn das Programm entdeckt und entfernt wird.

    Wenn die technischen Details zum Programm angeben, dass es über Backdoor-Funktionen verfügt, empfehlen wir, die Festplatte des Computers zu formatieren und Windows sicher neu zu installieren. Informationen zur Verbesserung der Sicherheit von Windows-basierten Computern und Servern finden Sie im folgenden Microsoft Security Guidance Center.

  3. Wenn der Antivirenscan kein schädliches Programm auf dem System identifiziert, bedeutet dies nicht, dass der Computer nicht durch ein schädliches Programm infiziert ist. Wahrscheinlicher ist es, dass das bösartige Programm ein neues Programm oder eine neue Variante ist und dass die neuesten Virusdefinitionen es nicht erkennen. Wenden Sie sich in diesem Fall an den Antivirenanbieter, um das Problem zu melden, oder öffnen Sie einen Supportvorfall mit Microsoft Product Support Services (PSS), um das Problem zu untersuchen.

  4. Überprüfen Sie nach Abschluss des Antivirenscans den Computer auf andere schädliche Programme, z. B. Spyware oder bösartige Benutzertools. Im Abschnitt "Weitere Informationen" finden Sie Links zu Spyware und zu Tools zur Erkennung bösartiger Benutzer.

  5. Die Kontaktinformationen zu den in diesem Artikel erwähnten Drittanbietern sollen Ihnen helfen, den benötigten technischen Support zu finden. Diese Kontaktinformationen können ohne vorherige Ankündigung geändert werden. Sie werden von Microsoft ohne jede Gewähr weitergegeben.