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Die Leistung ist schlecht, wenn benutzerdefiniertes Standardbenutzerprofil in Windows verwendet wird.

Dieser Artikel enthält eine Lösung für Probleme, die auftreten, wenn Sie Standardbenutzerprofile verwenden.

Gilt für: Windows 10 – alle Editionen, Windows Server 2019, Windows Server 2016
Ursprüngliche KB-Nummer: 4056823

Symptom

Nehmen Sie das folgende Szenario als Beispiel:

  • Sie erstellen ein neues Standardbenutzerprofil und aktivieren es.
  • Ein neuer Benutzer meldet sich mithilfe eines Profils an, das über das Standardprofil auf einem Windows 10-, Windows Server 2016- oder Windows Server 2019-basierten Computer erstellt wird.

In diesem Szenario treten mindestens eine der folgenden Probleme auf:

  • Desktopsymbole dauern lange, bis sie angezeigt werden.

  • Die Leistung ist schlecht, wenn Sie internet Explorer oder Microsoft Edge starten oder durchsuchen.

  • ESENT-Fehler wie die folgenden werden im Ereignisprotokoll aufgezeichnet:

    EventLogID: 454
    TaskHostW: (pid)
    WebCacheLocal: "Datenbankwiederherstellung/Wiederherstellung fehlgeschlagen mit unerwartetem Fehler -1907"

    Hinweis

    Die vollständige Ereignisprotokollnachricht kann auch eine Zuordnung zu einem anderen Speicherort des Benutzerordners angeben, z. B. "C:\Benutzer\Administrator".

Ursache

Diese Probleme treten auf, da das Standardbenutzerprofil eine gesperrte Kopie der Cachedatenbank eines anderen Benutzers enthält.

Wenn sich ein neuer Benutzer am Computer anmeldet, wird der Standardinhalt des Benutzerprofils in sein neues Profil integriert. Da die Windows-Shell und der Desktop mit dem Laden beginnen, kann die Datenbank nicht vollständig initialisiert werden. Anwendungen, die die Datenbank verwenden, haben negative Leistung oder melden Fehler.

Lösung

Gehen Sie folgendermaßen vor, um das Problem zu beheben:

  1. Melden Sie sich bei jedem betroffenen Computer an, indem Sie ein Konto verwenden, das über Administratoranmeldeinformationen verfügt, und löschen Sie dann die folgende ausgeblendete Datei und den folgenden Ordner, falls vorhanden:

    Datei: C:\Users\Default\AppData\Local\Microsoft\Windows\WebCacheLock.dat
    Ordner: C:\Users\Default\AppData\Local\Microsoft\Windows\WebCache

  2. Stellen Sie für jedes Benutzerkonto auf dem Computer sicher, dass der Benutzer vollständig abgemeldet ist und das Profil vollständig entladen wurde, und löschen Sie dann die folgende ausgeblendete Datei und den folgenden Ordner, falls vorhanden:

    Datei: C:\Users\<affectedUserFolder>\AppData\Local\Microsoft\Windows\WebCacheLock.dat
    Ordner: C:\Users\<affectedUserFolder>\AppData\Local\Microsoft\Windows\WebCache

Hinweis

<affectedUserFolder> ist ein Platzhalter für den Namen des Benutzerprofilordners. For example, for the Administrator user account, the folder is under C:\Users\Administrator. Sie müssen die oben genannten Dateien und Ordner für jedes betroffene Benutzerkonto auf dem Computer entfernen.

So zeigen Sie ausgeblendete Dateien an

Führen Sie die folgenden Schritte aus, um ausgeblendete Dateien anzuzeigen:

  1. Wählen Sie im Windows-Explorer "Datei" und dann "Optionen" aus.
  2. Wählen Sie auf der Registerkarte "Ansicht " die Option "Ausgeblendete Dateien, Ordner und Laufwerke anzeigen" aus.
  3. Deaktivieren Sie die Option "Geschützte Betriebssystemdateien ausblenden" (Empfohlen), und klicken Sie dann auf "OK".

Hinweis

Es wird empfohlen, die beiden Optionen erneut auszuwählen, nachdem das Problem behoben wurde.

Weitere Informationen

Da die Cachedatenbank zum Zeitpunkt der anfänglichen Anmeldung bei einem einzelnen Computer pro Benutzer generiert werden soll, empfiehlt oder unterstützt Microsoft nicht die Aufnahme der Cachedatenbank in die Standarddatenbank oder ein anderes Benutzerprofil, das als Vorlage verwendet werden soll.