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Dieser Artikel enthält Problemumgehungen für ein Problem, bei dem Sie keine Verbindung mit einem Remotecomputer herstellen oder eine Remoteanwendung starten können, wenn Sie TS Web Access oder RemoteWeb Workspace verwenden.
Ursprüngliche KB-Nummer: 951607
Symptome
Auf einem windows XP Service Pack 3 (SP3)-basierten oder Windows Small Business Server 2003 Service Pack 1 (SP1)-basierten Computer treten die folgenden Symptome auf:
Wenn Sie versuchen, über die Remotedesktopwebverbindung (TSWeb) eine Verbindung mit einem Remotecomputer herzustellen, ist die Schaltfläche "Verbinden " deaktiviert. Die TSWeb-Seite kann auch die folgende Warnmeldung enthalten:
Das ActiveX-Steuerelement für Remotedesktop-Webverbindung ist nicht installiert. Eine Verbindung kann nicht ohne eine funktionierende installierte Version des Steuerelements hergestellt werden.
Notiz
Wenn Sie versuchen, den Remotedesktopverbindung 6.0-Client zu installieren, wird eine Meldung angezeigt, dass er bereits auf dem Computer installiert ist.
Wenn Sie die REMOTE Web Workspace (RWW)-Website zum Herstellen einer Verbindung mit einem Remotecomputer verwenden, stellen Sie fest, dass Sie das ActiveX-Steuerelement für die Remotedesktopverbindung nicht herunterladen können. Oder Sie erhalten die folgende Fehlermeldung:
Ungültiger Servername.
Notiz
RemoteWeb Workspace ist ein Feature, das in Microsoft Windows Small Business Server (Windows SBS) verfügbar ist.
Wenn Sie die Terminal Services Web Access (TSWA)-Website verwenden, um eine Verbindung mit einem Remotecomputer herzustellen oder eine Remoteanwendung zu starten, wird die folgende Fehlermeldung angezeigt: Für diese Website ist der Terminaldienste-Client erforderlich, der auf diesem System nicht installiert wird. Installieren Sie den neuesten Client, und stellen Sie sicher, dass Sie über die neuesten Windows-Updates verfügen, bevor Sie fortfahren.
Wenn Sie über Windows Home Server auf Die Seite "Remotezugriffscomputer" zugreifen, wird möglicherweise die folgende Fehlermeldung angezeigt: "Add-On deaktiviert" Diese Webseite fordert ein deaktiviertes Add-On an. Um das Add-On zu aktivieren, klicken Sie hier. Wenn Sie versuchen, eine Verbindung mit Ihrem Windows Home Server oder einem Heimcomputer herzustellen, wird möglicherweise die folgende Fehlermeldung angezeigt:
Für dieses Feature muss die Websiteadresse
https://my.homeserver.com
Ihres Windows Home Server der Zone "Vertrauenswürdige Sites" in Internet Explorer hinzugefügt werden. Um die Websiteadresse Ihres Windows Home Server hinzuzufügen, öffnen Sie das Dialogfeld "Internetoptionen" von Internet Explorer, und klicken Sie auf die Registerkarte "Sicherheit". Wählen Sie "Vertrauenswürdige Websites" aus, und klicken Sie auf die Schaltfläche "Websites". Fügen Sie die Websiteadressehttps://my.homeserver.com
mit der Schaltfläche "Hinzufügen" hinzu, und drücken Sie dann "Schließen".Notiz
Nachdem Sie der Liste der vertrauenswürdigen Websites die URL des Startservers hinzugefügt haben, erhalten Sie dieselbe Fehlermeldung, und Sie können trotzdem keine Verbindung herstellen.
Wenn Sie mithilfe des Remotezugriffs auf Ihren Windows Home Server zugreifen, wird möglicherweise die folgende Fehlermeldung angezeigt:
Add-On deaktiviert Diese Webseite fordert ein deaktiviertes Add-On an. Um das Add-On zu aktivieren, klicken Sie hier.
Wenn Sie versuchen, eine Verbindung mit Ihrem Windows Home Server herzustellen, wird möglicherweise die folgende Fehlermeldung angezeigt: Um remote eine Verbindung mit Ihrem Heimserver oder Heimcomputer herzustellen, muss das Microsoft Terminal Services Client Control-Add-On oder das Microsoft RDP-Add-On installiert und für Ihren Webbrowser aktiviert sein. Wenn Sie die Installation des Add-Ons abgelehnt haben, aktualisieren Sie die Seite, und installieren Sie es, wenn Sie dazu aufgefordert werden. Aktivieren Sie andernfalls dieses Add-On mithilfe des Symbols "Add-Ons verwalten" in der Statusleiste des Webbrowsers, oder lesen Sie die Dokumentation Ihres Webbrowsers zum Aktivieren dieses Add-Ons.
Ursache
Dieses Problem tritt auf, wenn das ActiveX-Steuerelement für den Remotedesktopverbindungsclient nicht im Webbrowser aktiviert ist. Standardmäßig ist das ActiveX-Steuerelement nach der Installation von Windows XP Service Pack 3 (SP3) oder Windows Small Business Server 2003 SP1 deaktiviert.
Problemumgehung
Gehen Sie folgendermaßen vor, um dieses Problem zu umgehen:
Starten Sie Internet Explorer.
Besuchen Sie die Website, die dieses Problem verursacht.
Wenn Sie Windows Internet Explorer 7 verwenden, führen Sie die folgenden Schritte aus:
- Zeigen Sie im Menü "Extras " auf "Add-Ons verwalten", und klicken Sie dann auf "Add-Ons aktivieren oder deaktivieren". Das Dialogfeld "Add-Ons verwalten" wird angezeigt.
- Suchen Sie in der Liste der Add-Ins nach dem ActiveX-Steuerelement des Microsoft Terminal Services-Clientsteuerelements oder nach dem ActiveX-Steuerelement des Microsoft RDP-Clientsteuerelements. Wenn Sie das Steuerelement nicht finden können, lesen Sie die Schritte unter "Wenn das Steuerelement nicht in der Liste der Add-Ons angezeigt wird" am Ende dieses Abschnitts.
- Klicken Sie auf das Steuerelement, klicken Sie auf "Aktivieren", und klicken Sie dann auf "OK ", um das Dialogfeld "Add-Ons verwalten" zu schließen.
Wenn Sie Internet Explorer 6 verwenden, führen Sie die folgenden Schritte aus:
- Klicken Sie im Menü "Extras " auf "Add-Ons verwalten". Das Dialogfeld "Add-Ons verwalten" wird angezeigt.
- Suchen Sie in der Liste der Add-Ins nach dem ActiveX-Steuerelement des Microsoft Terminal Services-Clientsteuerelements oder nach dem ActiveX-Steuerelement des Microsoft RDP-Clientsteuerelements. Wenn Sie das Steuerelement nicht finden können, lesen Sie die Schritte unter "Wenn das Steuerelement nicht in der Liste der Add-Ons angezeigt wird" am Ende dieses Abschnitts.
- Klicken Sie auf das Steuerelement, klicken Sie auf "Aktivieren", und klicken Sie dann auf "OK ", um das Dialogfeld "Add-Ons verwalten" zu schließen.
Fügen Sie die Website zu Ihren vertrauenswürdigen Websites in Internet Explorer hinzu.
Starten Sie Internet Explorer neu.
Versuchen Sie, eine Verbindung mit dem Remotecomputer herzustellen. Oder versuchen Sie, die Remoteanwendung zu starten.
Wenn das Steuerelement nicht in der Liste der Add-Ons angezeigt wird
Manchmal wird das ActiveX-Steuerelement des Microsoft Terminal Services-Clientsteuerelements nicht in der Liste der Add-Ons angezeigt.
Um dieses Problem zu beheben, können Sie die folgenden Schritte ausprobieren, um zu versuchen, das Steuerelement anzuzeigen, indem Sie Internet Explorer auf eine Standardkonfiguration zurücksetzen.
- Starten Sie Internet Explorer.
- Klicken Sie auf "Datei" und dann auf "Importieren und Exportieren".
- Führen Sie die Schritte im Assistenten aus, um Ihre Favoriten zu exportieren.
- Klicken Sie auf Tools und dann auf Internetoptionen.
- Klicken Sie auf "Erweitert" und dann auf "Zurücksetzen".
Nachdem Internet Explorer auf eine Standardkonfiguration zurückgesetzt wurde, versuchen Sie, eine Verbindung mit dem Remotecomputer herzustellen oder die Remoteanwendung zu starten. Wenn dies nicht funktioniert, führen Sie die Schritte in der Problemumgehung aus, um das ActiveX-Steuerelement des Microsoft-Terminaldienst-Clientsteuerelements zu aktivieren. Wenn das Steuerelement immer noch nicht aufgeführt ist, können Sie die Registrierung ändern, um einen Schlüssel zu entfernen, sofern vorhanden.
Wichtig
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Sie sollten eine Sicherungskopie der Registrierung erstellen, bevor Sie die Registrierung bearbeiten. Sie müssen wissen, wie die Registrierung wiederhergestellt werden kann, wenn ein Problem auftritt. Weitere Informationen zum Sichern, Wiederherstellen und Ändern der Registrierung finden Sie in der Microsoft Knowledge Base auf der folgenden Artikelnummer: 322756 Sichern und Wiederherstellen der Registrierung in Windows
Entfernen Sie die folgenden Registrierungsschlüssel, sofern vorhanden:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{7584C670-2274-4EFB-B00B-D6AABA6D3850}
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{971127BB-259F-48C2-BD75-5F97A3331551}
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{9059F30F-4EB1-4BD2-9FDC-36F43A218F4A}
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{4EB89FF4-7F78-4A0F-8B8D-2BF02E94E4B2}
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{4EDCB26C-D24C-4e72-AF07-B576699AC0DE}
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{7390F3D8-0439-4C05-91E3-CF5CB290C3D0}
Nachdem die Registrierungsschlüssel entfernt wurden, beenden Sie Internet Explorer, und starten Sie sie erneut, und versuchen Sie, eine Verbindung mit dem Remotecomputer herzustellen oder die Remoteanwendung erneut zu starten.
Wenn das Problem dadurch nicht behoben wird, können Sie die mstscax.dll Datei erneut registrieren. Gehen Sie dazu wie folgt vor:
Beenden Sie Internet Explorer.
Klicken Sie auf "Start", klicken Sie auf "Ausführen", und geben Sie den folgenden Text in das Feld "Öffnen" ein, und klicken Sie auf "OK": %windir%\system32\regsvr32 mstscax.dll
Klicken Sie an der Bestätigungsaufforderung auf "OK".
Starten Sie Internet Explorer neu, und versuchen Sie, eine Verbindung mit dem Remotecomputer herzustellen oder die Remoteanwendung zu starten.
Weitere Informationen
In Windows XP Service Pack 2 (SP2) mussten Sie die Datei Msrdp.ocx installieren, um das ActiveX-Steuerelement für Terminaldienste zu aktivieren. Windows XP Service Pack 3 (SP3) enthält dieses ActiveX-Steuerelement bereits und installiert es mithilfe der Mstscax.dll-Datei. Standardmäßig ist dieses ActiveX-Steuerelement in Windows XP Service Pack 3 (SP3) deaktiviert.