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Dieser Artikel bietet eine Lösung für ein Problem, bei dem Terminaldienste-Clients nach dem Upgrade von Windows wiederholt zugriff auf den Terminalserver verweigert werden.
Ursprüngliche KB-Nummer: 329896
Symptome
Nachdem Sie eine Microsoft Windows NT-Domäne auf Windows 2000 oder Windows Server 2003 aktualisiert haben, wird windows 2000-Terminaldienste-Clients möglicherweise wiederholt der Zugriff auf den Terminalserver verweigert. Wenn Sie einen Terminaldienste-Client verwenden, um sich beim Terminalserver anzumelden, erhalten Sie möglicherweise eine der folgenden Fehlermeldungen:
Aufgrund eines Sicherheitsfehlers konnte der Client keine Verbindung mit dem Terminalserver herstellen. Wenn Sie genau wissen, dass Sie am Netzwerk angemeldet sind, versuchen Sie erneut, eine Verbindung mit dem Server herzustellen.
or
Remotedesktop getrennt. Aufgrund eines Sicherheitsfehlers konnte der Client keine Verbindung mit dem Remotecomputer herstellen. Stellen Sie sicher, dass Sie am Netzwerk angemeldet sind, und versuchen Sie dann noch einmal, eine Verbindung herzustellen.
Darüber hinaus werden die folgenden Ereignis-ID-Nachrichten möglicherweise in Ereignisanzeige auf dem Terminalserver protokolliert:
Ereignis-ID: 50
Ereignisquelle: TermDD
Ereignisbeschreibung: Die RDP-Protokollkomponente X.224 hat einen Fehler im Protokolldatenstrom erkannt und den Client getrennt.
und
Ereignis-ID: 1008
Ereignisquelle: TermService
Ereignisbeschreibung: Die Lizenzfrist für Terminaldienste ist abgelaufen, und der Dienst hat sich nicht bei einem Lizenzserver registriert. Für den kontinuierlichen Betrieb ist ein Lizenzserver für Terminaldienste erforderlich. Ein Terminalserver kann nach dem ersten Start 90 Tage ohne Lizenzserver ausgeführt werden.
und
Ereignis-ID: 1004
Ereignisquelle: TermService
Ereignisbeschreibung: Der Terminalserver kann keine Clientlizenz ausgeben.
und
Ereignis-ID: 1010
Ereignisquelle: TermService
Ereignisbeschreibung: Die Terminaldienste konnten keinen Lizenzserver finden. Vergewissern Sie sich, dass alle Lizenzserver im Netzwerk in WINS\DNS registriert sind, Netzwerkanforderungen akzeptieren und der Terminaldienste-Lizenzierungsdienst ausgeführt wird.
und
Ereignis-ID: 28
Ereignisquelle: TermServLicensing
Ereignisbeschreibung: Die Terminaldienstelizenzierung kann nur auf Domänencontrollern oder Servern in einer Arbeitsgruppe ausgeführt werden. Weitere Informationen finden Sie im Hilfethema zur Terminalserverlizenzierung.
Ursache
Dieses Problem kann auftreten, wenn ein Zertifikat auf dem Terminalserver beschädigt ist.
Lösung
Wichtig
Dieser Abschnitt, diese Methode bzw. diese Aufgabe enthält eine Beschreibung der Schritte zum Bearbeiten der Registrierung. Durch die falsche Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Daher müssen Sie sicherstellen, dass Sie diese Schritte sorgfältig ausführen. Für weiteren Schutz sichern Sie die Registrierung, bevor Sie sie ändern. Anschließend können Sie die Registrierung wiederherstellen, wenn ein Problem auftritt. Weitere Informationen zum Sichern und Wiederherstellen der Registrierung finden Sie in der Microsoft Knowledge Base auf der folgenden Artikelnummer: 322756 Sichern und Wiederherstellen der Registrierung in Windows
Um dieses Problem zu beheben, sichern Sie die X509-Zertifikatregistrierungsschlüssel, starten Sie den Computer neu, und reaktivieren Sie dann den Terminaldienste-Lizenzierungsserver. Gehen Sie hierzu wie folgt vor.
Notiz
Führen Sie das folgende Verfahren auf jedem der Terminalserver aus.
Stellen Sie sicher, dass die Registrierung des Terminalservers erfolgreich gesichert wurde.
Starten Sie den Registrierungs-Editor.
Klicken Sie auf den folgenden Registrierungsunterschlüssel:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Parameters
Klicken Sie im Menü Registrierung auf Registrierungsdatei exportieren.
Geben Sie exportierte Parameter in das Feld "Dateiname " ein, und klicken Sie dann auf " Speichern".
Notiz
Wenn Sie diesen Registrierungsunterschlüssel in Zukunft wiederherstellen müssen, doppelklicken Sie auf die Datei „Exported-parameters.reg", die Sie in diesem Schritt gespeichert haben.
Klicken Sie unter dem Registrierungsunterschlüssel "Parameters " mit der rechten Maustaste auf jeden der folgenden Werte, klicken Sie auf "Löschen", und klicken Sie dann auf "Ja ", um den Löschvorgang zu bestätigen:
- Bescheinigung
- X509-Zertifikat
- X509-Zertifikat-ID
Beenden Sie den Registrierungs-Editor, und starten Sie den Server dann neu.
Reaktivieren Sie den Terminaldienste-Lizenzierungsserver mithilfe der Telefonverbindungsmethode im Lizenzierungs-Assistenten.
Notiz
Wenn Sie den Terminaldienste-Lizenzierungsserver mithilfe der Option "Telefon " aktivieren, verwendet der Lizenzierungsserver eine andere Form von Zertifikat.