Fehlermeldung "Dienstspezifischer Fehlercode -2147944102", wenn Sie versuchen, den BITS-Dienst zu starten

Dieser Artikel enthält eine Lösung für einen Fehler 2147944102, der auftritt, wenn Sie den BitS-Dienst (Background Intelligent Transfer Service) starten.

Ursprüngliche KB-Nummer: 326460

Symptome

Wenn Sie versuchen, den BITS-Dienst auf einem Windows 2000-basierten Computer zu starten, auf dem Terminaldienste installiert sind, können die folgenden Symptome auftreten:

  • Sie erhalten eine der folgenden Fehlermeldungen:

    Windows konnte den Intelligenten Hintergrundübertragungsdienst nicht auf dem lokalen Computer starten. Weitere Informationen können Sie im Systemereignisprotokoll anzeigen. Wenn es sich um einen Nicht-Microsoft-Dienst handelt, wenden Sie sich an den Dienstanbieter, und verweisen Sie auf den dienstspezifischen Fehlercode -2147023194.

    Oder

    Ein dienstspezifischer Fehler ist aufgetreten: -2147944102.

  • Das folgende Ereignis wird im Systemprotokoll von Windows NT Ereignisanzeige aufgezeichnet:

    Ereignistyp: Fehler
    Ereignisquelle: Dienststeuerungs-Manager
    Ereigniskategorie: Keine
    Ereignis-ID: 7024
    Benutzer: N/V
    Beschreibung: Der Dienst für den intelligenten Hintergrundübertragungsdienst wurde mit dienstspezifischem Fehler 2147944102 beendet.

Ursache

Dieses Verhalten kann auftreten, wenn der Terminaldienstedienst deaktiviert ist.

Wenn die Terminaldienste-Komponente installiert ist, ist standardmäßig der Starttyp für den Terminaldienstedienst auf "Automatisch" festgelegt. Wenn ein Administrator den Starttyp des Diensts in "Deaktiviert" ändert, wird der BITS-Dienst nicht gestartet.

Lösung

Um dieses Problem zu beheben, rufen Sie das neueste Service Pack für Microsoft Windows 2000 ab.

Problemumgehung

Um dieses Problem zu umgehen, verwenden Sie eine der folgenden Methoden (entsprechend Ihrer Situation).

Methode 1: Konfigurieren der Terminaldienste für den automatischen Start

Führen Sie die folgenden Schritte aus, um den Terminaldienstedienst so zu konfigurieren, dass er automatisch gestartet wird:

  1. Klicken Sie auf "Start", zeigen Sie auf "Einstellungen", und klicken Sie dann auf Systemsteuerung.
  2. Doppelklicken Sie auf "Verwaltungstools", und doppelklicken Sie dann auf "Dienste".
  3. Klicken Sie im rechten Bereich mit der rechten Maustaste auf Terminaldienste, und klicken Sie dann auf Eigenschaften.
  4. Klicken Sie auf die Registerkarte Allgemein.
  5. Klicken Sie im Feld "Starttyp " auf "Automatisch" und dann auf "OK".

Methode 2: Entfernen von Terminaldiensten

Wenn Sie keine Terminaldienste benötigen oder nicht auf dem Server verwendet werden, entfernen Sie Terminaldienste. Gehen Sie dazu wie folgt vor:

  1. Klicken Sie auf "Start", zeigen Sie auf "Einstellungen", und klicken Sie dann auf Systemsteuerung.
  2. Doppelklicken Sie auf "Programme hinzufügen/entfernen".
  3. Klicken Sie auf Windows-Komponenten hinzufügen/entfernen.
  4. Klicken Sie im Windows-Komponenten-Assistenten, um das Kontrollkästchen "Terminaldienste " zu deaktivieren, und klicken Sie dann auf "Weiter".
  5. Klicken Sie auf der Seite "Abschließen des Assistenten für Windows-Komponenten" auf " Fertig stellen".
  6. Klicken Sie im Fenster "Programme hinzufügen/entfernen" auf " Schließen".

Status

Microsoft hat bestätigt, dass dies ein Problem in den Microsoft-Produkten ist, die am Anfang dieses Artikels aufgeführt sind. Dieses Problem wurde zuerst in Microsoft Windows 2000 Service Pack 4 behoben.

Weitere Informationen

Das im Abschnitt "Symptome" dieses Artikels beschriebene Problem kann auch auftreten, nachdem Sie Microsoft Software Update Services (SUS) 1.0 oder den Client für automatische Updates 2.2 auf einem Windows 2000 Server-basierten Computer mit installierten Terminaldiensten installiert haben.