Freigeben über


Fehler bei der VMware-Treiberinstallation in Windows Server 2008 R2 SP1

Dieser Artikel hilft bei der Behebung eines Problems, bei dem Sie Keine Treiber auf virtuellen Computern installieren können, die auf VMware gehostet werden. Dieses Problem tritt auf, wenn Sie das Kontrollkästchen "Dienst für die Interaktion mit Dem Desktop zulassen" nicht aktivieren.

Gilt für: Windows Server 2008 R2 Service Pack 1
Ursprüngliche KB-Nummer: 3025586

Problembeschreibung

Virtuelle Computer in VMware installieren oder aktualisieren einen Treiber nicht erfolgreich, wenn die folgenden Bedingungen erfüllt sind:

  • Sie installieren den Telnet Server-Dienst auf einem Computer, auf dem Windows Server 2008 R2 Service Pack 1 (SP1) ausgeführt wird und VMware vSphere installiert ist.
  • Sie konfigurieren den Telnet-Serverdienst so, dass er manuell oder automatisch in der Dienst-Microsoft Management Console (MMC) gestartet wird. Darüber hinaus ändern Sie den Telnet-Serverdienst so, dass er sich mithilfe des lokalen Systemkontos anmeldet, und Sie aktivieren nicht das Kontrollkästchen "Dienst für die Interaktion mit dem Desktop zulassen".

Wenn Sie versuchen, den Treiber in Geräte-Manager auf virtuellen Computern zu installieren, schlägt er fehl, und Sie erhalten die folgende Fehlermeldung:

Windows hat Treibersoftware für Ihr Gerät gefunden, aber beim Versuch, es zu installieren, ist ein Fehler aufgetreten.

Darüber hinaus wird ein Protokoll, das dem folgenden ähnelt, in der setupapi.dev.log Datei protokolliert, die sich im Ordner %windir%/inf befindet:

dvi: {Plug & Play Service: Geräteinstallation für PCI\VEN_15AD&DEV_07B0&SUBSYS_07B015AD&REV_01\FF565000B37984FE00}
ump: Erstellungsprozess: DrvInst.exe <DateTime>
ump: Serverinstallationsprozess wurde mit Code 0xc0000142 <DateTime beendet>
ump: {Plug & Play Dienst: Device Install exit(c0000142)}
ndv: Fehler bei der Geräteinstallation für ein neues Gerät... Installieren des NULL-Treibers.
dvi: {Plug & Play Service: Geräteinstallation für PCI\VEN_15AD&DEV_07B0&SUBSYS_07B015AD&REV_01\FF565000B37984FE00}

Ursache

Dieses Problem tritt aus Sicherheitsgründen auf. Der Telnet-Serverdienst nimmt einige Berechtigungsänderungen an der Fensterstation vor, in der er während der Initialisierung ausgeführt wird. Wenn Sie den Telnet Server-Dienst so konfigurieren, dass er mithilfe des lokalen Systemkontos ausgeführt wird, ohne mit dem Desktop interagieren zu können, wird er unter einer anderen Fensterstation gestartet. Dies kann Probleme für andere Prozesse verursachen, die auch unter dem lokalen Systemkonto ausgeführt werden und nicht mit dem Desktop interagieren. Ein solcher Prozess ist der Treiberinstallationsprozess, der bei der Installation eines neuen Gerätetreibers verwendet wird.

Problemumgehung

Um dieses Problem zu umgehen, ändern Sie den Telnet-Serverdienst nicht so, dass er unter dem lokalen Systemkonto ausgeführt wird. Es wird empfohlen, den Telnet Server-Dienst unter seinem standardmäßigen lokalen Dienstkonto auszuführen.

Wenn das Problem weiterhin nicht behoben wird, können Sie überprüfen, ob die neueste Version von VMWare-Tools installiert ist. Wenn Sie feststellen, dass Sie VMWare-Tools nicht aktualisieren oder deinstallieren können, führen Sie die folgenden Schritte aus:

  1. Rufen Sie die Setupdateien für die neueste Version von VMWare-Tools ab.

  2. Klicken Sie auf "Start", klicken Sie auf "Ausführen", geben Sie "cmd" ein, und klicken Sie dann auf "OK". Es wird ein Eingabeaufforderungsfenster geöffnet.

  3. Ändern Sie das Laufwerk auf das CD-ROM-Laufwerk, auf dem sich die VMware Tools-Setupdateien befinden (z. B. D:\).

  4. Geben Sie setup /c ein, und drücken Sie die EINGABETASTE, um das Entfernen aller Registrierungseinträge zu erzwingen und die alte Version von VMware Tools zu löschen.

    Notiz

    Geben Sie für 64-Bit-Gastbetriebssysteme setup64 /c ein.

  5. Alle früheren Versionen von VMware Tools sollten entfernt werden.

  6. Installieren Sie die neueste Version von VMware Tools, und führen Sie dann einen Neustart durch, nachdem Sie überprüft haben, ob die Einstellung für die Telnet Server-Dienstanmeldeeinstellung ordnungsgemäß festgelegt ist.

Datensammlung

Wenn Sie Unterstützung vom Microsoft-Support benötigen, empfehlen wir Ihnen, die Informationen zu sammeln, indem Sie die Schritte unter Sammeln von Informationen mithilfe von TSS für Bereitstellungsprobleme ausführen.

Informationen zum Haftungsausschluss von Drittanbietern

Die in diesem Artikel genannten Drittanbieterprodukte stammen von Herstellern, die von Microsoft unabhängig sind. Microsoft gewährt keine implizite oder sonstige Garantie in Bezug auf die Leistung oder Zuverlässigkeit dieser Produkte.