Die Windows-Suche ist in Windows Server 2016 standardmäßig deaktiviert.

Dieser Artikel enthält die Schritte zum erneuten Aktivieren der Windows-Suchdienst in Windows Server 2016.

Gilt für: Windows Server 2016
Ursprüngliche KB-Nummer: 3204979

Problembeschreibung

Wenn Sie versuchen, über das Startmenü oder über Cortana auf einem Windows Server 2016-basierten Computer zu suchen, erhalten Sie möglicherweise keine Ergebnisse oder inkonsistente Ergebnisse.

Ursache

Standardmäßig ist die Windows-Suchdienst in Windows Server 2016 auf "Deaktiviert" festgelegt. Der Grund dafür ist, dass die Indizierung der Volumes in bestimmten Szenarien Probleme verursachen kann, einschließlich:

  • Freigegebene Clustervolumes (CSV)
  • Ausführen von Remotedesktop-Sitzungshost (RDSH) mit mehreren gleichzeitigen Sitzungen.

Lösung

Sie können die Windows-Suchdienst in den folgenden Szenarien erneut aktivieren:

  • Sie planen, Windows Server 2016 als Clientdesktopcomputer zu verwenden.
  • Sie möchten die Windows-Suchfunktion über das Startmenü verwenden.

Führen Sie hierfür die folgenden Schritte aus:

  1. Drücken Sie die Windows-TASTE +R, um das Feld "Ausführen " zu öffnen.
  2. Geben Sie "services.msc" ein, und drücken Sie dann die EINGABETASTE.
  3. Klicken Sie mit der rechten Maustaste auf Windows Search, und wählen Sie dann "Eigenschaften" aus.
  4. Ändern Sie den Starttyp in "Automatisch" (verzögerter Start).
  5. Wählen Sie "Übernehmen" und dann " Start" aus.
  6. Wählen Sie "OK" aus, und schließen Sie dann die Dienstkonsole.