Freigeben über


Sie können Rollen und Features nicht anzeigen und fehlercode 0x800706BE in Server-Manager

Dieser Artikel enthält eine Lösung für das Problem, das Sie nicht in der Lage sind, Rollen und Features anzuzeigen und Fehlercode 0x800706BE in Server-Manager zu erhalten.

Ursprüngliche KB-Nummer: 2461206

Problembeschreibung

Stellen Sie sich folgendes Szenario vor:

  1. Sie verfügen über einen Computer, auf dem Windows Server 2008 oder Windows Server 2008 R2 ausgeführt wird.
  2. Sie öffnen das fenster Server-Manager, um Rollen und Features anzuzeigen/hinzuzufügen/zu entfernen.

In diesem Szenario werden Rollen und Features im fenster Server-Manager nicht mit einem gelben Knall gegen sie angezeigt. Wenn Sie versuchen, sie zu öffnen, wird unten in Server-Manager die folgende Fehlermeldung angezeigt:

Server-Manager
Unerwarteter Fehler beim Aktualisieren Server-Manager: Fehler beim Remoteprozeduraufruf. (Ausnahme von HRESULT: 0x800706BE)
Weitere Informationen finden Sie im Ereignisprotokoll: Diagnose, Ereignisanzeige, Anwendungs- und Dienstprotokolle, Microsoft, Windows, Server-Manager, Operational.)

Gleichzeitig wird das folgende Ereignis dem Microsoft-Windows-ServerManager/Operational-Protokoll hinzugefügt:

Protokollname: Microsoft-Windows-ServerManager/Operational
Quelle: Microsoft-Windows-ServerManager
Datum: <Datum und Uhrzeit>
Ereignis-ID: 1601
Aufgabenkategorie: Keine
Ebene: Fehler
Schlüsselwörter:
Benutzer: <Benutzername>
Computer: <Computername>
Beschreibung:
Der Status des Systems konnte nicht ermittelt werden. Es wurde eine unerwartete Ausnahme gefunden:
System.Runtime.InteropServices.COMException (0x800706BE): Fehler beim Remoteprozeduraufruf. (Ausnahme von HRESULT: 0x800706BE)
at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
at Microsoft.Windows.ServerManager.ComponentInstaller.CreateSessionAndPackage(IntPtr& session, IntPtr& package)
at Microsoft.Windows.ServerManager.ComponentInstaller.InitializeUpdateInfo()
at Microsoft.Windows.ServerManager.ComponentInstaller.Initialize()
at Microsoft.Windows.ServerManager.Common.Provider.RefreshDiscovery()
at Microsoft.Windows.ServerManager.LocalResult.PerformDiscovery()
at Microsoft.Windows.ServerManager.ServerManagerModel.CreateLocalResult(RefreshType refreshType)
at Microsoft.Windows.ServerManager.ServerManagerModel.InternalRefreshModelResult(Object state)

Ursache

Einige Katalogdateien, Manifestdateien oder MUM-Dateien sind auf dem Computer beschädigt.

Lösung

Hier sind die Schritte zum Beheben des Problems:

  1. Rufen Sie das Microsoft Update Readiness Tool vom Speicherort ab: https://support.microsoft.com/kb/947821.

  2. Führen Sie das Microsoft Update Readiness Tool auf dem problematischen Computer aus.

  3. Sie öffnen die Datei "%Systemroot%\Windows\logs\CBS\Checksur.log", nachdem die Überprüfung abgeschlossen wurde.

  4. Sie überprüfen beschädigte Informationen in den Dateien. Hier sind einige Beispiele:

    (f) CBS MUM Corrupt 0x00000000 servicing\Packages\Package_for_KB978601~31bf3856ad364e35~amd64~~6.0.1.0.mum Dateiname Package_for_KB978601_server~31bf3856ad364e35~amd64~~6.0.1.0.mum stimmt nicht mit dem tatsächlichen Dateinamen überein.
    (f) CBS MUM Corrupt 0x00000000 servicing\Packages\Package_for_KB979309~31bf3856ad364e35~amd64~~6.0.1.0.mum Dateiname Package_for_KB979309_server~31bf3856ad364e35~amd64~~6.0.1.0.mum stimmt nicht mit dem tatsächlichen Dateinamen überein.

    Oder

    (f) CBS MUM Corrupt 0x800B0100 servicing\Packages\Package_for_KB978601~31bf3856ad364e35~amd64~~6.0.1.0.mum servicing\Packages\Package_for_KB978601~31bf3856ad364e35~amd64~~6.0.1.0.cat Package manifest kann nicht durch den entsprechenden Katalog überprüft werden (f) CBS MUM Corrupt 0x800B0100 servicing\Packages\Package_for_KB979309~31bf3856ad364e35~amd64~~6.0.1.0.mum servicing\Packages\Package_for_KB979309~31bf3856ad364e35~amd64~~6.0.1.0.cat Package manifest kann nicht durch das Manifest des Pakets überprüft werden. entsprechender Katalog

    Oder

    (f) CBS MUM Fehlt 0x00000002 Servicing\packages\Package_114_for_KB955839~31bf3856ad364e35~amd64~~6.0.1.0.mum (f) CBS MUM Fehlt 0x00000002 Servicing\packages\Package_83_for_KB955839~31bf3856ad364e35~amd64~~6.0.1.0.mum

    Weiter unten sehen Sie:

    Nicht verfügbare Reparaturdateien:
    servicing\packages\Package_for_KB978601~31bf3856ad364e35~amd64~~6.0.1.0.mum
    servicing\packages\Package_for_KB979309~31bf3856ad364e35~amd64~~6.0.1.0.mum
    servicing\packages\Package_for_KB978601~31bf3856ad364e35~amd64~~6.0.1.0.cat
    servicing\packages\Package_for_KB979309~31bf3856ad364e35~amd64~~6.0.1.0.cat

Kopieren Sie diese Dateien in: %systemroot\Windows\Servicing\Packages.

  1. Sie müssen zuerst die Kontrolle über diesen Ordner erlangen. Verwenden Sie hierzu die folgenden Befehle:

    takeown /F c:\Windows\Servicing\Packages /D y /R
    
  2. Weisen Sie nun den vollzugriff mit dem folgenden Befehl zu. Sie erhalten die vollständige Kontrolle über das Verzeichnis:

    cacls c:\Windows\Servicing\Packages /E /T /C /G "UserName": F
    
  3. Jetzt müssen Sie die fehlenden oder beschädigten Dateien aus dem checksur Protokoll sammeln: Laden Sie die KB-Dateien für die fehlenden Dateien herunter.

    servicing\packages\Package_for_ KB978601 ~31bf3856ad364e35~amd64~~6.0.1.0.mum

  4. Entpacken Sie sie mit dem folgenden Befehl:

    Expand -F:\* UpdateKBXXXX.msu x:\DestinationDirectory
    
  5. Nach dem Erweitern wird eine UpdateKBXXXX.cab Datei angezeigt. Erweitern Sie sie auch:

    Expand -F:\* UpdateKBXXXX.CAB x:\DestinationDirectoryCAB
    

    Innerhalb dieser Cab müssen Sie zwei Dateien abrufen: update.mum und update.cat.

  6. Benennen Sie die gesammelten Dateien "update.mum" und update.cab genau so um, wie sie sich im checksur.log befinden:

    Ex.: update.mum für KB978601 wird Package_for_ KB978601 ~31bf3856ad364e35~amd64~~6.0.1.0.mum
    Führen Sie den gleichen Vorgang für alle anderen fehlenden/beschädigten Dateien aus, und platzieren Sie sie in das verzeichnis, das in checksur.log (/servicing/packages) angegeben ist.

Nach diesen Schritten sollte das Problem behoben werden, kein Neustart erforderlich.

Notiz

Wenn Server-Manager auch nach diesen Schritten nicht funktioniert, führen Sie das Update Readiness Tool erneut aus, und überprüfen Sie die oben beschriebenen Schritte.