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Für einige Computer ist möglicherweise ein BIOS-Update erforderlich, um die Hyper-V-Rolle zu installieren und/oder virtuelle Hyper-V-Computer zu starten.

Dieser Artikel enthält Hilfe zum Beheben von Problemen, die auftreten, wenn Sie die Hyper-V-Rolle installieren oder virtuelle Hyper-V-Computer starten.

Ursprüngliche KB-Nummer: 2762297

Symptome

Verschiedene Symptome und Fehler:

Problem 1:

Auf einem Computer mit Windows Server 2012 oder Windows 8 mit installierter Hyper-V-Rolle oder nach dem Upgrade von einer früheren Version von Windows mit der bereits installierten Hyper-V-Rolle erhalten Sie möglicherweise die folgende Fehlermeldung beim Starten eines virtuellen Computers:

Der virtuelle Computer "VM_Name" konnte nicht gestartet werden, da der Hypervisor nicht ausgeführt wird (VM-ID <Virtual_Machine_ID>). Die folgenden Aktionen können Ihnen dabei helfen, das Problem zu beheben:

  1. Stellen Sie sicher, dass der Prozessor des physischen Computers über eine unterstützte Version der hardwaregestützten Virtualisierung verfügt.
  2. Stellen Sie sicher, dass hardwaregestützte Virtualisierung und hardwaregestützter Datenausführungsschutz im BIOS des physischen Computers aktiviert sind. (Wenn Sie das BIOS bearbeiten, um eine der beiden Einstellungen zu aktivieren, müssen Sie die Stromversorgung auf dem physischen Computer deaktivieren und dann wieder aktivieren. Das Zurücksetzen des physischen Computers reicht nicht aus.)
  3. Wenn Sie Änderungen am Datenspeicher für die Startkonfiguration vorgenommen haben, überprüfen Sie diese Änderungen, um sicherzustellen, dass der Hypervisor für den automatischen Start konfiguriert ist.

Problem 2:

Ein Computer mit Windows Server 2012 oder Windows 8, der versucht, die Hyper-V-Rolle zu aktivieren, erhalten Sie möglicherweise eine der folgenden Fehlermeldungen:

  1. Hyper-V kann nicht installiert werden, da die Virtualisierungsunterstützung im BIOS nicht aktiviert ist.
  2. Hyper-V kann nicht installiert werden: Die Datenausführungsverhinderung ist nicht aktiviert.
  3. Überprüfen, ob das BIOS des Computers Virtualisierungsunterstützung hat und Der Datenschutz für die Datenausführung aktiviert ist.

Problem 3

Wenn Sie versuchen, die SR-IOV-Unterstützung unter Windows Server 2012 mit der installierten Hyper-V zu aktivieren, erhalten Sie möglicherweise die folgenden Fehlermeldungen von der IovSupportReasons-Eigenschaft, wenn Sie den folgenden PowerShell-Befehl ausführen:

Get-VMHost | Format-List IovSupport, IovSupportReasons  
  • SR-IOV kann auf diesem Computer nicht verwendet werden, da der Prozessor keine Adressübersetzung der zweiten Ebene (SLAT) unterstützt. Bei Intel-Prozessoren kann dieses Feature als erweiterte Seitentabellen (Extended Page Tables, EPT) bezeichnet werden. Bei AMD-Prozessoren kann dieses Feature als Rapid Virtualization Indexing (RVI) oder geschachtelte Seitentabellen (NPT) bezeichnet werden.
  • Der Chipsatz auf dem System unterbricht die Neuzuordnung nicht, ohne die SR-IOV nicht unterstützt werden kann.
  • Der Chipsatz auf dem System führt keine DMA-Neuzuordnung durch, ohne die SR-IOV nicht unterstützt werden kann.
  • SR-IOV kann auf diesem System nicht verwendet werden, da es so konfiguriert wurde, dass die Verwendung von E/A-Neuzuordnungshardware deaktiviert wird.
  • Stellen Sie sicher, dass das System über Chipsatzunterstützung für SR-IOV verfügt und dass die E/A-Virtualisierung im BIOS aktiviert ist.
  • Um SR-IOV auf diesem Computer zu verwenden, muss das BIOS aktualisiert werden, da es falsche Informationen zur Beschreibung der Hardwarefunktionen enthält. Wenden Sie sich an ihren Computerhersteller, um ein Update zu erhalten.
  • SR-IOV kann nicht auf diesem System verwendet werden, da es berichtet, dass kein PCI Express Bus vorhanden ist. Wenden Sie sich an Ihren Systemhersteller, um weitere Informationen zu erfahren.
  • Um SR-IOV auf diesem System zu verwenden, muss das System-BIOS aktualisiert werden, damit Windows PCI Express steuern kann. Wenden Sie sich an den Systemhersteller, um ein Update zu erhalten.
  • SR-IOV kann auf diesem System nicht verwendet werden, da die PCI Express-Hardware access Control Services (ACS) an keinem Stammport unterstützt. Wenden Sie sich an Ihren Systemanbieter, um weitere Informationen zu erfahren.

Ursache

Verschiedene Ursachen im Zusammenhang mit Problemen, die im Abschnitt "Symptome" erwähnt werden.

Ursache für Problem 1

Dieser Fehler tritt auf, da die im BIOS verfügbare SMX-Funktion (Secure Mode Extensions) aktiviert ist und eine Änderung in der Ausführungsumgebung vorliegt. Dies bewirkt, dass der Hypervisor nicht geladen wird.

Ursache für Problem 2

Dieser Fehler kann auftreten, wenn das BIOS meldet, dass virtualisierungsunterstützung oder Data Execution Protection nicht aktiviert ist, obwohl er im BIOS-Konfigurationsmenü aktiviert ist.

Ursache für Problem 3

Diese Fehler können aus folgenden Gründen verursacht werden:

  • Ein veraltetes BIOS
  • Falsche BIOS-Einstellung
  • Inkompatible Hardware

Lösung

Informationen zum Beheben von Problemen, die im Abschnitt "Symptome" erwähnt werden, finden Sie im entsprechenden Abschnitt unten:

Lösung für Problem 1

Wenden Sie sich an die Hardwarehersteller, um nach einem BIOS-/Firmwareupdate zu suchen und das SMX-Feature (Secure Mode Extensions) aus dem BIOS zu deaktivieren.

Lösung für Problem 2

Wenden Sie sich an die Hardwarehersteller, um nach einem BIOS-/Firmwareupdate zu suchen.

Lösung für Problem 3

  1. Vergewissern Sie sich bei Ihrem Hardwarehersteller, dass das System die erforderliche Chipsatzunterstützung enthält und für die SR-IOV-Funktion über die Firmware unterstützt wird.
  2. Stellen Sie sicher, dass das System mit der neuesten Firmwareversion aktualisiert wird, die SR-IOV-Unterstützung enthält.
  3. Es kann erforderlich sein, die Firmwareeinstellungen zu ändern, um VT-d (auf Intel-Plattformen) oder AMD-Vi (auf AMD-Plattformen) zu aktivieren. Dies kann auf verschiedene Arten bezeichnet werden, darunter "IOMMU", "IO/MMU", "I/O Virtualization" oder "SR-IOV-Unterstützung". Die Benennung der Firmwareeinstellungen ist herstellerspezifisch.
  4. Einige Systeme verfügen möglicherweise über Einstellungen an zwei verschiedenen Stellen in der Firmware, die eine Konfiguration erfordern. Sie sollten sich in der Dokumentation Ihrer Hardwarehersteller für die spezifischen Einstellungen und die NIC-Hardware informieren, die sie für SR-IOV-Netzwerke unterstützen.
  5. Nach dem Ändern der BIOS-/Firmwareeinstellungen kann es erforderlich sein, das System kalt neu zu starten.

Weitere Informationen zu SR-IOV finden Sie in den Versionshinweisen zu Windows Server 2012 für Hyper-V.
Versionshinweise: Wichtige Probleme in Windows Server 2012