Share via


Codeausschnitte und deren Verwendung

Codeschnipsel sind kleine Blöcke von wiederverwendbarem Code, den Sie einer Codedatei hinzufügen können. Codeschnipsel enthalten normallerweise häufig verwendete Codeblöcke wie z. B. Try...Finally- oder If...Else-Blöcke. Sie können Code auch verwenden, um ganze Klassen oder Methoden hinzuzufügen.

Ein Codeausschnitt hat einen Titel, den Sie zum Auswählen des Codeausschnitts verwenden, und kann einen Verknüpfungsnamen haben, den Sie eingeben können, um den Codeausschnitt einzufügen. Codeschnipsel können auch Ersatzparameter enthalten, die als Platzhalter dienen. Codeschnipsel sind für viele Sprachen verfügbar, darunter C#, C++ und Visual Basic.

Erweiterungsausschnitte und umschließende Ausschnitte

Sie können zwei Arten von Codeschnipseln zu Ihrem Code hinzufügen.

  • An einer angegebenen Einfügemarke wird ein Erweiterungsausschnitt hinzugefügt.
  • Ein Umgeben–mit-Codeausschnitt wird um den ausgewählten Code herum hinzugefügt und ist nur für C# und C++ verfügbar.

Suchen nach verfügbaren Codeschnipseln

Um verfügbare Codeschnipsel für eine Sprache anzuzeigen, wählen Sie in der Menüleiste Tools>Codeschnipsel-Manager (oder drücken Sie Ctrl+K, B) und dann die gewünschte Sprache aus dem Dropdownmenü.

Screenshot: Dialogfeld für den Codeschnipsel-Manager

Informationen zum Erstellen und Importieren ihres eigenen Codeausschnitts, damit er in der Codeausschnittliste angezeigt wird, finden Sie unter Exemplarische Vorgehhensweise: Erstellen eines Codeausschnitts in Visual Studio.

Hinzufügen eines Codeschnipsels zu einer Codedatei

So fügen Sein einen Codeschnipsels zur Codedatei hinzu:

  1. Platzieren Sie im Code-Editor den Cursor, oder wählen Sie C#- oder C++-Code aus, in dem Sie den Codeausschnitt hinzufügen möchten.

  2. Führen Sie eine der folgenden Aktionen aus:

    • Wählen Sie auf der Menüleiste von Visual Studio Bearbeiten>IntelliSense>Codeausschnitt einfügen oder Bearbeiten>IntelliSense>Umgeben mit aus.
    • Klicken Sie mit der rechten Maustaste, und wählen Sie Snippet>Codeausschnitt einfügen oder Codeausschnitt>Umgeben mit aus dem Kontextmenü aus.
    • Drücken Sie auf der Tastatur STRG+K, X für einen Erweiterungsausschnitt oder STRG+K, S für einen Umbruchausschnitt.
  3. Doppelklicken Sie auf den gewünschten Codeausschnitt in der Dropdownliste, oder geben Sie die Codeausschnittverknüpfung ein, und drücken Sie die TAB- oder EINGABETASTE.

Hinzufügen eines Erweiterungsausschnitts

Der C#-Erweiterungsausschnitt tryf fügt beispielsweise den folgenden Try...Finally-Block hinzu:

try
{

}
finally
{

}

So fügen Sie diesen Erweiterungscodeschnipsel hinzu

  1. Positionieren Sie den Cursor im Code-Editor an der Stelle, an der Sie den Codeschnipsel hinzufügen möchten.
  2. Klicken Sie mit der rechten Maustaste, und wählen Sie Codeausschnitt einfügen aus dem Kontextmenü aus, oder verwenden Sie die Menüleiste oder Tastaturbefehle.
  3. Öffnen Sie den Visual C#-Ordner, und doppelklicken Sie dann in der Dropdownliste auf tryf, oder wählen Sie tryf aus, und drücken Sie die TAB- oder EINGABETASTE.

Tipp

Sie können den Cursor auch an der Einfügemarke platzieren, tryf eingeben und dann zweimal die TAB-TASTE drücken.

Fügen Sie einen Umschließungsausschnitt ein

Im folgenden Beispiel für einen Codeschnipsel C++ kann die Verknüpfung if als Einfügungs- oder Umschließungsschnipsel verwendet werden. Wenn Sie die Codezeile return FALSE; auswählen und dann Umschließen mit>wenn, wird der Ausschnitt um folgende Zeile erweitert.

if (true)
{
    return FALSE;
}

Ersatzparameter für Ausschnitte

Codeschnipsel können Ersatzparameter enthalten, die Platzhalter sind und ersetzt werden müssen, um den Code anzupassen, den Sie schreiben. Im vorherigen Beispiel ist true ein Ersatzparameter, den Sie durch die entsprechende Bedingung ersetzen. Diese Ersetzung wiederholt sich für jede Instanz des Ersatzparameters im Ausschnitt.

In Visual Basic hat z.B. einen Codeausschnitt, der eine Eigenschaft definiert. So fügen Sie das Codeschnipsel ein:

  1. Wählen Sie im Kontextmenü in einer Visual Basic-Codedatei Codeschnipsel>Codeschnipsel einfügen aus.
  2. Wählen Sie Codemuster>Eigenschaften, Prozeduren, Ereignisse>Eigenschaft definieren aus.

Screenshot: Menü „Codeschnipsel“ für „Eigenschaft definieren“

Der folgende Code wird eingefügt:

Private newPropertyValue As String
Public Property NewProperty() As String
    Get
        Return newPropertyValue
    End Get
    Set(ByVal value As String)
        newPropertyValue = value
    End Set
End Property

Wenn Sie newPropertyValue in m_property ändern, ändert sich jede Instanz von newPropertyValue. Wenn Sie String in der Eigenschaftendeklaration in Int ändern, wird der Wert in der Set-Methode ebenfalls in Int geändert.

Bewährte Methoden für die Verwendung von Codeausschnitten

Der Code in einem Codeausschnitt zeigt nur die grundlegende Methode, etwas zu tun. Für die meisten Anwendungen muss der Code geändert werden, um der Anwendung zu entsprechen.

Ausnahmebehandlung

In der Regel blockiert Codeausschnitte Try...Catch alle Ausnahmen, aber dies ist möglicherweise nicht die richtige Wahl für Ihr Projekt. Bei jeder Ausnahme gibt es mehrere Reaktionsmöglichkeiten. Beispiele finden Sie unter Vorgehensweise: Behandeln einer Ausnahme mit try/catch (C#) und Try...Catch...Finally Statement (Visual Basic) (Try...Catch...Finally-Anweisung (Visual Basic)).

Dateispeicherorte

Wenn Sie Dateispeicherorte an Ihre Anwendung anpassen, sollten Sie die folgenden Faktoren berücksichtigen.

  • Suchen eines verfügbaren Speicherorts. Benutzer haben möglicherweise keinen Zugriff auf den Ordner Programme des Computers. Daher kann das Speichern von Benutzerdateien mit den Anwendungsdateien eventuell nicht funktionieren.

  • Suchen eines sicheren Speicherorts. Das Speichern von Dateien im Stammordner wie C:\ ist nicht sicher. Für Anwendungsdaten ist es am besten, den Ordner Anwendungsdaten zu verwenden. Für die Daten einzelner Benutzer kann die Anwendung im Ordner Dokumente eines jeden Benutzer eine Datei erstellen.

  • Verwenden Sie einen gültigen Dateinamen. Sie können die Steuerelemente OpenFileDialog und SaveFileDialog verwenden, um die Wahrscheinlichkeit ungültiger Dateinamen zu reduzieren.

  • Beachten Sie, dass eine vom Benutzer ausgewählte Datei gelöscht werden kann, bevor Ihr Code die Datei bearbeiten kann. Außerdem verfügt ein Benutzer möglicherweise nicht über die Berechtigung zum Schreiben in die Datei.

Sicherheit

Die Sicherheit eines Ausschnitts hängt davon ab, wo Sie ihn im Quellcode verwenden und wie Sie ihn ändern, nachdem er in den Code eingefügt wurde. Die folgende Liste enthält einige der zu berücksichtigenden Bereiche.

  • Zugriff auf Dateien und Datenbanken
  • Codezugriffssicherheit
  • Schützen von Ressourcen wie z. B. Ereignisprotokolle und Registrierung
  • Speichern von Geheimnissen
  • Überprüfen von Eingaben
  • Übergeben von Daten an Skriptingtechnologien

Weitere Informationen finden Sie unter Sichern von Anwendungen.

Heruntergeladene Codeausschnitte

Codeschnipsel, die von Visual Studio installiert werden, sind selbst kein Sicherheitsrisiken. Allerdings können sie Sicherheitsrisiken in Ihrer Anwendung erstellen. Aus dem Internet heruntergeladene Ausschnitte sollten mit größter Vorsicht wie jeglicher anderer heruntergeladener Inhalt behandelt werden. Laden Sie Ausschnitte nur von vertrauenswürdigen Sites herunter, und verwenden Sie Antivirensoftware, die auf dem neuesten Stand ist.

Öffnen Sie alle heruntergeladenen Ausschnittdateien im Editor oder XML-Editor von Visual Studio, und überprüfen Sie sie vor der Installation sorgfältig. Achten Sie auf die folgenden Probleme:

  • Code eines Ausschnitts, der bei der Ausführung das System beschädigen kann. Lesen Sie den Quellcode sorgfältig, bevor Sie ihn ausführen.

  • HelpURL-Blöcke in Codeausschnittdateien, die URLs enthalten, die schädliche Skriptdateien ausführen oder anstößige Websites anzeigen.

  • Codeausschnitt mit Verweisen, die automatisch dem Projekt hinzugefügt werden und von überall auf Ihr System geladen werden können. Sie können diese Verweise von demselben Speicherort herunterladen, von dem Sie einen Codeausschnitt herunterladen. Der Ausschnitt kann dann eine Methode im Verweis aufrufen, die bösartigen Code ausführt. Um solche Verweise zu erkennen, überprüfen Sie die Blöcke Imports und References der Codeausschnittdatei.