PreviewLogoVisual Studio 2022 Version 17.4 Preview 2 Versionshinweise


Tipp

Sehen Sie sich die Aufzeichnungen der Visual Studio 2022-Einführungsveranstaltung an, um mehr über die neuen Funktionen zu erfahren, Tipps und Tricks zu erhalten und kostenloses digitales Zubehör herunterzuladen.

| Entwicklercommunity Visual Studio 2022 Roadmap | Systemanforderungen | Kompatibilitätskompatibilität Verteilerbare | CodeVersionsverlauf | | Lizenzbedingungen | Blogs | Neueste Bekannte Probleme | Whats New in Visual Studio Docs


Klicken Sie auf eine Schaltfläche, um die aktuelle Version von Visual Studio 2022 herunterzuladen. Anweisungen zum Installieren und Aktualisieren von Visual Studio 2022 finden Sie unter Aktualisieren von Visual Studio 2022 auf das aktuelle Release. Sehen Sie sich auch die Anweisungen zur Offlineinstallation an.

Schaltfläche Herunterladen Professional ButtonHerunterladen Enterprise"

Besuchen Sie die Visual Studio-Website , um andere Visual Studio 2022-Produkte herunterzuladen.

Wichtig

Der Vorschaukanal befindet sich nicht in der endgültigen Phase und ist nicht für die Verwendung auf Produktionscomputern oder zur Erstellung von Produktionscode vorgesehen. Weitere Informationen finden Sie unter Projektlebenszyklus und Wartung in Visual Studio.

Schaltfläche Herunterladen Professional PreviewEnterprise Preview herunterladen


Visual Studio 2022 Version 17.4 Vorschauversionen

Supportzeitrahmen

Visual Studio 2022, Version 17.4, wird der nächste langfristige Wartungskanal sein, nachdem er veröffentlicht wurde. Enterprise- und Professional-Benutzer, die für den Empfang von Updates auf dem 17.4 LTSC-Kanal konfiguriert sind, werden unterstützt und erhalten Korrekturen für Sicherheitsrisiken bis Juli 2024. Weitere Informationen zu den unterstützten Visual Studio-Baselines finden Sie in der Supportrichtlinie für Visual Studio 2022.

Visual Studio 2022-Blog

Im Visual Studio 2022-Blog finden Sie alle wichtigen Informationen zu Produkten direkt vom Visual Studio-Engineeringteam. In den folgenden Beiträgen finden Sie ausführliche Informationen zu den Visual Studio 2022-Releases:

Wir haben eine Reihe Ihrer top gemeldeten Fehler in dieser Version behoben und neue Features basierend auf Ihren Vorschlägen in Entwicklercommunity hinzugefügt. Vielen Dank für Ihr fortgesetztes Feedback. Hier ist eine Liste Ihres Vorschlags, den wir als Teil dieser Vorschau versenden.


17.4.0-pre.2.0 Visual Studio 2022, Version 17.4 Preview 2

veröffentlicht am 14. September 2022

Zusammenfassung der Neuerungen in dieser Version von Visual Studio 2022, Version 17.4 Preview 2

Aktualisierungen über Microsoft Endpoint Manager

Visual Studio-Sicherheitsupdates werden für moderne in der Cloud verbundene Azure Active Directory (AAD)-Geräte verfügbar, die Windows Update for Business verwenden und von Mobilen Geräteverwaltungslösungen wie Microsoft Endpoint Manager (früher als Intune bezeichnet) verwaltet werden. Sie können diese Funktionalität jetzt auf Ihren Clientgeräten anzeigen, indem Sie einen Vorschaurichtlinienschlüssel festlegen. Weitere Details und Anweisungen zum Konfigurieren Ihrer Geräte finden Sie im Blogbeitrag 17.4 Preview 2 , damit ihnen die Sicherheitsupdates zur Verfügung stehen, und geben Sie hier Feedback.

Microsoft Teams Development Tools (Teams Toolkit)

  • Die microsoft Teams Tab-App-Vorlage, die von Teams Toolkit bereitgestellt wird, besteht darin, die Authentifizierung mithilfe der Teams-Identität in früherer Version zu aktivieren. Jetzt können Sie auswählen, ob Die Authentifizierung für einmaliges Anmelden für Ihre Teams-App zum Zeitpunkt der Erstellung der Teams-App einbezogen werden soll.
  • Wenn Sie sich entschieden haben, die Einmalige Anmeldung für Ihre Teams-App nicht einzubeziehen, können Sie es jetzt später während der Entwicklung hinzufügen. Die Option ist im Menü Project > Teams Toolkit > Code hinzufügen verfügbar.
  • Nachdem Sie Ihrem Projekt Authentifizierungscode hinzugefügt haben, fordert das Teams Toolkit Anleitungen zur Verwendung auf. Bitte lesen Sie sorgfältig die Anleitungen.
  • Für Projekte, die mit früherer Version des Teams Toolkits erstellt wurden, aktualisiert Teams Toolkit Ihr Projekt automatisch, um in verspäteter Version ausgeführt zu werden.
  • Das Teams-Toolkit löst die automatische Aktualisierung des Projekts aus, wenn Sie eine beliebige Option in Teams Toolkit auslösen, z. B. Vorbereiten von Teams-App-Abhängigkeiten oder Debug usw.
  • Das Projektupdate enthält das Hinzufügen neuer Dateien (Azure AAD-Vorlagendatei) zu Ihrem Projekt, das Hinzufügen von Konfigurationen in Ihrer ProjectSettings-Datei und manifestdatei. Ausführliche Informationen finden Sie in den Ausgabeprotokollen beim Aktualisieren.
  • Weitere Informationen zum Teams Toolkit finden Sie unter https://aka.ms/teams-toolkit-vs-docs

F#

C++

  • Wir haben Visual Studio für vcpkg-Artefakte mit CMake-Projekten unterstützt. Bei Projekten, die ein vcpkg-Manifest enthalten, wird die Umgebung automatisch aktiviert, wenn das Projekt geöffnet wird. Weitere Informationen hierzu finden Sie in der vcpkg-Umgebungsaktivierung im Visual Studio-Blogbeitrag.
  • Sie können jetzt Dev Containers für Ihre C++-Projekte verwenden. Weitere Informationen zu diesem Feature finden Sie in unserem Blogbeitrag "Dev Containers for C++".
  • IntelliSense respektiert die Reihenfolge von vordefinierten Headern, wenn es sich um einen PCH handelt. Früher, als ein PCH über /Yu und force-included via /FIverwendet wurde, verarbeitet IntelliSense es immer zuerst, bevor alle anderen Header über ./FI Dies entspricht nicht dem Buildverhalten, sodass diese Änderungsheader /FI in der angegebenen Reihenfolge verarbeitet werden.
  • Interne Präfixe aus CTest-Namen im Test-Explorer entfernt.
  • Die Mit Visual Studio ausgelieferte Version von CMake wurde auf Version 3.24.1 aktualisiert. Weitere Informationen finden Sie in den CMake-Versionshinweisen .
  • Android SDK-Update
    • Ant-Skripts wurden entfernt, sodass Benutzer im Dialogfeld "Neues Projekt" keine antbasierten Vorlagen mehr sehen. Hilfe beim Migrieren von Ant-Vorlagen zu Gradle-Vorlagen finden Sie unter: Migrieren von Builds von Apache Ant (gradle.org)
    • Unterstützung für das Erstellen mit NDK 23 und 24 hinzugefügt
    • Aktualisierte NDK-Komponente auf die LTS Version 23
  • Vektorisierte Implementierungen von ranges::min_element(), ranges::max_element()und ranges::minmax_element()
  • Wir verfolgen weiterhin die neuesten Entwicklungen in der C++-Standardisierung, die Unterstützung für die folgenden C++ 23-Features ist verfügbar, indem wir /std:c++neueste in Ihren Compileroptionen einschließen.
    • P2302ranges::contains, ranges::contains_subrange
    • P2499string_view Bereichskonstruktor sollte sein explicit

Audiohinweise

  • Wir haben in dieser Vorschau zwei zusätzliche Audiohinweise hinzugefügt. Um die Audiohinweise zu aktivieren, wechseln Sie zu "Tools > Verwalten von Vorschaufeatures", und aktivieren Sie dann die Option "Audiohinweise für den Editor aktivieren".
  • Die beiden neuen Audiohinweise werden wiedergegeben, wenn der Caret auf einer Zeile eingeht, die beim Anzeigen einer Datei in der Diff Viewer hinzugefügt oder gelöscht wurde. Diese Audiohinweise werden dem Fehler, haltepunkt und Warnungsaudiohinweisen hinzugefügt, die in 17.3 hinzugefügt wurden.

Markdown

  • Wir haben eine sehr frühe Vorschau unseres Markdown-Editors für Visual Studio hinzugefügt. Um den Markdown-Editor zu aktivieren, wechseln Sie zu "Tools > Verwalten von Vorschaufeatures", und aktivieren Sie dann die Option "Markdown-Sprachdienst".
  • Sobald das Feature aktiviert ist, wird beim Öffnen einer BELIEBIGEN MD-Datei der neue Markdown-Editor in Visual Studio geöffnet. Um die Vorschau für den Markdown zu öffnen, gibt es unten rechts im Editor eine Vorschauschaltfläche (neben den Informationen zu Zeile und Spalte).
  • Diese Erfahrung ist eine sehr frühe Vorschau, und wir erwarten eine große Änderung. Wenn Sie Feedback zu der Erfahrung haben, treten Sie bitte hier zu Entwicklercommunity an der Unterhaltung teil.

.NET-Produktivität

  • Es gibt eine neue Inlineumbenennungsbenutzeroberfläche, mit der Sie einen Typ umbenennen können. Drücken Sie STRG+R,R, um die neue Inlineumbenennungsoberfläche anzuzeigen. Beachten Sie, dass die neue Benutzeroberfläche nun unter dem Typ mit einer Option zum Umbenennen von Kommentaren, Zeichenfolgen und Symboldateien angezeigt wird.

Inline-Umbenennung

  • Es gibt jetzt eine Option zum Deaktivieren Source Link und eingebetteten Quelle. Sie können dies unter "Extras > Options Text Editor > C# Advanced" > deaktivieren und die Option "Navigation aktivieren" für Source Link und eingebettete > Quellen deaktivieren.

Deaktivieren von Source Link und eingebetteten Quellen

Debuggen und Diagnose

  • Für die DataTable-Schnellansicht wurde ein Upgrade mit neuen Verbesserungen wie Filtern, Sortieren, Exportieren und Design durchgeführt.
  • Um den Datenexport im CSV/Excel-Format zu exportieren, verwenden Sie die Dropdownliste in der oberen rechten Ecke.
  • Mit dem Visualizer können Sie auch datenbasierte gewünschte Filterzeichenfolge filtern. Es gibt alle Zeilen zurück, die einen Wert enthalten, der der Filterzeichenfolge entspricht. Sie können die gefilterten und sortierten Ergebnisse auch im CSV/Excel-Format exportieren.
  • Das Visual Studio-Fenster wird entsprechend dem ausgewählten Visual Studio-Design versehen.

DataTable-Visualisierung


17.4.0-pre.1.0 Visual Studio 2022, Version 17.4 Preview 1

veröffentlicht am 9. August 2022

Zusammenfassung der Neuerungen in dieser Version von Visual Studio 2022, Version 17.4 Preview 1

Installation und Updates

Das Visual Studio-Installationsprogramm, das in dieser Visual Studio 2022-Version 17.4 Preview 1 debütiert, enthält zwei neue Features: Rollback- und Entfernen von Out-of-Support-Komponenten

Das erste Feature, das im Visual Studio-Installationsprogramm enthalten ist, ist Rollback – die Möglichkeit, zur zuvor installierten Version von Visual Studio zurückzukehren.  

Was passiert?

Das Rollback gibt Visual Studio vor dem letzten angewendeten Update an die version zurück, die installiert wurde. Sie behält alle Änderungen an ausgewählten Komponenten bei, die seit dieser letzten Aktualisierung ausgewählt wurden. Lokale Anpassungen, z. B. Ihre Benutzereinstellungen und Profile, werden entfernt. Ihre gängigen synchronisierten Einstellungen wie Designs, Schriftarten, Tastenbindungen und Das Fensterlayout werden jedoch wiederhergestellt.

Ab sofort können Sie komponenten rollbacken, die mit der VS-Instanz und freigegebenen Komponenten wie SDKs und Tools enthalten sind, die nur von VS verwaltet und verwaltet werden. Pro Computererweiterungen, systemweite Komponenten und Tools, die von Visual Studio nicht verwaltet werden, verbleiben in ihren aktuellen Versionen. Pro Benutzer werden jedoch Erweiterungen deinstalliert. Weitere Informationen finden Sie im Abschnitt "Komponenten, die kompatibel sind". 

Was geschieht mit meinen Sicherheitsupdates?

Sicherheitsupdates, die in einer Version enthalten sind, die größer als die Version ist, auf die Sie zurückgesetzt haben, werden entfernt, wodurch Ihr Gerät anfällig ist. Es wird empfohlen, bald wieder auf die neueste Version zu aktualisieren, um sicher zu bleiben.  

Welche Versionen unterstützen rollback?

Sie können das Rollback-Feature mithilfe der neuesten Visual Studio 2022 Preview-Version (17.4 P1) testen.  

Komponenten, die kompatibel sind  

In der folgenden Tabelle wird der Typ der Komponenten beschrieben, die mit dem Rollbackfeature unterstützt werden. Als allgemeine Faustregel werden Komponenten, die VS installiert, installiert und verwendet werden, im Rollbackversuch enthalten.  

RollbackComp

Kann ich rollback, wenn ich in einer verwalteten Umgebung bin?

Aufgrund Ihrer Organisationsrichtlinien und der Anforderung, sich auf der sichersten Version zu befinden, kann Ihr Rollbackversuch rückgängig machen. Es wird empfohlen, dass Sie sich im Vorschaukanal befinden, um dieses Feature zu testen.

Wie kann ich Rollback ausführen?

Sie sollten "Rollback zu früherer Version" auf der Dropdownschaltfläche "Mehr" auf einer Produktkarte nach einem Update sehen. 

RollbackHow

Von dort aus wird ein Warn-Popup angezeigt, und Sie haben die Möglichkeit, entweder abzubrechen oder fortzufahren.

RollbackWarning

Teilen Sie uns Ihre Gedanken mit!

Wir würden uns freuen, Ihr Feedback über das Rollback-Feature zu erhalten, also geben Sie es einen Versuch, und teilen Sie uns mit, was Sie denken. Sie können jedes Feedback teilen, indem Sie besuchen https://aka.ms/DeveloperCommunity-RollbackFeedback.

Das zweite neue Feature, das im Visual Studio-Installationsprogramm enthalten ist, ist die Möglichkeit, alle Komponenten zu entfernen, die zu einem Außer-Support-Zustand übergestellt wurden. Sowohl Entwickler als auch IT-Administratoren können diese Aktion aufrufen, um diese nicht unterstützten Komponenten zu deinstallieren, wodurch die Verwaltung einer sicheren und kompatiblen Umgebung erleichtert wird. Teil dieses Features wird in Vorschau 1 bereitgestellt, und der Rest wird online mit Preview 2 bereitgestellt. Weitere Details zur Vorschau finden Sie auf der Seite "RemoveOos preview details" und "Feedback ".

Git-Tools

  • Verbesserte Multi-Repository-Erfahrung umfasst konfigurierbare Einstellungen pro Repository, geöffneten Ordner und verbesserte Schnittstelle für Netzwerkvorgänge wie Fetch, Pull, Push und Sync

  • Erweiterte GitHub- und ADO-Integration, sodass Sie GitHub-Probleme und ADO-Arbeitselemente aus Ihren Commits in Visual Studio abfragen und darauf verweisen können

Verweisen auf GitHub-Probleme in Ihren Commits

.NET-Produktivität

  • Sie können nun die Struktur einer Datei ganz einfach auf einen Blick im Dokumentgliederungsfenster anzeigen. Das Dokumentgliederungsfenster zeigt die Symbolstruktur der Datei im Editor an, die Ihnen dabei hilft, schnell zu navigieren und Projektdateien zu bearbeiten. Sie können die Dokumentgliederung öffnen, indem Sie weitereWindows-Dokumentgliederungen>anzeigen> oder die Tastenkombination STRG+ALT+T verwenden.

Dokumentgliederung

Arm64
Diese Vorschau baut weiterhin unsere native Arm64-Unterstützung auf Windows 11 auf. Neben der Unterstützung der .NET-Desktopentwicklung (WinForms und WPF), der Desktopentwicklung mit C++ (für MSBuild-basierte Projekte) und ASP.NET und Webentwicklung haben wir nun die Universelle Windows-Plattform Entwicklungsauslastung aktiviert.

Weitere Informationen finden Sie in unserem Blogbeitrag.

F#

  • QuickInfos für lokale Funktionen zeigen jetzt Argumentnamen an.

QuickInfos für lokale Funktionsargumente

C++

  • Es wurde eine Option "Navigation nach der Erstellung von Deklaration/Definition" hinzugefügt, damit Sie das Navigationsverhalten des Features "Deklaration erstellen/Definition erstellen" auswählen können. Sie können zwischen der Vorschau (standard) oder dem Öffnen des Dokuments oder ohne Navigation auswählen.
  • Arm64-Builds von Visual Studio bündeln jetzt Arm64-Versionen von CMake und Ninja.
  • Unterstützung für CMake Presets Version 4 hinzugefügt. Weitere Informationen zu den verfügbaren Versionen finden Sie in den CMake-Versionshinweisen .
  • Die Verbindung mit Remotesystemen mit dem Verbindungs-Manager unterstützt jetzt SSH-ProxyJump, der verwendet wird, um über einen anderen SSH-Host auf einen SSH-Host zuzugreifen (z. B. um auf einen Host hinter einer Firewall zuzugreifen).
  • Sie können jetzt devcontainers für die plattformübergreifende C++-Entwicklung mit CMake verwenden. Fügen Sie einfach eine devcontainer.json-Datei in Ihr Projekt ein, genau wie sie mit Visual Studio Code verwendet werden sollen, um die Funktionalität zu aktivieren. Dies ist derzeit auf C++-Projekte beschränkt, die mit CMakeLists.txt und CMakePresets.json konfiguriert sind.
  • Es wurden Integrationen für vcpkg-Artefakte hinzugefügt. vcpkg activate wird im Hintergrund ausgeführt, wenn eine vcpkg-configuration.json Datei gefunden wird, und Umgebungsvariablen werden für die neue Umgebung geladen, wenn sie abgeschlossen ist.
  • Wir verfolgen weiterhin die neuesten Entwicklungen in der C++-Standardisierung, die Unterstützung für die folgenden C++ 23-Features ist verfügbar, indem wir /std:c++neueste in Ihren Compileroptionen einschließen.
    • P0849r8auto(x): decay-copy In der Sprache
      • Der Compilerteil ist noch nicht implementiert; Das Bibliotheksteil wurde im C++20-Modus implementiert, als Bereiche anfänglich implementiert wurden.
    • P0881R7<stacktrace>
    • P2301R1 Hinzufügen eines pmr Alias für std::stacktrace
    • P1328R1constexpr type_info::operator==()
    • P2440R1ranges::iota, , ranges::shift_leftranges::shift_right
    • P2441R2views::join_with

Codesuche und -navigation

Wir verbessern weiterhin die Leistung, Zuverlässigkeit und Barrierefreiheit der All-In-One-Suchumgebung (STRG+Q für die Funktionssuche, STRG+T für die Codesuche). Zusätzlich zu Dateien und Bildern funktionieren Vorschauen jetzt für C++-Typen und -Member.

Sie können "All-In-One-Suche" aktivieren: Tools > verwalten Vorschaufeatures > "Neue Visual Studio-Suchumgebung (Neustart erforderlich)".

Testtools

  • Live Unit Testing bietet jetzt eine Schaltfläche zum Zurücksetzen des gesamten Zustands. Indem Sie den Status "Live Unit Testing" > testen, wird der Status "Live Unit Testing > " für die Lösung zurückgesetzt. Status für Live-Komponententests
  • Live Unit Testing unterstützt jetzt Razor-Dateien.

Configuration

Heute haben wir die Vorschau der Visual Studio Administrative Vorlagendateien (ADMX/ADML) veröffentlicht. Jetzt ist es schwierig, dass IT-Administratoren feststellen können, welche globalen Richtlinien für Visual Studio vorhanden sind, und es ist genauso schwer, diese Richtlinien in häufig verwendete IT-Verwaltungsinfrastruktur und -tools zu integrieren und zu verwalten. Die Visual Studio-Verwaltungsvorlagendateien (ADMX/ADML) ermöglichen Administratoren das einfache Ermitteln, Verwalten und Steuern von Visual Studio-Verhaltensweisen, die verfügbar sind, die von der Richtlinie gesteuert werden können. Weitere Informationen finden Sie hier und geben Sie Feedback zu dieser Vorschau an.

Aus der Entwicklercommunity


Visual Studio im Dev Box

  • Da sich ein Dev Box nicht auf Ihrem lokalen Netzwerk befindet, müssen Sie eine öffentliche IP verwenden, um eine Verbindung über das Internet mit allen Macs in Ihrem lokalen Netzwerk herzustellen.
  • Wenn der Android-Emulator nicht geladen wird, stellen Sie sicher, dass Hyper-V über {Insert-Anweisungen hier} aktiviert ist. Wenn die Hyper-V-Option nicht deaktiviert wurde, aktivieren Sie sie, und starten Sie dann das Dev Box neu, bevor Sie versuchen, den Emulator zu verwenden.

Bekannte Probleme

Sehen Sie alle offenen Probleme und verfügbare Problemumgehungen in Visual Studio 2022, indem Sie den folgenden Links folgen.


Feedback und Vorschläge

Wir freuen uns auf Ihr Feedback! Sie können ein Problem melden oder ein Featurefeedbacksymbol vorschlagen, indem Sie das Symbol "Feedback senden" in der oberen rechten Ecke des Installers oder der Visual Studio IDE oder aus "Feedback > senden" verwenden. Sie können Ihre Probleme in der Entwicklercommunity für Visual Studio nachverfolgen, in der Sie Kommentare hinzufügen und Lösungen suchen können. Über unseren Livechatsupport erhalten Sie zudem kostenlose Hilfe bei der Installation.


Blogs

Profitieren Sie von den Einblicken und Empfehlungen auf der Webseite mit Blogs zu Entwicklertools, um sich bei allen Releases auf dem neuesten Stand zu halten und Zugang zu ausführlichen Beiträgen zu zahlreichen Funktionen zu erhalten.


Seitenanfang