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Visual Studio-Abonnements: Warum werden persönliche Konten für meine Abonnenten angezeigt?

Nachdem Unternehmen vom Volume Licensing Service Center (VLSC) auf das neue Visual Studio Subscriptions Admin Portal migriert haben, waren Administratoren überrascht, dass die „Sign-in Email Address“ für einige Abonnenten eine persönliche E-Mail-Adresse wie Hotmail oder Outlook anzeigt.

Ursache

Grund für dieses Szenario sind Anmeldeprozesse, die mit dem älteren MSDN-Abonnentenprozess verknüpft waren. Die Benutzer wurden ohne Änderungen vom Volume License Service Center (VLSC) zum Visual Studio Subscriptions Admin Portal migriert. Administrator*innen wissen möglicherweise nicht, dass Benutzer*innen persönliche Konten verwenden, um auf ihre Abonnementnutzen zuzugreifen. Vor der Migration der Visual Studio Subscriber, die 2016 abgeschlossen wurde, waren zwei Aktionen erforderlich, um eine Visual Studio Subscription erfolgreich zu nutzen:

  1. Der Administrator musste das Abonnement einem einzelnen Abonnenten unter Verwendung seiner Geschäfts-, Schul- oder Uni-E-Mail-Adresse „zuweisen“.
  2. Der Abonnent „aktivierte“ das Abonnement.

Während des Aktivierungsprozesses der Abonnenten war ein Microsoft-Konto (MSA) erforderlich, um sich anzumelden. Wenn der oder die Abonnent*in nicht versucht hat, sein oder ihr Geschäfts-, Schul- oder Unikonto (z. B. tasha@contoso.com) zu einem MSA zu machen, konnte er oder sie ein neues MSA erstellen oder ein vorhandenes nutzen. Die Verwendung einer persönlichen E-Mail führte dazu, dass die „Anmelde-E-Mail-Adresse“ nicht mit der „Zugewiesenen E-Mail-Adresse“ übereinstimmte

Hinweis

Der moderne Abonnentenprozess in https://my.visualstudio.com unterstützt sowohl Geschäfts-, Uni- und Schul- als auch Microsoft-Kontoidentitätstypen (MSA).

Lösung

Um das Problem zu beheben, wählen Sie die Schaltfläche E-Mails verbinden aus. Das System versucht, die Konten mit MSAs mit bestehenden Benutzern in der Microsoft Entra ID Ihrer Organisation abzugleichen, indem es den Vor- und Nachnamen abgleicht. Im Falle eines Fehlers können Sie Übereinstimmungen entfernen, indem Sie rechts neben der Übereinstimmung das X auswählen.

Sehen Sie sich dieses Video an, oder lesen Sie weiter, um mehr über die Behebung dieses Problems zu erfahren.

Schaltfläche „E-Mail-Adressen verknüpfen“

Sie können auch die Option Verzeichnis durchsuchen verwenden, um Fehler zu beheben oder fehlende Informationen aus Microsoft Entra ID einzufügen. Wenn die Übereinstimmungen korrekt aussehen, können Sie auf die Schaltfläche Current identity (Aktuelle Identität) klicken, um alle übereinstimmenden Einträge auf einmal anstatt einzeln auszuwählen.

Flyoutfenster „E-Mail-Adressen verknüpfen“

Wählen Sie Weiter. aus Daraufhin wird eine Liste der anstehenden Änderungen angezeigt. Wenn Sie mit den Änderungen einverstanden sind, können Sie Speichern auswählen, um die Änderungen zu implementieren. Ihre Abonnenten werden bei der nächsten Anmeldung bei ihrem Abonnement über die Änderung benachrichtigt. Beachten Sie, dass nur die beiden Abonnenten, die in Microsoft Entra ID übereinstimmen, in dieser Liste erscheinen. Da Frederick in unserem Beispiel über keine entsprechende Adresse in Microsoft Entra ID verfügte, wurde das Microsoft-Konto (Microsoft Account, MSA) keinem Geschäftskonto zugeordnet.

Hinweis

Wenn Sie die E-Mail-Adresse für die Anmeldung bearbeiten, wird nur die E-Mail-Adresse geändert, die der Abonnent für die Anmeldung beim Abonnement unter https://my.visualstudio.com verwendet. Wenn der Abonnent bereits Vorteile wie Azure oder Pluralsight mithilfe der anderen E-Mail-Adresse aktiviert hat, muss er diese E-Mail-Adresse weiterhin verwenden, um darauf zuzugreifen. Wenn Benutzer auf neue Vorteile zugreifen, sollten sie die neue E-Mail-Adresse verwenden.

Supportressourcen

Wenden Sie sich an den Support für Visual Studio-Abonnements, wenn Sie Hilfe bei der Verwaltung von Visual Studio-Abonnements benötigen.

Weitere Informationen

Nächste Schritte

  • Wenn Sie die E-Mail-Adressen der Abonnenten aktualisieren, sollten Sie ihnen mitteilen, dass sich ihre Anmeldedaten geändert haben. Sie erhalten eine E-Mail mit den aktualisierten Informationen.
  • Es könnte hilfreich sein, die Liste der Abonnenten in Ihrer Organisation zu filtern, um nach Anmelde-E-Mail-Adressen zu suchen, die möglicherweise geändert werden müssen.