Visual Studio-Abonnements: Warum werden persönliche Konten für meine Abonnenten angezeigt?
Nachdem Unternehmen vom Volume Licensing Service Center (VLSC) zum neuen Abonnementverwaltungsportal von Visual Studio migriert haben, stellen Administratoren möglicherweise fest, dass als „Anmelde-E-Mail-Adresse“ für manche Abonnenten eine persönliche E-Mail-Adresse wie Hotmail oder Yahoo angezeigt wird.
Ursache
Grund für dieses Szenario sind Anmeldeprozesse, die mit dem älteren MSDN-Abonnentenprozess verknüpft waren. Benutzer wurden ohne Änderungen aus dem Volume Licensing-Servicecenter (VLSC) zum Verwaltungsportal für Visual Studio-Abonnements migriert. Administrator*innen ist möglicherweise nicht bewusst, dass Benutzer*innen persönliche Konten verwenden, um auf ihre Abonnementvorteile zuzugreifen. Vor den Visual Studio-Abonnentenmigrationen, die 2016 abgeschlossen wurden, waren zur erfolgreichen Verwendung eines Visual Studio-Abonnements zwei Aktionen erforderlich:
- Der Administrator musste das Abonnement einem einzelnen Abonnenten unter Verwendung seiner Geschäfts-, Schul- oder Uni-E-Mail-Adresse „zuweisen“.
- Der Abonnent „aktivierte“ das Abonnement.
Während der Aktivierung des Abonnenten galt: Ein Microsoft-Konto (MSA) war zum Anmelden erforderlich. Wenn der oder die Abonnent*in nicht versucht hat, sein oder ihr Geschäfts-, Schul- oder Unikonto (z. B. tasha@contoso.com) zu einem MSA zu machen, konnte er oder sie ein neues MSA erstellen oder ein vorhandenes nutzen. Die Verwendung einer persönlichen E-Mail-Adresse führte dazu, dass die E-Mail-Adresse für die Anmeldung sich von der E-Mail-Adresse für die Zuweisung unterscheidet.
Hinweis
Der moderne Abonnentenprozess in https://my.visualstudio.com unterstützt sowohl Geschäfts-, Uni- und Schul- als auch Microsoft-Kontoidentitätstypen (MSA).
Lösung
Sie können das Problem beheben, indem Sie die Schaltfläche E-Mails verbinden auswählen. Das System versucht dann, die Konten mit MSAs den vorhandenen Benutzer*innen in der Azure AD-Instanz (Azure Active Directory) Ihrer Organisation anhand von Vor- und Nachname zuzuordnen. Im Falle eines Fehlers können Sie Übereinstimmungen entfernen, indem Sie rechts neben der Übereinstimmung das X auswählen.
Sehen Sie sich dieses Video an, oder lesen Sie weiter, um mehr über die Behebung dieses Problems zu erfahren.
Sie können auch die Option Verzeichnis durchsuchen nutzen, um Fehler zu beheben oder fehlende Informationen aus Azure AD einzufügen. Wenn die Übereinstimmungen korrekt aussehen, können Sie auf die Schaltfläche Current identity (Aktuelle Identität) klicken, um alle übereinstimmenden Einträge auf einmal anstatt einzeln auszuwählen.
Wählen Sie Weiter. aus Daraufhin wird eine Liste der anstehenden Änderungen angezeigt. Wenn Sie mit den Änderungen einverstanden sind, können Sie Speichern auswählen, um die Änderungen zu implementieren. Ihre Abonnenten werden bei der nächsten Anmeldung bei ihrem Abonnement über die Änderung benachrichtigt. Beachten Sie, dass nur die zwei Abonnenten, die in der Azure Active Directory-Instanz als übereinstimmend ermittelt wurden, in dieser Liste angezeigt werden. Da Frederick in diesem Beispiel über keine entsprechende Adresse in Azure AD verfügte, wurde das Microsoft-Konto (Microsoft Account, MSA) keinem Geschäftskonto zugeordnet.
Hinweis
Wenn Sie die E-Mail-Adresse für die Anmeldung bearbeiten, wird nur die E-Mail-Adresse geändert, die der Abonnent für die Anmeldung beim Abonnement unter https://my.visualstudio.com verwendet. Wenn der Abonnent bereits Vorteile wie Azure oder Pluralsight mithilfe der anderen E-Mail-Adresse aktiviert hat, muss er diese E-Mail-Adresse weiterhin verwenden, um darauf zuzugreifen. Wenn Benutzer auf neue Vorteile zugreifen, sollten sie die neue E-Mail-Adresse verwenden.
Supportressourcen
Wenden Sie sich an den Support für Visual Studio-Abonnements, wenn Sie Hilfe bei der Verwaltung von Visual Studio-Abonnements benötigen.
Weitere Informationen
- Dokumentation zu Visual Studio
- Dokumentation zu Azure DevOps Services
- Azure-Dokumentation
- Dokumentation zu Microsoft 365
Nächste Schritte
- Wenn Sie die E-Mail-Adressen der Abonnenten aktualisiert haben, sollten Sie ihnen mitteilen, dass ihre Anmeldeinformationen geändert wurden. Sie erhalten auch eine E-Mail mit den aktualisierten Informationen.
- Es kann hilfreich sein, die Liste der Abonnenten in Ihrer Organisation zu filtern, um nach Anmelde-E-Mail-Adressen zu suchen, die möglicherweise geändert werden müssen.